aboutsummaryrefslogtreecommitdiff
path: root/security/stunnel
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2010-04-16 12:49:44 +0000
committerPeter Pentchev <roam@FreeBSD.org>2010-04-16 12:49:44 +0000
commitc02cff316e40bcf67079320e56bc5740def9fd90 (patch)
tree753cd6427ea4d5b46d56f387e34090e362eb807b /security/stunnel
parent751273da692b767734c0d2ef3a54b117190740c0 (diff)
downloadports-c02cff316e40bcf67079320e56bc5740def9fd90.tar.gz
ports-c02cff316e40bcf67079320e56bc5740def9fd90.zip
Notes
Diffstat (limited to 'security/stunnel')
-rw-r--r--security/stunnel/Makefile2
-rw-r--r--security/stunnel/distinfo9
-rw-r--r--security/stunnel/files/patch-Makefile.in6
-rw-r--r--security/stunnel/files/patch-src::common.h4
-rw-r--r--security/stunnel/files/ssl-noengine.patch8
5 files changed, 13 insertions, 16 deletions
diff --git a/security/stunnel/Makefile b/security/stunnel/Makefile
index 96589d659e2d..2cd302156194 100644
--- a/security/stunnel/Makefile
+++ b/security/stunnel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= stunnel
-PORTVERSION= 4.29
+PORTVERSION= 4.33
CATEGORIES= security
MASTER_SITES= http://www.stunnel.org/download/stunnel/src/ \
ftp://stunnel.mirt.net/stunnel/ \
diff --git a/security/stunnel/distinfo b/security/stunnel/distinfo
index 35ffa036e205..228660c4ac24 100644
--- a/security/stunnel/distinfo
+++ b/security/stunnel/distinfo
@@ -1,6 +1,3 @@
-MD5 (stunnel-4.29.tar.gz) = 14dc3f8412947f0548975cbce74d6863
-SHA256 (stunnel-4.29.tar.gz) = 018064e852a2a125bcfb4b81baa77b5701ccf6aabe6a47564bfc046b18d11f9b
-SIZE (stunnel-4.29.tar.gz) = 544292
-MD5 (execargs.patch) = c893028f869f6d1f527373334605d639
-SHA256 (execargs.patch) = 88e682c0deee13d9768c8cbdd3e71f90dd26d92621d2e64542d5379a3939ac4c
-SIZE (execargs.patch) = 756
+MD5 (stunnel-4.33.tar.gz) = 559a864066d8cc4afd8a97682c90d41c
+SHA256 (stunnel-4.33.tar.gz) = 240763140000dea6ab76b30f5f5571a8ef4d22ba0712176a9c31c221bb9a48fc
+SIZE (stunnel-4.33.tar.gz) = 560103
diff --git a/security/stunnel/files/patch-Makefile.in b/security/stunnel/files/patch-Makefile.in
index 2a3cac1bfa5e..9efb5181dd8e 100644
--- a/security/stunnel/files/patch-Makefile.in
+++ b/security/stunnel/files/patch-Makefile.in
@@ -2,11 +2,11 @@ Description: Do not install the sample stunnel.pem file.
This is handled by the FreeBSD port's Makefile.
Forwarded: not-needed
Author: Peter Pentchev <roam@FreeBSD.org>
-Last-Update: 2009-11-13
+Last-Update: 2010-04-07
--- tools/Makefile.in.orig
+++ tools/Makefile.in
-@@ -339,7 +339,7 @@
+@@ -334,7 +334,7 @@
info-am:
@@ -14,4 +14,4 @@ Last-Update: 2009-11-13
+install-data-am: install-confDATA \
install-examplesDATA
- install-exec-am:
+ install-dvi: install-dvi-am
diff --git a/security/stunnel/files/patch-src::common.h b/security/stunnel/files/patch-src::common.h
index fb872c929110..d719c3734e2c 100644
--- a/security/stunnel/files/patch-src::common.h
+++ b/security/stunnel/files/patch-src::common.h
@@ -1,11 +1,11 @@
Description: Build on FreeBSD versions of OpenSSL < 0.9.8b.
Forwarded: not-needed
Author: Peter Pentchev <roam@FreeBSD.org>
-Last-Update: 2010-02-01
+Last-Update: 2010-04-07
--- src/common.h.orig
+++ src/common.h
-@@ -344,9 +344,6 @@
+@@ -350,9 +350,6 @@
#define OPENSSL_THREAD_DEFINES
#include <openssl/opensslconf.h>
diff --git a/security/stunnel/files/ssl-noengine.patch b/security/stunnel/files/ssl-noengine.patch
index 48c80828e4a0..d0fcddda2126 100644
--- a/security/stunnel/files/ssl-noengine.patch
+++ b/security/stunnel/files/ssl-noengine.patch
@@ -1,16 +1,16 @@
Description: Disable the OpenSSL engine support for the FreeBSD port.
Forwaded: not-needed
Author: Peter Pentchev <roam@FreeBSD.org>
-Last-Update: 2009-11-13
+Last-Update: 2010-04-07
--- src/ssl.c.orig
+++ src/ssl.c
-@@ -276,6 +276,8 @@
+@@ -288,6 +288,8 @@
}
- static void init_engine() {
+ static char *init_engine(void) {
+ s_log(LOG_ERR, "This version of stunnel was compiled WITHOUT support for OpenSSL hardware engines! If you need this functionality, rebuild the FreeBSD port with the WITH_STUNNEL_SSL_ENGINE option set to 'yes'; contact Peter Pentchev <roam@FreeBSD.org> for details.");
+ exit(1);
if(engine_initialized)
- return;
+ return NULL; /* OK */
engine_initialized=1;