aboutsummaryrefslogtreecommitdiff
path: root/security/stunnel
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2005-05-12 11:36:41 +0000
committerPeter Pentchev <roam@FreeBSD.org>2005-05-12 11:36:41 +0000
commitf06998a46e968baee5d849a2e1faea6c77a98c27 (patch)
tree45bef24145d5601c07e9839cd917f44adf86574e /security/stunnel
parent51e03f515b881a0bf007cf460149c8ee711acad5 (diff)
downloadports-f06998a46e968baee5d849a2e1faea6c77a98c27.tar.gz
ports-f06998a46e968baee5d849a2e1faea6c77a98c27.zip
Notes
Diffstat (limited to 'security/stunnel')
-rw-r--r--security/stunnel/Makefile2
-rw-r--r--security/stunnel/distinfo4
-rw-r--r--security/stunnel/files/patch-Makefile.in22
-rw-r--r--security/stunnel/files/patch-src::client.c17
-rw-r--r--security/stunnel/files/patch-src::network.c19
-rw-r--r--security/stunnel/files/stunnel.in2
-rw-r--r--security/stunnel/files/stunnel.sh2
7 files changed, 29 insertions, 39 deletions
diff --git a/security/stunnel/Makefile b/security/stunnel/Makefile
index 7330326347b9..69541c422f46 100644
--- a/security/stunnel/Makefile
+++ b/security/stunnel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= stunnel
-PORTVERSION= 4.07
+PORTVERSION= 4.10
CATEGORIES= security
MASTER_SITES= http://www.stunnel.org/download/stunnel/src/ \
ftp://stunnel.mirt.net/stunnel/OBSOLETE/ \
diff --git a/security/stunnel/distinfo b/security/stunnel/distinfo
index 50c938857b2d..b465790a2894 100644
--- a/security/stunnel/distinfo
+++ b/security/stunnel/distinfo
@@ -1,2 +1,2 @@
-MD5 (stunnel-4.07.tar.gz) = 7d53af550a1c2e01e146b936e58b8860
-SIZE (stunnel-4.07.tar.gz) = 486230
+MD5 (stunnel-4.10.tar.gz) = 9de7a62a44083114779ca4e109d70776
+SIZE (stunnel-4.10.tar.gz) = 487066
diff --git a/security/stunnel/files/patch-Makefile.in b/security/stunnel/files/patch-Makefile.in
index ecf842d628d1..9cf0627fd5c8 100644
--- a/security/stunnel/files/patch-Makefile.in
+++ b/security/stunnel/files/patch-Makefile.in
@@ -1,19 +1,11 @@
---- tools/Makefile.in.orig Mon Dec 27 13:52:12 2004
-+++ tools/Makefile.in Mon Dec 27 13:52:25 2004
-@@ -163,7 +163,7 @@
- stunnel.spec stunnel.mak stunnel.cnf
+--- tools/Makefile.in.orig Wed May 11 18:33:24 2005
++++ tools/Makefile.in Wed May 11 18:34:12 2005
+@@ -332,7 +332,7 @@
- confdir = $(sysconfdir)/stunnel
--conf_DATA = stunnel.conf-sample stunnel.pem
-+conf_DATA = stunnel.conf-sample
- docdir = $(datadir)/doc/stunnel
- examplesdir = $(docdir)/examples
- examples_DATA = ca.html ca.pl importCA.html importCA.sh script.sh \
-@@ -337,7 +337,6 @@
- install-data-am: install-confDATA install-data-local \
+ info-am:
+
+-install-data-am: install-confDATA install-data-local \
++install-data-am: install-confDATA \
install-examplesDATA
- @$(NORMAL_INSTALL)
-- $(MAKE) $(AM_MAKEFLAGS) install-data-hook
install-exec-am:
-
diff --git a/security/stunnel/files/patch-src::client.c b/security/stunnel/files/patch-src::client.c
new file mode 100644
index 000000000000..38f6f78bfb87
--- /dev/null
+++ b/security/stunnel/files/patch-src::client.c
@@ -0,0 +1,17 @@
+--- src/client.c.orig Thu May 12 14:01:28 2005
++++ src/client.c Thu May 12 14:04:19 2005
+@@ -841,6 +841,14 @@
+ sigemptyset(&newmask);
+ sigprocmask(SIG_SETMASK, &newmask, NULL);
+ #endif
++ if (c->opt->execargs != NULL && c->opt->execargs[0] == NULL) {
++ free(c->opt->execargs);
++ c->opt->execargs = NULL;
++ }
++ if (c->opt->execargs == NULL) {
++ c->opt->execargs = calloc(2, sizeof(c->opt->execargs[0]));
++ c->opt->execargs[0] = c->opt->execname;
++ }
+ execvp(c->opt->execname, c->opt->execargs);
+ ioerror(c->opt->execname); /* execv failed */
+ _exit(1);
diff --git a/security/stunnel/files/patch-src::network.c b/security/stunnel/files/patch-src::network.c
deleted file mode 100644
index dd41ae7f3d49..000000000000
--- a/security/stunnel/files/patch-src::network.c
+++ /dev/null
@@ -1,19 +0,0 @@
---- src/network.c.orig Mon Jan 3 09:16:45 2005
-+++ src/network.c Mon Jan 3 09:17:49 2005
-@@ -488,10 +488,13 @@
-
- char *s_ntop(char *text, SOCKADDR_UNION *addr) {
- char host[IPLEN-6], port[6];
-+ int err;
-
-- if(getnameinfo(&addr->sa, addr_len(*addr),
-- host, IPLEN-6, port, 6, NI_NUMERICHOST|NI_NUMERICSERV)) {
-- sockerror("getnameinfo");
-+ err = getnameinfo(&addr->sa, addr_len(*addr),
-+ host, IPLEN-6, port, 6, NI_NUMERICHOST|NI_NUMERICSERV);
-+ if (err) {
-+ s_log(LOG_ERR, "Error resolving the specified address: %s",
-+ s_gai_strerror(err));
- strcpy(text, "unresolvable IP");
- return text;
- }
diff --git a/security/stunnel/files/stunnel.in b/security/stunnel/files/stunnel.in
index d86bc5d630e0..f9a485fee264 100644
--- a/security/stunnel/files/stunnel.in
+++ b/security/stunnel/files/stunnel.in
@@ -26,7 +26,7 @@
name="stunnel"
rcvar=`set_rcvar`
stunnel_config="!!PREFIX!!/etc/stunnel/${name}.conf"
-stunnel_pidfile="!!PREFIX!!/var/stunnel/${name}.pid"
+stunnel_pidfile="/var/run/${name}.pid"
command="!!PREFIX!!/sbin/stunnel"
[ -z "$stunnel_enable" ] && stunnel_enable="NO"
diff --git a/security/stunnel/files/stunnel.sh b/security/stunnel/files/stunnel.sh
index d86bc5d630e0..f9a485fee264 100644
--- a/security/stunnel/files/stunnel.sh
+++ b/security/stunnel/files/stunnel.sh
@@ -26,7 +26,7 @@
name="stunnel"
rcvar=`set_rcvar`
stunnel_config="!!PREFIX!!/etc/stunnel/${name}.conf"
-stunnel_pidfile="!!PREFIX!!/var/stunnel/${name}.pid"
+stunnel_pidfile="/var/run/${name}.pid"
command="!!PREFIX!!/sbin/stunnel"
[ -z "$stunnel_enable" ] && stunnel_enable="NO"