aboutsummaryrefslogtreecommitdiff
path: root/security/sudo/Makefile
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2014-03-17 17:55:57 +0000
committerWesley Shields <wxs@FreeBSD.org>2014-03-17 17:55:57 +0000
commit42d597ff9434dc78e71641ae7f2267c9c4329a40 (patch)
treef664d66173ede539a578de6d7c4acce815e093f1 /security/sudo/Makefile
parent84460ddec91bb7dfcbcc9e2f08c534572a8a5128 (diff)
Notes
Diffstat (limited to 'security/sudo/Makefile')
-rw-r--r--security/sudo/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/security/sudo/Makefile b/security/sudo/Makefile
index 3065c6a2e4c6..f9c3b88f668d 100644
--- a/security/sudo/Makefile
+++ b/security/sudo/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= sudo
-DISTVERSION= 1.8.9p5
+DISTVERSION= 1.8.10p2
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SUDO}
@@ -88,5 +88,10 @@ post-patch:
post-install:
${INSTALL_DATA} ${FILESDIR}/pam.conf ${STAGEDIR}${PREFIX}/etc/pam.d/sudo.default
${TOUCH} ${STAGEDIR}${PREFIX}/etc/sudoers.d/.keep-me
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/sudoreplay
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/sbin/visudo
+.for f in group_file.so sudoers.so system_group.so
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/libexec/sudo/${f}
+.endfor
.include <bsd.port.mk>