aboutsummaryrefslogtreecommitdiff
path: root/security/sudo/Makefile
diff options
context:
space:
mode:
authorMichael Haro <mharo@FreeBSD.org>1999-12-22 17:53:40 +0000
committerMichael Haro <mharo@FreeBSD.org>1999-12-22 17:53:40 +0000
commit9e2a601197ed4852f185a73cfa28d5c49f2e7226 (patch)
tree9683418f312ef848ba7aba9d3b04b9d104579c23 /security/sudo/Makefile
parent157e05f118fff6c8381eac776ca58db2fdad4433 (diff)
downloadports-9e2a601197ed4852f185a73cfa28d5c49f2e7226.tar.gz
ports-9e2a601197ed4852f185a73cfa28d5c49f2e7226.zip
Notes
Diffstat (limited to 'security/sudo/Makefile')
-rw-r--r--security/sudo/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/security/sudo/Makefile b/security/sudo/Makefile
index 877ff8393191..9d7c7190f456 100644
--- a/security/sudo/Makefile
+++ b/security/sudo/Makefile
@@ -1,21 +1,21 @@
# New ports collection makefile for: sudo
-# Version required: 1.6
+# Version required: 1.6.1
# Date created: Sun Aug 13 12:36:14 CDT 1995
# Whom: erich@rrnet.com
#
# $FreeBSD$
#
-DISTNAME= sudo-1.6
+DISTNAME= sudo-1.6.1
CATEGORIES= security
-MASTER_SITES= ftp://ftp.cs.colorado.edu/pub/sysadmin/sudo/OLD/
+MASTER_SITES= ftp://ftp.cs.colorado.edu/pub/sysadmin/sudo/
MAINTAINER= mharo@FreeBSD.org
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-skey \
- --sysconfdir=/usr/local/etc \
+ --sysconfdir=${PREFIX}/etc \
--disable-log-wrap \
--with-ignore-dot \
--with-tty-tickets \
@@ -25,6 +25,9 @@ CONFIGURE_ARGS= --with-skey \
MAN5= sudoers.5
MAN8= sudo.8 visudo.8
+post-patch:
+ perl -i -pe 's,!!PREFIX!!,${PREFIX},g' ${WRKSRC}/*.man
+
post-install:
${INSTALL_DATA} ${WRKSRC}/sample.sudoers ${PREFIX}/etc/sudoers.sample