aboutsummaryrefslogtreecommitdiff
path: root/security/sudo/files
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2010-08-16 02:16:26 +0000
committerWesley Shields <wxs@FreeBSD.org>2010-08-16 02:16:26 +0000
commit09077111fca0d6553e5368958a1d881e7fc4b932 (patch)
tree5d33bfffa6420ede4336f3e2f8971924735376f1 /security/sudo/files
parent587fcc73b8e2e25a71fe5c853e8c63d5f7576e68 (diff)
downloadports-09077111fca0d6553e5368958a1d881e7fc4b932.tar.gz
ports-09077111fca0d6553e5368958a1d881e7fc4b932.zip
Notes
Diffstat (limited to 'security/sudo/files')
-rw-r--r--security/sudo/files/patch-Makefile.in15
-rw-r--r--security/sudo/files/patch-sudoers33
2 files changed, 32 insertions, 16 deletions
diff --git a/security/sudo/files/patch-Makefile.in b/security/sudo/files/patch-Makefile.in
new file mode 100644
index 000000000000..b3bab6ba66c9
--- /dev/null
+++ b/security/sudo/files/patch-Makefile.in
@@ -0,0 +1,15 @@
+--- ./Makefile.in.orig 2010-07-30 11:58:54.000000000 -0400
++++ ./Makefile.in 2010-08-15 21:33:54.000000000 -0400
+@@ -493,11 +493,9 @@
+ if [ -f .libs/lib$(noexecfile) ]; then $(INSTALL) -b~ -O $(install_uid) -G $(install_gid) -M 0755 .libs/lib$(noexecfile) $(DESTDIR)$(noexecdir)/$(noexecfile); fi
+
+ install-sudoers: install-dirs
+- $(INSTALL) -d -O $(sudoers_uid) -G $(sudoers_gid) -M 0750 \
+- $(DESTDIR)$(sudoersdir)/sudoers.d
+ test -f $(DESTDIR)$(sudoersdir)/sudoers || \
+ $(INSTALL) -O $(sudoers_uid) -G $(sudoers_gid) -M $(sudoers_mode) \
+- $(srcdir)/sudoers $(DESTDIR)$(sudoersdir)/sudoers
++ $(srcdir)/sudoers $(DESTDIR)$(sudoersdir)/sudoers.sample
+
+ install-doc: install-dirs ChangeLog
+ (cd $(srcdir) && for f in ChangeLog HISTORY LICENSE NEWS README TROUBLESHOOTING UPGRADE sample.*; do $(INSTALL) -O $(install_uid) -G $(install_gid) -M 0444 $$f $(DESTDIR)$(docdir); done)
diff --git a/security/sudo/files/patch-sudoers b/security/sudo/files/patch-sudoers
index 0183f396f043..dc95d16d3733 100644
--- a/security/sudo/files/patch-sudoers
+++ b/security/sudo/files/patch-sudoers
@@ -1,16 +1,17 @@
---- sudoers.orig 2008-01-15 22:18:17.000000000 +0000
-+++ sudoers 2008-10-11 20:36:46.928244000 +0000
-@@ -14,6 +14,13 @@
- # Cmnd alias specification
-
- # Defaults specification
-+# Uncomment if needed to preserve environmental variables related to the
-+# FreeBSD pkg_* utilities and fetch.
-+#Defaults env_keep += "PKG_PATH PKG_DBDIR PKG_TMPDIR TMPDIR PACKAGEROOT PACKAGESITE PKGDIR FTP_PASSIVE_MODE"
-+
-+# Additionally uncomment if needed to preserve environmental variables
-+# related to portupgrade.
-+#Defaults env_keep += "PORTSDIR PORTS_INDEX PORTS_DBDIR PACKAGES PKGTOOLS_CONF"
-
- # Runas alias specification
-
+--- ./sudoers.orig 2010-07-30 11:58:54.000000000 -0400
++++ ./sudoers 2010-08-15 21:31:54.000000000 -0400
+@@ -31,6 +31,14 @@
+ ##
+ ## Defaults specification
+ ##
++## Uncomment if needed to preserve environmental variables related to the
++## FreeBSD pkg_* utilities and fetch.
++# Defaults env_keep += "PKG_PATH PKG_DBDIR PKG_TMPDIR TMPDIR PACKAGEROOT PACKAGESITE PKGDIR FTP_PASSIVE_MODE"
++##
++## Additionally uncomment if needed to preserve environmental variables
++## related to portupgrade
++# Defaults env_keep += "PORTSDIR PORTS_INDEX PORTS_DBDIR PACKAGES PKGTOOLS_CONF"
++##
+ ## You may wish to keep some of the following environment variables
+ ## when running commands via sudo.
+ ##