aboutsummaryrefslogtreecommitdiff
path: root/security/sudo
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2010-08-16 13:06:02 +0000
committerWesley Shields <wxs@FreeBSD.org>2010-08-16 13:06:02 +0000
commitfd5d554e160bd632981bd0eb200893c4bef4de8a (patch)
tree7213e827334c45fb474bb27d09e4b2007b5f15f8 /security/sudo
parentb35856bf03b9c1708c9984c1a92261974888a8c9 (diff)
Notes
Diffstat (limited to 'security/sudo')
-rw-r--r--security/sudo/Makefile1
-rw-r--r--security/sudo/files/patch-Makefile.in11
-rw-r--r--security/sudo/pkg-install15
3 files changed, 7 insertions, 20 deletions
diff --git a/security/sudo/Makefile b/security/sudo/Makefile
index b206dee73924..b4fea318f602 100644
--- a/security/sudo/Makefile
+++ b/security/sudo/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sudo
PORTVERSION= 1.7.4.2
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://www.sudo.ws/sudo/dist/ \
ftp://obsd.isc.org/pub/sudo/ \
diff --git a/security/sudo/files/patch-Makefile.in b/security/sudo/files/patch-Makefile.in
index b3bab6ba66c9..3366efdc21d1 100644
--- a/security/sudo/files/patch-Makefile.in
+++ b/security/sudo/files/patch-Makefile.in
@@ -1,14 +1,15 @@
---- ./Makefile.in.orig 2010-07-30 11:58:54.000000000 -0400
-+++ ./Makefile.in 2010-08-15 21:33:54.000000000 -0400
-@@ -493,11 +493,9 @@
+--- Makefile.in.orig 2010-07-30 17:58:54.000000000 +0200
++++ Makefile.in 2010-08-16 10:21:01.000000000 +0200
+@@ -493,11 +493,8 @@
if [ -f .libs/lib$(noexecfile) ]; then $(INSTALL) -b~ -O $(install_uid) -G $(install_gid) -M 0755 .libs/lib$(noexecfile) $(DESTDIR)$(noexecdir)/$(noexecfile); fi
install-sudoers: install-dirs
- $(INSTALL) -d -O $(sudoers_uid) -G $(sudoers_gid) -M 0750 \
- $(DESTDIR)$(sudoersdir)/sudoers.d
- test -f $(DESTDIR)$(sudoersdir)/sudoers || \
- $(INSTALL) -O $(sudoers_uid) -G $(sudoers_gid) -M $(sudoers_mode) \
+- test -f $(DESTDIR)$(sudoersdir)/sudoers || \
+- $(INSTALL) -O $(sudoers_uid) -G $(sudoers_gid) -M $(sudoers_mode) \
- $(srcdir)/sudoers $(DESTDIR)$(sudoersdir)/sudoers
++ $(INSTALL) -O $(sudoers_uid) -G $(sudoers_gid) -M $(sudoers_mode) \
+ $(srcdir)/sudoers $(DESTDIR)$(sudoersdir)/sudoers.sample
install-doc: install-dirs ChangeLog
diff --git a/security/sudo/pkg-install b/security/sudo/pkg-install
deleted file mode 100644
index 9e312f8f7a63..000000000000
--- a/security/sudo/pkg-install
+++ /dev/null
@@ -1,15 +0,0 @@
-#!/bin/sh
-if [ $2 != "POST-INSTALL" ]; then
- exit 0
-fi
-if [ -e ${PKG_PREFIX}/etc/sudoers ]; then
- echo "Will not overwrite existing ${PKG_PREFIX}/etc/sudoers file."
-else
- cp -p ${PKG_PREFIX}/etc/sudoers.default ${PKG_PREFIX}/etc/sudoers
- chmod 440 ${PKG_PREFIX}/etc/sudoers
-fi
-if [ -e ${PKG_PREFIX}/etc/pam.d/sudo ]; then
- echo "Will not overwrite existing ${PKG_PREFIX}/etc/pam.d/sudo file."
-else
- cp -p ${PKG_PREFIX}/etc/pam.d/sudo.default ${PKG_PREFIX}/etc/pam.d/sudo
-fi