aboutsummaryrefslogtreecommitdiff
path: root/security/sudo
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2012-09-27 13:44:01 +0000
committerWesley Shields <wxs@FreeBSD.org>2012-09-27 13:44:01 +0000
commitc53371256db30ae522c60302ff42aa2a2597af5a (patch)
tree14aeacbe6192f92d7720c1dddf0fc163b8b6fbf8 /security/sudo
parent1c7b6f75e90884d56d2d789575b5e9cea2e35a3e (diff)
Notes
Diffstat (limited to 'security/sudo')
-rw-r--r--security/sudo/Makefile12
1 files changed, 3 insertions, 9 deletions
diff --git a/security/sudo/Makefile b/security/sudo/Makefile
index fb4df6a664f6..d5fd8a2b1f5d 100644
--- a/security/sudo/Makefile
+++ b/security/sudo/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sudo
DISTVERSION= 1.8.6p3
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SUDO}
@@ -21,6 +22,7 @@ LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
MAKE_JOBS_SAFE= yes
GNU_CONFIGURE= yes
LDFLAGS+= -lgcc
+LDFLAGS+= -lssp_nonshared
CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc \
--with-ignore-dot \
@@ -99,14 +101,6 @@ CONFIGURE_ARGS+=--with-bsm-audit
CONFIGURE_ARGS+=--with-opie
.endif
-.include <bsd.port.pre.mk>
-
-# Temporary workaround until I can figure out why the build fails on i386.
-# You can add --stack-protector to LDFLAGS but that doesn't work with clang.
-.if ${ARCH} == "i386"
-CONFIGURE_ARGS+= --disable-hardening
-.endif
-
MAN5+= sudoers.5
MAN8= sudo.8 visudo.8 sudoreplay.8 sudo_plugin.8
MLINKS= sudo.8 sudoedit.8
@@ -134,4 +128,4 @@ post-install:
fi
${TOUCH} ${PREFIX}/etc/sudoers.d/.keep-me
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>