aboutsummaryrefslogtreecommitdiff
path: root/security/sudo
diff options
context:
space:
mode:
authorTom McLaughlin <tmclaugh@FreeBSD.org>2007-07-21 03:15:13 +0000
committerTom McLaughlin <tmclaugh@FreeBSD.org>2007-07-21 03:15:13 +0000
commitff833c5c46a0d90eb241b6017822109fe7bacf86 (patch)
tree1c0b74fa93557114f7d41d9ad4e8f31d3a915733 /security/sudo
parent17d1a0c169d5d3553bcf3bff681a30007729ae6a (diff)
downloadports-ff833c5c46a0d90eb241b6017822109fe7bacf86.tar.gz
ports-ff833c5c46a0d90eb241b6017822109fe7bacf86.zip
Notes
Diffstat (limited to 'security/sudo')
-rw-r--r--security/sudo/Makefile39
-rw-r--r--security/sudo/distinfo6
-rw-r--r--security/sudo/pkg-descr7
-rw-r--r--security/sudo/pkg-install5
-rw-r--r--security/sudo/pkg-plist13
5 files changed, 47 insertions, 23 deletions
diff --git a/security/sudo/Makefile b/security/sudo/Makefile
index 6c98bab21744..8c68fea3dd0d 100644
--- a/security/sudo/Makefile
+++ b/security/sudo/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= sudo
-PORTVERSION= 1.6.8.12
-PORTREVISION= 2
+PORTVERSION= 1.6.9
CATEGORIES= security
MASTER_SITES= http://www.sudo.ws/sudo/dist/ \
http://probsd.org/sudoftp/ \
@@ -19,7 +18,6 @@ MASTER_SITES= http://www.sudo.ws/sudo/dist/ \
http://pluto.cdpa.nsysu.edu.tw/sudo/ \
ftp://ftp.cs.colorado.edu/pub/sysadmin/sudo/ \
ftp://ftp.stikman.com/pub/sudo/
-DISTNAME= ${PORTNAME}-1.6.8p12
MAINTAINER= ports@FreeBSD.org
COMMENT= Allow others to run commands as root
@@ -36,7 +34,6 @@ CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc \
--with-pam
OPTIONS= LDAP "With LDAP support" off \
- OPIE "With OPIE support" off \
INSULTS "With all insults" off \
SHELL_SETS_HOME "Set HOME env to target user in shell mode" off
@@ -51,12 +48,9 @@ CONFIGURE_ARGS+=--with-all-insults
USE_OPENLDAP=yes
CONFIGURE_ARGS+=--with-ldap=${PREFIX}
CONFIGURE_ARGS+=--with-ldap-conf-file=${PREFIX}/etc/ldap.conf
-.endif
-
-.if defined(WITH_OPIE) || ${OSVERSION} > 500021
-CONFIGURE_ARGS+=--with-opie
+PLIST_SUB+= LDAP=""
.else
-CONFIGURE_ARGS+=--with-skey
+PLIST_SUB= LDAP="@comment "
.endif
.if defined(WITH_SHELL_SETS_HOME)
@@ -67,13 +61,28 @@ MAN5= sudoers.5
MAN8= sudo.8 visudo.8
MLINKS= sudo.8 sudoedit.8
-post-patch:
- @${REINPLACE_CMD} -e 's|^|#|g' ${WRKSRC}/sample.sudoers
-
post-install:
- ${INSTALL_DATA} ${WRKSRC}/sample.sudoers ${PREFIX}/etc/sudoers.sample
- ${INSTALL_DATA} ${WRKSRC}/sudoers ${PREFIX}/etc/sudoers.default
${RM} ${PREFIX}/libexec/sudo_noexec.la
- ${INSTALL_DATA} ${FILESDIR}/pam.conf ${PREFIX}/etc/pam.d/sudo
+ ${INSTALL_DATA} ${WRKSRC}/sudoers ${PREFIX}/etc/sudoers.default
+ ${INSTALL_DATA} ${FILESDIR}/pam.conf ${PREFIX}/etc/pam.d/sudo.default
+
+ if [ ! -e ${PREFIX}/etc/pam.d/sudo ]; then \
+ cp -p ${PREFIX}/etc/pam.d/sudo.default \
+ ${PREFIX}/etc/pam.d/sudo ;\
+ fi
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/BUGS ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/CHANGES ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/TROUBLESHOOTING ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/UPGRADE ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/sample.sudoers ${DOCSDIR}
+.if defined(WITH_LDAP)
+ ${INSTALL_DATA} ${WRKSRC}/README.LDAP ${DOCSDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/sudoers2ldif ${DOCSDIR}
+.endif
+.endif
.include <bsd.port.post.mk>
diff --git a/security/sudo/distinfo b/security/sudo/distinfo
index 807d3e80b155..47d22014ded3 100644
--- a/security/sudo/distinfo
+++ b/security/sudo/distinfo
@@ -1,3 +1,3 @@
-MD5 (sudo-1.6.8p12.tar.gz) = b29893c06192df6230dd5f340f3badf5
-SHA256 (sudo-1.6.8p12.tar.gz) = 56f7d86032538a4a98d90af3742903a09ba16d6db82b593e4a47605f87fa581a
-SIZE (sudo-1.6.8p12.tar.gz) = 585643
+MD5 (sudo-1.6.9.tar.gz) = 7eeb0d89a7c358012377c8d150581cd7
+SHA256 (sudo-1.6.9.tar.gz) = 7c657029eaebe5dfa3617e47fcb90c1ed8a5eddebc48b8efeb85c88ee647787f
+SIZE (sudo-1.6.9.tar.gz) = 557692
diff --git a/security/sudo/pkg-descr b/security/sudo/pkg-descr
index c7e549dc2917..c249b8bcb4c1 100644
--- a/security/sudo/pkg-descr
+++ b/security/sudo/pkg-descr
@@ -1,8 +1,9 @@
This is the CU version of sudo.
-Sudo is a program designed to allow a sysadmin to give limited root privileges
-to users and log root activity. The basic philosophy is to give as few
-privileges as possible but still allow people to get their work done.
+Sudo is a program designed to allow a sysadmin to give limited root
+privileges to users and log root activity. The basic philosophy is to
+give as few privileges as possible but still allow people to get their
+work done.
MAILING LISTS:
diff --git a/security/sudo/pkg-install b/security/sudo/pkg-install
index 8848ddc2e5a0..9e312f8f7a63 100644
--- a/security/sudo/pkg-install
+++ b/security/sudo/pkg-install
@@ -8,3 +8,8 @@ else
cp -p ${PKG_PREFIX}/etc/sudoers.default ${PKG_PREFIX}/etc/sudoers
chmod 440 ${PKG_PREFIX}/etc/sudoers
fi
+if [ -e ${PKG_PREFIX}/etc/pam.d/sudo ]; then
+ echo "Will not overwrite existing ${PKG_PREFIX}/etc/pam.d/sudo file."
+else
+ cp -p ${PKG_PREFIX}/etc/pam.d/sudo.default ${PKG_PREFIX}/etc/pam.d/sudo
+fi
diff --git a/security/sudo/pkg-plist b/security/sudo/pkg-plist
index 9b5a215bd1a3..994fc14a5635 100644
--- a/security/sudo/pkg-plist
+++ b/security/sudo/pkg-plist
@@ -1,8 +1,17 @@
@unexec if cmp -s %D/etc/sudoers %D/etc/sudoers.default; then rm -f %D/etc/sudoers; fi
+@unexec if cmp -s %D/etc/pam.d/sudo %D/etc/pam.d/sudo.default; then rm -f %D/etc/pam.d/sudo; fi
bin/sudo
bin/sudoedit
-etc/pam.d/sudo
+etc/pam.d/sudo.default
etc/sudoers.default
-etc/sudoers.sample
libexec/sudo_noexec.so
sbin/visudo
+%%PORTDOCS%%%%DOCSDIR%%/BUGS
+%%PORTDOCS%%%%DOCSDIR%%/CHANGES
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/TROUBLESHOOTING
+%%PORTDOCS%%%%DOCSDIR%%/UPGRADE
+%%PORTDOCS%%%%DOCSDIR%%/sample.sudoers
+%%LDAP%%%%PORTDOCS%%%%DOCSDIR%%/README.LDAP
+%%LDAP%%%%PORTDOCS%%%%DOCSDIR%%/sudoers2ldif
+%%PORTDOCS%%@dirrm %%DOCSDIR%%