aboutsummaryrefslogtreecommitdiff
path: root/security/sudo
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2020-06-19 14:22:34 +0000
committerRenato Botelho <garga@FreeBSD.org>2020-06-19 14:22:34 +0000
commit01d2e83ad61faa5b0b1b472419f8d39aff4b1c16 (patch)
tree051cec49b2a882d00678a560141f66d74b86f8a3 /security/sudo
parent83635bf0fe8bdacce53c6217119313bf48ab3df0 (diff)
downloadports-01d2e83ad61faa5b0b1b472419f8d39aff4b1c16.tar.gz
ports-01d2e83ad61faa5b0b1b472419f8d39aff4b1c16.zip
Notes
Diffstat (limited to 'security/sudo')
-rw-r--r--security/sudo/Makefile16
-rw-r--r--security/sudo/distinfo6
-rw-r--r--security/sudo/pkg-plist24
3 files changed, 39 insertions, 7 deletions
diff --git a/security/sudo/Makefile b/security/sudo/Makefile
index 2f29f69f8368..5e4e857affab 100644
--- a/security/sudo/Makefile
+++ b/security/sudo/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= sudo
-PORTVERSION= 1.8.31p1
+PORTVERSION= 1.9.1
CATEGORIES= security
MASTER_SITES= SUDO
@@ -29,7 +29,7 @@ CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc \
--with-rundir=/var/run/sudo
OPTIONS_DEFINE= LDAP INSULTS DISABLE_ROOT_SUDO DISABLE_AUTH NOARGS_SHELL \
- AUDIT OPIE PAM NLS SSSD DOCS EXAMPLES
+ AUDIT OPIE PAM PYTHON NLS SSSD DOCS EXAMPLES
OPTIONS_RADIO= KERBEROS
OPTIONS_DEFAULT= AUDIT PAM
OPTIONS_SUB= yes
@@ -41,6 +41,7 @@ NOARGS_SHELL_DESC= Run a shell if no arguments are given
AUDIT_DESC= Enable BSM audit support
KERBEROS_DESC= Enable Kerberos 5 authentication (no PAM support)
OPIE_DESC= Enable one-time passwords (no PAM support)
+PYTHON_DESC= Enable python plugin support
SSSD_DESC= Enable SSSD backend support.
PAM_PREVENTS= OPIE GSSAPI_BASE GSSAPI_HEIMDAL GSSAPI_MIT
@@ -75,6 +76,8 @@ NOARGS_SHELL_CONFIGURE_ENABLE= noargs-shell
AUDIT_CONFIGURE_WITH= bsm-audit
PAM_CONFIGURE_ON= --with-pam
OPIE_CONFIGURE_ON= --with-opie
+PYTHON_USES= python
+PYTHON_CONFIGURE_ENABLE= python
SSSD_CONFIGURE_ON= --with-sssd
SSSD_RUN_DEPENDS= sssd:security/sssd
@@ -107,12 +110,19 @@ post-patch:
post-install:
${INSTALL_DATA} ${FILESDIR}/pam.conf ${STAGEDIR}${PREFIX}/etc/pam.d/sudo.default
+ ${MV} ${STAGEDIR}${PREFIX}/etc/sudo.conf ${STAGEDIR}${PREFIX}/etc/sudo.conf.sample
+ ${MV} ${STAGEDIR}${PREFIX}/etc/sudo_logsrvd.conf ${STAGEDIR}${PREFIX}/etc/sudo_logsrvd.conf.sample
${RM} ${STAGEDIR}${PREFIX}/etc/sudoers
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/cvtsudoers
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/sudoreplay
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/sbin/sudo_logsrvd
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/sbin/sudo_sendlog
${STRIP_CMD} ${STAGEDIR}${PREFIX}/sbin/visudo
-.for f in group_file.so libsudo_util.so sudoers.so system_group.so
+.for f in audit_json.so group_file.so libsudo_util.so sample_approval.so sudoers.so system_group.so
${STRIP_CMD} ${STAGEDIR}${PREFIX}/libexec/sudo/${f}
.endfor
+post-install-PYTHON-on:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/libexec/sudo/python_plugin.so
+
.include <bsd.port.mk>
diff --git a/security/sudo/distinfo b/security/sudo/distinfo
index fa8372abb3dd..f7500ab3b399 100644
--- a/security/sudo/distinfo
+++ b/security/sudo/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1584533326
-SHA256 (sudo-1.8.31p1.tar.gz) = c73cfdfbc1c5cc259fcc3a355e1bacfed99c5580daeadec9704a24cd5e6d15d8
-SIZE (sudo-1.8.31p1.tar.gz) = 3351312
+TIMESTAMP = 1592528955
+SHA256 (sudo-1.9.1.tar.gz) = 294116cefe10a02773917fc7440d8384b925955bc96a6e0eaa1977c83b34adff
+SIZE (sudo-1.9.1.tar.gz) = 3834744
diff --git a/security/sudo/pkg-plist b/security/sudo/pkg-plist
index 0987b7819be0..1171250086b4 100644
--- a/security/sudo/pkg-plist
+++ b/security/sudo/pkg-plist
@@ -2,27 +2,39 @@ bin/cvtsudoers
bin/sudo
bin/sudoedit
bin/sudoreplay
-@sample etc/sudoers.dist etc/sudoers
@sample etc/pam.d/sudo.default etc/pam.d/sudo
+@sample etc/sudo.conf.sample
+@sample etc/sudo_logsrvd.conf.sample
+@sample etc/sudoers.dist etc/sudoers
include/sudo_plugin.h
+libexec/sudo/audit_json.so
libexec/sudo/group_file.so
libexec/sudo/libsudo_util.so
libexec/sudo/libsudo_util.so.0
libexec/sudo/libsudo_util.so.0.0.0
+%%PYTHON%%libexec/sudo/python_plugin.so
+libexec/sudo/sample_approval.so
libexec/sudo/sudo_noexec.so
libexec/sudo/sudoers.so
libexec/sudo/system_group.so
man/man1/cvtsudoers.1.gz
man/man5/sudo.conf.5.gz
+man/man5/sudo_logsrv.proto.5.gz
+man/man5/sudo_logsrvd.conf.5.gz
man/man5/sudoers.5.gz
man/man5/sudoers_timestamp.5.gz
%%LDAP%%man/man5/sudoers.ldap.5.gz
man/man8/sudo.8.gz
+man/man8/sudo_logsrvd.8.gz
man/man8/sudo_plugin.8.gz
+man/man8/sudo_plugin_python.8.gz
+man/man8/sudo_sendlog.8.gz
man/man8/sudoedit.8.gz
man/man8/sudoreplay.8.gz
man/man8/visudo.8.gz
sbin/visudo
+sbin/sudo_logsrvd
+sbin/sudo_sendlog
%%PORTDOCS%%%%DOCSDIR%%/CONTRIBUTORS
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
%%PORTDOCS%%%%DOCSDIR%%/HISTORY
@@ -38,8 +50,16 @@ sbin/visudo
%%LDAP%%%%PORTDOCS%%%%DOCSDIR%%/schema.olcSudo
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pam.conf
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sudo.conf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sudo_logsrvd.conf
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sudoers
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/syslog.conf
+%%PYTHON%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example_approval_plugin.py
+%%PYTHON%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example_audit_plugin.py
+%%PYTHON%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example_conversation.py
+%%PYTHON%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example_debugging.py
+%%PYTHON%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example_group_plugin.py
+%%PYTHON%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example_io_plugin.py
+%%PYTHON%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example_policy_plugin.py
%%NLS%%share/locale/ast/LC_MESSAGES/sudo.mo
%%NLS%%share/locale/ast/LC_MESSAGES/sudoers.mo
%%NLS%%share/locale/ca/LC_MESSAGES/sudo.mo
@@ -85,6 +105,8 @@ sbin/visudo
%%NLS%%share/locale/pt/LC_MESSAGES/sudoers.mo
%%NLS%%share/locale/pt_BR/LC_MESSAGES/sudo.mo
%%NLS%%share/locale/pt_BR/LC_MESSAGES/sudoers.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/sudo.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/sudoers.mo
%%NLS%%share/locale/ru/LC_MESSAGES/sudo.mo
%%NLS%%share/locale/ru/LC_MESSAGES/sudoers.mo
%%NLS%%share/locale/sk/LC_MESSAGES/sudo.mo