aboutsummaryrefslogtreecommitdiff
path: root/security/sudosh
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2007-01-05 03:30:02 +0000
committerCy Schubert <cy@FreeBSD.org>2007-01-05 03:30:02 +0000
commita686bbe427e141c11516092d3cc7b30c7ad78393 (patch)
tree414cdf9535944a48d5cb8f52ffc75ccefbf10926 /security/sudosh
parent9fc08733821c5115abdddac42810cff99dbbc7d1 (diff)
downloadports-a686bbe427e141c11516092d3cc7b30c7ad78393.tar.gz
ports-a686bbe427e141c11516092d3cc7b30c7ad78393.zip
Notes
Diffstat (limited to 'security/sudosh')
-rw-r--r--security/sudosh/Makefile8
-rw-r--r--security/sudosh/files/patch-src::sudosh.c4
2 files changed, 3 insertions, 9 deletions
diff --git a/security/sudosh/Makefile b/security/sudosh/Makefile
index 84f8f32f0400..06ed10922bbd 100644
--- a/security/sudosh/Makefile
+++ b/security/sudosh/Makefile
@@ -34,10 +34,4 @@ MAN1= sudosh.1
MAN5= sudosh.conf.5
MAN8= sudosh-replay.8
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BROKEN= "Does not compile on FreeBSD 4.x"
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/sudosh/files/patch-src::sudosh.c b/security/sudosh/files/patch-src::sudosh.c
index 8e65ebccc460..7f6da6fe8f0e 100644
--- a/security/sudosh/files/patch-src::sudosh.c
+++ b/security/sudosh/files/patch-src::sudosh.c
@@ -44,7 +44,7 @@
+#endif
perror ("Cannot open cloning master pty");
return -1;
-+#ifdef __FreeBSD
++#ifndef __FreeBSD__
}
+#endif
}
@@ -54,7 +54,7 @@
(void) grantpt (p->mfd);
+#endif
-+#ifndef __FreeBSD
++#ifndef __FreeBSD__
sname = (char *) ptsname (p->mfd);
+#endif