aboutsummaryrefslogtreecommitdiff
path: root/security/super
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-07-07 19:07:44 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-07-07 19:07:44 +0000
commit4c898cd90bdb7e9779ea1b7c9667459ddda14604 (patch)
tree83e3f969452a3c01642cdcd1f00f15a8aff80adf /security/super
parent4f1d58f459f05b264332a3f8713c362128719331 (diff)
downloadports-4c898cd90bdb7e9779ea1b7c9667459ddda14604.tar.gz
ports-4c898cd90bdb7e9779ea1b7c9667459ddda14604.zip
Notes
Diffstat (limited to 'security/super')
-rw-r--r--security/super/Makefile28
-rw-r--r--security/super/pkg-plist6
2 files changed, 13 insertions, 21 deletions
diff --git a/security/super/Makefile b/security/super/Makefile
index 23dfa74da939..d01c2aa7c3b0 100644
--- a/security/super/Makefile
+++ b/security/super/Makefile
@@ -3,6 +3,7 @@
PORTNAME= super
PORTVERSION= 3.30.0
+PORTREVISION= 1
CATEGORIES= security sysutils
MASTER_SITES= ftp://ftp.ucolick.org/pub/users/will/ \
http://www.ucolick.org/~will/RUE/super/
@@ -16,30 +17,19 @@ LICENSE_COMB= dual
GNU_CONFIGURE= yes
-MAN1= super.1 setuid.1
-MAN5= super.5
-
-NO_STAGE= yes
-
OPTIONS_DEFINE= DOCS EXAMPLES
-.include <bsd.port.options.mk>
-
post-patch:
- @${REINPLACE_CMD} 's|\.\/mkdir_p -p755|mkdir -p -m 755|g' \
+ @${REINPLACE_CMD} -e 's|\.\/mkdir_p -p755|mkdir -p -m 755|g' \
+ -e '/sysconfdir/ s|super\.tab|&.sample|' \
${WRKSRC}/Makefile.in
post-install:
- @${STRIP_CMD} ${PREFIX}/bin/super ${PREFIX}/bin/setuid
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
-.endif
-.if ${PORT_OPTIONS:MEXAMPLES}
- @${MKDIR} ${DOCSDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${FILESDIR}/sample.tab ${EXAMPLESDIR}
- ${INSTALL_DATA} ${FILESDIR}/sample.cdmount ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/barebones.tab ${EXAMPLESDIR}
-.endif
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/super ${STAGEDIR}${PREFIX}/bin/setuid
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${FILESDIR}/sample.tab ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${FILESDIR}/sample.cdmount ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>
diff --git a/security/super/pkg-plist b/security/super/pkg-plist
index 094771b4d6ac..e643777b2c47 100644
--- a/security/super/pkg-plist
+++ b/security/super/pkg-plist
@@ -1,8 +1,10 @@
bin/setuid
bin/super
-%%PORTEXAMPLES%%@unexec if cmp -s %D/etc/super.tab %D/%%EXAMPLESDIR%%/barebones.tab; then rm -f %D/etc/super.tab; fi
+@sample etc/super.tab.sample
+man/man1/setuid.1.gz
+man/man1/super.1.gz
+man/man5/super.5.gz
%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/barebones.tab
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sample.cdmount
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sample.tab
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%