aboutsummaryrefslogtreecommitdiff
path: root/security/tea-total
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2002-10-27 23:15:10 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2002-10-27 23:15:10 +0000
commitf2b175a3491e68c67e5d498606785fff176f34ba (patch)
tree64a920aeff344f03b37ecb1d0cdb862653913774 /security/tea-total
parent24cee1bfb149e5b2a6bfe4c1aba37ebcb3ab2883 (diff)
downloadports-f2b175a3491e68c67e5d498606785fff176f34ba.tar.gz
ports-f2b175a3491e68c67e5d498606785fff176f34ba.zip
Notes
Diffstat (limited to 'security/tea-total')
-rw-r--r--security/tea-total/Makefile3
-rw-r--r--security/tea-total/files/patch-Makefile32
2 files changed, 28 insertions, 7 deletions
diff --git a/security/tea-total/Makefile b/security/tea-total/Makefile
index 001b4b1bf973..22f20f0834fd 100644
--- a/security/tea-total/Makefile
+++ b/security/tea-total/Makefile
@@ -7,9 +7,10 @@
PORTNAME= tea-total
PORTVERSION= 0.4
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= ftp://ftp.linuxhacker.org/pub/tea-total/ \
- http://www.linuxhacker.org/tea-total/
+ http://www.linuxhacker.org/pub/tea-total/
MAINTAINER= ports@FreeBSD.org
diff --git a/security/tea-total/files/patch-Makefile b/security/tea-total/files/patch-Makefile
index 9d773c203365..2d8a941a7a9f 100644
--- a/security/tea-total/files/patch-Makefile
+++ b/security/tea-total/files/patch-Makefile
@@ -1,20 +1,24 @@
---- Makefile.orig Tue Jan 2 05:04:34 2001
-+++ Makefile Fri Jan 12 02:18:24 2001
-@@ -1,5 +1,5 @@
+--- Makefile.orig Tue Jan 2 22:04:34 2001
++++ Makefile Fri Oct 25 03:32:00 2002
+@@ -1,6 +1,6 @@
include config.inc
-CC = $(CROSS_PREFIX)gcc
+#CC = $(CROSS_PREFIX)gcc
CP = cp -f
RM = rm -f
-@@ -9,5 +9,5 @@
+ LN = ln -sf
+@@ -8,7 +8,7 @@
+ CD = cd
MKDIR = mkdir -p
CMP = cmp
-CFLAGS = -O2 -Wall -DARCH_$(ARCH)
-+CFLAGS += -O2 -Wall -DARCH_$(ARCH)
++CFLAGS += -DARCH_$(ARCH)
LDFLAGS =
BINDIR = $(PREFIX)/bin
-@@ -27,4 +27,9 @@
+ TEATOTAL = teatotal
+@@ -26,6 +26,11 @@
+ ifeq ($(ARCH), OPENBSD)
MANDIR = $(PREFIX)/share/man/man1
RANDOM_DEVICE = \"/dev/srandom\"
+else
@@ -24,3 +28,19 @@
+endif
endif
endif
+
+@@ -115,12 +120,12 @@
+
+ install: all
+ $(MKDIR) $(BINDIR)
+- $(CP) $(TEATOTAL) $(BINDIR)
++ ${BSD_INSTALL_PROGRAM} $(TEATOTAL) $(BINDIR)
+ $(LN) $(TEATOTAL) $(BINDIR)/$(TEA)
+ $(LN) $(TEATOTAL) $(BINDIR)/$(UNTEA)
+ $(LN) $(TEATOTAL) $(BINDIR)/$(TEA-KGEN)
+ $(MKDIR) $(MANDIR)
+- $(CP) $(MANPAGES) $(MANDIR)
++ ${BSD_INSTALL_MAN} $(MANPAGES) $(MANDIR)
+
+ clean:
+ $(RM) core *.o $(PROGRAMS) testout.tea test.out test2.key test3.key \