aboutsummaryrefslogtreecommitdiff
path: root/security/termlog
diff options
context:
space:
mode:
authorChristian S.J. Peron <csjp@FreeBSD.org>2009-03-03 14:53:31 +0000
committerChristian S.J. Peron <csjp@FreeBSD.org>2009-03-03 14:53:31 +0000
commit52af32c4e3fd919939640851846d543d333e8d03 (patch)
tree79b77b0b392f450aaff301bcc448c17477598aa6 /security/termlog
parent3f0e34a100f99ca2e83624b73a3ce439acd10b71 (diff)
downloadports-52af32c4e3fd919939640851846d543d333e8d03.tar.gz
ports-52af32c4e3fd919939640851846d543d333e8d03.zip
Notes
Diffstat (limited to 'security/termlog')
-rw-r--r--security/termlog/Makefile2
-rw-r--r--security/termlog/files/termlog.in31
2 files changed, 33 insertions, 0 deletions
diff --git a/security/termlog/Makefile b/security/termlog/Makefile
index 59079147243c..495f227d9594 100644
--- a/security/termlog/Makefile
+++ b/security/termlog/Makefile
@@ -7,6 +7,7 @@
PORTNAME= termlog
PORTVERSION= 2.5
+PORTREVISION= 1
CATEGORIES= security sysutils
MASTER_SITES= http://www.seccuris.com/documents/downloads/
MASTER_SITE_SUBDIR= termlog
@@ -15,6 +16,7 @@ MAINTAINER= csjp@FreeBSD.org
COMMENT= Monitor or log multiple system terminals synchronously
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+USE_RC_SUBR= ${PORTNAME}
MAN1= termlog.1
PLIST_FILES= bin/termlog
diff --git a/security/termlog/files/termlog.in b/security/termlog/files/termlog.in
new file mode 100644
index 000000000000..3d194bdc865d
--- /dev/null
+++ b/security/termlog/files/termlog.in
@@ -0,0 +1,31 @@
+#!/bin/sh
+
+# PROVIDE: termlog
+# REQUIRE: cron devfs syslogd
+
+. /etc/rc.subr
+
+load_rc_config termlog
+
+name=termlog
+rcvar=`set_rcvar`
+
+command="/usr/local/bin/termlog"
+
+# default to disable
+termlog_enable=${termlog_enable:-"NO"}
+# logging path
+termlog_log_dir=${termlog_log_dir:-"/var/log/termlog/"}
+# maximum monitored consoles
+termlog_max_cons=${termlog_max_cons:-"30"}
+termlog_flags=${termlog_flags:-" -C $termlog_log_dir -f -n $termlog_max_cons &"}
+
+start_precmd=start_precmd
+
+start_precmd()
+{
+ mkdir -p $termlog_log_dir
+ chmod 0700 $termlog_log_dir
+}
+
+run_rc_command "$1"