aboutsummaryrefslogtreecommitdiff
path: root/security/tinc-devel
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2017-11-05 11:40:37 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2017-11-05 11:40:37 +0000
commit45fd7dd40f049fd693b6724f68d0a735b61cc0ed (patch)
tree36d98a62aaebde7035242f92b7bdb0382680310e /security/tinc-devel
parent7eb91ea7b932922138de7819721a81c1be7ec17a (diff)
downloadports-45fd7dd40f049fd693b6724f68d0a735b61cc0ed.tar.gz
ports-45fd7dd40f049fd693b6724f68d0a735b61cc0ed.zip
Notes
Diffstat (limited to 'security/tinc-devel')
-rw-r--r--security/tinc-devel/Makefile28
-rw-r--r--security/tinc-devel/distinfo3
-rw-r--r--security/tinc-devel/files/tincd.in89
-rw-r--r--security/tinc-devel/pkg-descr20
4 files changed, 140 insertions, 0 deletions
diff --git a/security/tinc-devel/Makefile b/security/tinc-devel/Makefile
new file mode 100644
index 000000000000..9a0323148d12
--- /dev/null
+++ b/security/tinc-devel/Makefile
@@ -0,0 +1,28 @@
+# Created by: ijliao
+# $FreeBSD$
+
+PORTNAME= tinc
+PORTVERSION= 1.0.32
+CATEGORIES= security
+MASTER_SITES= https://www.tinc-vpn.org/packages/ \
+ http://www.tinc-vpn.org/packages/
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= Virtual Private Network (VPN) daemon
+
+LICENSE= GPLv3
+
+LIB_DEPENDS= liblzo2.so:archivers/lzo2
+
+USES= cpe ssl makeinfo
+CPE_VENDOR= tinc-vpn
+GNU_CONFIGURE= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ARGS= --localstatedir=/var
+USE_RC_SUBR= tincd
+INFO= tinc
+PLIST_FILES= sbin/tincd \
+ man/man5/tinc.conf.5.gz man/man8/tincd.8.gz
+
+.include <bsd.port.mk>
diff --git a/security/tinc-devel/distinfo b/security/tinc-devel/distinfo
new file mode 100644
index 000000000000..2d9a1c67ea11
--- /dev/null
+++ b/security/tinc-devel/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1506227200
+SHA256 (tinc-1.1pre15.tar.gz) = 41dc3e40c5f8be497b779acd6f59ef4572e1430d0d0f0436f2de5cb21a59ef18
+SIZE (tinc-1.1pre15.tar.gz) = 704145
diff --git a/security/tinc-devel/files/tincd.in b/security/tinc-devel/files/tincd.in
new file mode 100644
index 000000000000..8ada85c631cc
--- /dev/null
+++ b/security/tinc-devel/files/tincd.in
@@ -0,0 +1,89 @@
+#!/bin/sh
+
+# $FreeBSD$
+#
+# PROVIDE: tincd
+# REQUIRE: ipfilter FILESYSTEMS sysctl netif
+# BEFORE: SERVERS routing
+#
+# Define these tincd_* variables in one of these files:
+# /etc/rc.conf
+# /etc/rc.conf.local
+# /etc/rc.conf.d/tincd
+#
+# tincd_enable (bool): Set to "NO" by default.
+# Set it to "YES" to enable tincd.
+# tincd_cfg (str): Set to "" by default.
+# Set it to NETNAMEs to use (ex.: "vpn1 vpn2").
+# tincd_flags (str): Set to "" by default.
+# Set it to flags to use (ex.: "-d 1 --logfile").
+#
+# DO NOT CHANGE THESE DEFAULT VALUES HERE
+
+tincd_enable=${tincd_enable:-"NO"}
+
+. /etc/rc.subr
+
+name="tincd"
+rcvar="tincd_enable"
+command="%%PREFIX%%/sbin/tinc"
+start_cmd="tincd_start"
+stop_cmd="tincd_stop"
+reload_cmd="tincd_reload"
+extra_commands="reload"
+procname=${command:-tincd}
+ldconfig_command="/sbin/ldconfig"
+
+load_rc_config $name
+
+tincd_start()
+{
+ ${ldconfig_command} -elf -m %%LOCALBASE%%/lib
+ if test -z "${tincd_cfg}"
+ then
+ echo "Starting tincd"
+ $command start
+ else
+ for cfg in ${tincd_cfg}
+ do
+ echo "Starting tincd for: ${cfg}"
+ $command -n $cfg start $tincd_flags
+ done
+ fi
+# code deliberately borrowed from /etc/rc.d/netif
+ if [ -f /etc/rc.d/ipfilter ] ; then
+ # Resync ipfilter
+ /etc/rc.d/ipfilter quietresync
+ fi
+}
+tincd_stop()
+{
+ if test -z "${tincd_cfg}"
+ then
+ echo "Stopping tincd"
+ $command stop
+ else
+ for cfg in $tincd_cfg
+ do
+ echo "Stopping tincd for: ${cfg}"
+ $command -n $cfg stop
+ done
+ fi
+}
+tincd_reload()
+{
+ if test -z "${tincd_cfg}"
+ then
+ echo "Sending reload to tincd"
+ $command reload
+ else
+ for cfg in $tincd_cfg
+ do
+ echo "Sending reload to tincd for: ${cfg}"
+ $command -n $cfg reload
+ done
+ fi
+}
+
+run_rc_command "$1"
+# eof
diff --git a/security/tinc-devel/pkg-descr b/security/tinc-devel/pkg-descr
new file mode 100644
index 000000000000..b5395f8a34c0
--- /dev/null
+++ b/security/tinc-devel/pkg-descr
@@ -0,0 +1,20 @@
+tinc is a Virtual Private Network (VPN) daemon that uses tunnelling and
+encryption to create a secure private network between hosts on the Internet.
+
+Because the tunnel appears to the IP level network code as a normal network
+device, there is no need to adapt any existing software. This tunnelling
+allows VPN sites to share information with each other over the Internet
+without exposing any information to others.
+
+A single tinc daemon can accept more than one connection at a time, thus
+making it possible to create larger virtual networks, because some
+limitations are circumvented.
+
+Instead of most other VPN implementations, tinc encapsulates each network
+packet in its own UDP packet, instead of encapsulating all into one TCP or
+even PPP over TCP stream. This results in lower latencies, less overhead,
+and in general better responsiveness and throughput.
+
+LICENSE: GPL3 or later with execption to link with OpenSSL
+
+WWW: http://www.tinc-vpn.org/