aboutsummaryrefslogtreecommitdiff
path: root/security/tinyca
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-08-31 08:49:28 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-08-31 08:49:28 +0000
commit7a18da4df1da521a01f1e1163a3f674dc7b4fb96 (patch)
tree9d4c3f0638a0d1bc1ebe4087465f5b40d6949167 /security/tinyca
parent48032fbbd7c8bd51028d0f2c540a3bdade7ea79a (diff)
downloadports-7a18da4df1da521a01f1e1163a3f674dc7b4fb96.tar.gz
ports-7a18da4df1da521a01f1e1163a3f674dc7b4fb96.zip
Notes
Diffstat (limited to 'security/tinyca')
-rw-r--r--security/tinyca/Makefile45
-rw-r--r--security/tinyca/distinfo1
-rw-r--r--security/tinyca/files/patch-lib::CA.pm11
-rw-r--r--security/tinyca/files/patch-tinyca29
-rw-r--r--security/tinyca/pkg-descr22
-rw-r--r--security/tinyca/pkg-plist11
6 files changed, 119 insertions, 0 deletions
diff --git a/security/tinyca/Makefile b/security/tinyca/Makefile
new file mode 100644
index 000000000000..624b76bcef96
--- /dev/null
+++ b/security/tinyca/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: tinyca
+# Date created: 17 July 2003
+# Whom: Janos.Mohacsi@bsd.hu
+#
+# $FreeBSD$
+#
+
+PORTNAME= tinyca
+PORTVERSION= 0.4.9
+CATEGORIES= security net
+MASTER_SITES= http://tinyca.sm-zone.net/
+
+MAINTAINER= Janos.Mohacsi@bsd.hu
+COMMENT= Simple graphical interface to manage a small Certification Authority
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Tk.pm:${PORTSDIR}/x11-toolkits/p5-Tk \
+ ${SITE_PERL}/${PERL_ARCH}/Locale/gettext.pm:${PORTSDIR}/devel/p5-Locale-gettext \
+ zip:${PORTSDIR}/archivers/zip
+
+WRKSRC= ${WRKDIR}/TinyCA
+USE_PERL5= yes
+USE_OPENSSL= yes
+NO_BUILD= yes
+DOC_FILES= INSTALL
+LIB_FILES= CA.pm CERT.pm GUI.pm KEY.pm OpenSSL.pm REQ.pm TCONFIG.pm
+
+do-install:
+ @${MKDIR} ${SITE_PERL}/${PORTNAME}/
+.for file in ${LIB_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/lib/${file} ${SITE_PERL}/${PORTNAME}
+.endfor
+ @${INSTALL_DATA} ${WRKSRC}/templates/openssl.cnf ${PREFIX}/etc/tinyca.cnf
+ @${SED} -e "s:%%PREFIX%%:${PREFIX}:g" -e "s:%%SITE_PERL%%:${SITE_PERL}:g" \
+ ${WRKSRC}/tinyca >${WRKSRC}/tinyca.new
+ @${INSTALL_SCRIPT} ${WRKSRC}/tinyca.new ${PREFIX}/bin/tinyca
+
+post-install:
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in ${DOC_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/tinyca/distinfo b/security/tinyca/distinfo
new file mode 100644
index 000000000000..1fb694d799de
--- /dev/null
+++ b/security/tinyca/distinfo
@@ -0,0 +1 @@
+MD5 (tinyca-0.4.9.tar.gz) = eabbf1023c77c2e0e0b8300999462f83
diff --git a/security/tinyca/files/patch-lib::CA.pm b/security/tinyca/files/patch-lib::CA.pm
new file mode 100644
index 000000000000..bccae6296ffd
--- /dev/null
+++ b/security/tinyca/files/patch-lib::CA.pm
@@ -0,0 +1,11 @@
+--- lib/CA.pm.orig Tue Jul 1 00:33:18 2003
++++ lib/CA.pm Tue Jul 15 17:05:35 2003
+@@ -328,7 +328,7 @@
+ };
+
+ # create configuration file
+- my $in = $self->{'init'}->{'templatedir'}."/openssl.cnf";
++ my $in = $self->{'init'}->{'templatedir'}."/tinyca.cnf";
+ my $out = $self->{$name}->{'dir'}."/openssl.cnf";
+
+ open(IN, "<$in") || do {
diff --git a/security/tinyca/files/patch-tinyca b/security/tinyca/files/patch-tinyca
new file mode 100644
index 000000000000..c8d200f0e7fe
--- /dev/null
+++ b/security/tinyca/files/patch-tinyca
@@ -0,0 +1,29 @@
+--- tinyca.orig Thu Jul 3 19:20:48 2003
++++ tinyca Thu Jul 17 11:21:29 2003
+@@ -18,7 +18,7 @@
+ # along with this program; if not, write to the Free Software
+ # Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111, USA.
+
+-BEGIN { push(@INC, './lib'); } # put here the location of the modules
++BEGIN { push(@INC, '%%SITE_PERL%%/tinyca'); } # put here the location of the modules
+
+ use strict;
+
+@@ -47,7 +47,7 @@
+
+ # location of openssl
+ $init->{'opensslbin'} = "/usr/bin/openssl";
+-$init->{'zipbin'} = "/usr/bin/zip";
++$init->{'zipbin'} = "%%PREFIX%%/bin/zip";
+
+ if(not -x $init->{'opensslbin'}) {
+ printf(gettext("Can't execute %s.\n"), $init->{'opensslbin'});
+@@ -61,7 +61,7 @@
+ }
+
+ # directory with the templates
+-$init->{'templatedir'} = "./templates";
++$init->{'templatedir'} = "%%PREFIX%%/etc";
+
+ if(not -d $init->{'templatedir'}) {
+ print gettext("Can't find templatedir.\n");
diff --git a/security/tinyca/pkg-descr b/security/tinyca/pkg-descr
new file mode 100644
index 000000000000..a73a620dad7a
--- /dev/null
+++ b/security/tinyca/pkg-descr
@@ -0,0 +1,22 @@
+TinyCA is a simple graphical userinterface written in Perl/Tk to manage a
+small CA (Certification Authority).
+Features:
+
+Currently TinyCA supports the following features:
+
+ * Creation and Revocation of x509 - S/MIME certificates
+ * PKCS#10 Requests can be imported and signed
+ * Servercertificates
+ o Certificates can be exported as: PEM, DER, TXT and PKCS#12
+ o Certificates may be used with e.g. Apache, Postfix, OpenLDAP,
+ Cyrus and FreeS/WAN
+ * Clientcertificates
+ o Certificates can be exported as: PEM, DER, TXT and PKCS#12
+ o Certificates may be used with e.g. Netscape, Konqueror, Opera,
+ Internet Explorer, Outlook (Express) and FreeS/WAN
+ * Certificate Revocation List
+ o CRLs can be exported as: PEM, DER and TXT
+
+WWW: http://tinyca.sm-zone.net/
+
+Janos Mohacsi <janos.mohacsi@bsd.hu>
diff --git a/security/tinyca/pkg-plist b/security/tinyca/pkg-plist
new file mode 100644
index 000000000000..002ded0d0208
--- /dev/null
+++ b/security/tinyca/pkg-plist
@@ -0,0 +1,11 @@
+bin/tinyca
+%%SITE_PERL%%/tinyca/CA.pm
+%%SITE_PERL%%/tinyca/CERT.pm
+%%SITE_PERL%%/tinyca/GUI.pm
+%%SITE_PERL%%/tinyca/KEY.pm
+%%SITE_PERL%%/tinyca/OpenSSL.pm
+%%SITE_PERL%%/tinyca/REQ.pm
+%%SITE_PERL%%/tinyca/TCONFIG.pm
+@dirrm %%SITE_PERL%%/tinyca/
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL
+%%PORTDOCS%%@dirrm %%DOCSDIR%%