aboutsummaryrefslogtreecommitdiff
path: root/security/tlswrap/Makefile
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-07-26 18:47:06 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-07-26 18:47:06 +0000
commit3ee5e28fa3999aeb67007f722474b96b498a7810 (patch)
tree33084f3c0b136490e28501a6c0b43fc81fe30b69 /security/tlswrap/Makefile
parentbc2070d1b95e54c1794e42dd835e2a60246789b7 (diff)
downloadports-3ee5e28fa3999aeb67007f722474b96b498a7810.tar.gz
ports-3ee5e28fa3999aeb67007f722474b96b498a7810.zip
Notes
Diffstat (limited to 'security/tlswrap/Makefile')
-rw-r--r--security/tlswrap/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/security/tlswrap/Makefile b/security/tlswrap/Makefile
new file mode 100644
index 000000000000..f3d8713a7c75
--- /dev/null
+++ b/security/tlswrap/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: tlswrap
+# Date created: 25 July 2005
+# Whom: Daniel O'Connor <darius@dons.net.au>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tlswrap
+PORTVERSION= 1.0.2
+CATEGORIES= security
+MASTER_SITES= http://tlswrap.sunsite.dk/
+DISTNAME= ${PORTNAME}-1.02
+
+MAINTAINER= darius@dons.net.au
+COMMENT= An FTP proxy that wraps data and control with TLS/SSL
+
+GNU_CONFIGURE= yes
+USE_OPENSSL= yes
+USE_REINPLACE= yes
+
+PLIST_FILES= bin/tlswrap
+PORTDOCS= README
+
+.include <bsd.port.pre.mk>
+
+post-configure:
+.if ( ${OSVERSION} < 500000 )
+ @${REINPLACE_CMD} -E 's,#define socklen_t size_t,,g' \
+ ${WRKSRC}/conf.h
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -E 's,^(CC|CFLAGS|LDFLAGS).*=,\1?=,g' \
+ ${WRKSRC}/Makefile.in
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>