aboutsummaryrefslogtreecommitdiff
path: root/security/tor-devel
diff options
context:
space:
mode:
authorBrendan Fabeny <bf@FreeBSD.org>2011-09-23 19:58:35 +0000
committerBrendan Fabeny <bf@FreeBSD.org>2011-09-23 19:58:35 +0000
commit37da0d8f4dd8c4d5fc0c51fcd26c161fccee6ec5 (patch)
tree28341e15779bf52302d1a8b3e60c6de22cf2994c /security/tor-devel
parent2601be140b7225aed7b59bccc8aefa3b7fd1a684 (diff)
Notes
Diffstat (limited to 'security/tor-devel')
-rw-r--r--security/tor-devel/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/security/tor-devel/Makefile b/security/tor-devel/Makefile
index 1fc872f45623..623b05bd6698 100644
--- a/security/tor-devel/Makefile
+++ b/security/tor-devel/Makefile
@@ -7,17 +7,20 @@
PORTNAME= tor
DISTVERSION= 0.2.3.4-alpha
+PORTREVISION= 1
CATEGORIES= security net ipv6
MASTER_SITES= https://www.torproject.org/dist/ \
ftp://ftp.bit.nl/mirror/tor/ \
http://cyberside.net.ee/tor/ \
http://mirrors.chaos-darmstadt.de/tor-mirror/dist/ \
+ http://mirror.host4site.co.il/torproject.org/dist/ \
http://mirror.tor.hu/dist/ \
http://onion.anonymo.us.org/dist/ \
http://theonionrouter.com/dist/ \
http://tor.amorphis.eu/dist/ \
http://tor.askapache.com/dist/ \
http://tor.beme-it.de/dist/ \
+ http://tor.blingblingsquad.net/dist/ \
http://tor.ccc.de/dist/ \
http://tor.cyberarmy.at/dist/ \
http://tor.homosu.net/dist/ \
@@ -29,6 +32,7 @@ MASTER_SITES= https://www.torproject.org/dist/ \
http://tordistua.reactor-xg.kiev.ua/ \
http://torproj.xpdm.us/dist/ \
http://torproject.nwlinux.us/dist/ \
+ http://www.torproject.org.in/dist/ \
http://www.oignon.net/dist/ \
http://www.torproject.org.nyud.net/dist/ \
http://www.torproject.us/dist/ \
@@ -52,6 +56,7 @@ MAKE_JOBS_UNSAFE= yes
OPTIONS= BUFFEREVENTS "use libevent's buffered IO" off \
BUFFREELISTS "freelists for buffer RAM" on \
+ GMAKE "parallel build safety via GNU make" off \
INSTR_DOWNLOADS "instrument downloads for analysis" off \
STATIC_TOR "build a static tor" off \
TCMALLOC "use the tcmalloc memory allocation library" off \
@@ -71,6 +76,12 @@ MAN1= tor.1 tor-resolve.1 torify.1 tor-gencert.1
.include <bsd.port.pre.mk>
+.if defined(WITH_GMAKE)
+USE_GMAKE= yes
+.else
+MAKE_JOBS_UNSAFE= yes
+.endif
+
.if ( (${OSVERSION} >= 703100 && ${OSVERSION} < 800000) || \
(${OSVERSION} >= 800500 && ${OSVERSION} < 900000) || \
(${OSVERSION} >= 900003) ) && !defined(USE_GCC) && empty(CC:M*gcc4*)