aboutsummaryrefslogtreecommitdiff
path: root/security/tor-devel
diff options
context:
space:
mode:
authorBrendan Fabeny <bf@FreeBSD.org>2011-07-24 01:16:14 +0000
committerBrendan Fabeny <bf@FreeBSD.org>2011-07-24 01:16:14 +0000
commit707bfbadd34b222fd4a94a9c661385112b1ec52c (patch)
tree956e5ada0d4fc1d1245bf3ad798c4f62152f91a8 /security/tor-devel
parent4b8f72d9d2a6f451c32f1bc9547b7424c06e84fc (diff)
downloadports-707bfbadd34b222fd4a94a9c661385112b1ec52c.tar.gz
ports-707bfbadd34b222fd4a94a9c661385112b1ec52c.zip
Notes
Diffstat (limited to 'security/tor-devel')
-rw-r--r--security/tor-devel/Makefile39
-rw-r--r--security/tor-devel/distinfo4
-rw-r--r--security/tor-devel/files/patch-configure67
3 files changed, 96 insertions, 14 deletions
diff --git a/security/tor-devel/Makefile b/security/tor-devel/Makefile
index acd19aac5359..ddf389b407d8 100644
--- a/security/tor-devel/Makefile
+++ b/security/tor-devel/Makefile
@@ -6,38 +6,48 @@
#
PORTNAME= tor
-DISTVERSION= 0.2.3.1-alpha
-PORTREVISION= 1
+DISTVERSION= 0.2.3.2-alpha
CATEGORIES= security net ipv6
MASTER_SITES= https://www.torproject.org/dist/ \
ftp://ftp.bit.nl/mirror/tor/ \
http://cyberside.net.ee/tor/ \
http://mirrors.chaos-darmstadt.de/tor-mirror/dist/ \
+ http://mirror.tor.hu/dist/ \
+ http://onion.anonymo.us.org/dist/ \
+ http://theonionrouter.com/dist/ \
http://tor-www.5coluna.com/dist/ \
http://tor.amorphis.eu/dist/ \
http://tor.askapache.com/dist/ \
http://tor.beme-it.de/dist/ \
- http://tor.boinc.ch/dist/ \
http://tor.ccc.de/dist/ \
+ http://tor.cyberarmy.at/dist/ \
http://tor.homosu.net/dist/ \
http://tor.idnr.ws/dist/ \
+ http://tor.kamagurka.org/dist/ \
http://tor.searchprivate.com/dist/ \
http://tor.taiga-san.net/dist/ \
+ http://tor.webersiedlung.at/dist/ \
+ http://tordistua.reactor-xg.kiev.ua/ \
http://torproj.xpdm.us/dist/ \
http://torproject.nwlinux.us/dist/ \
http://www.oignon.net/dist/ \
http://www.torproject.org.nyud.net/dist/ \
- http://www.torproject.us/dist/
+ http://www.torproject.us/dist/ \
+ http://www.torservers.net/mirrors/torproject.org/dist/
PKGNAMESUFFIX= -devel
MAINTAINER= bf@FreeBSD.org
COMMENT= An anonymizing overlay network for TCP
+LICENSE= BSD
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+= --with-openssl-dir="${OPENSSLBASE}" --disable-asciidoc
-CPPFLAGS+= -I${LOCALBASE}/include/event2
-LDFLAGS+= -L${LOCALBASE}/lib/event2
-CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
+CONFIGURE_ARGS= --with-openssl-dir="${OPENSSLBASE}" --disable-asciidoc
+CONFIGURE_ENV= LDFLAGS="${LDFLAGS}" \
+ TOR_CPPFLAGS_libevent="-I${LOCALBASE}/include/event2 -I${LOCALBASE}/include" \
+ TOR_LDFLAGS_libevent="-L${LOCALBASE}/lib/event2" \
+ TOR_LIBEVENT_LIBS="${TOR_LIBEVENT_LIBS}"
MAKE_JOBS_UNSAFE= yes
@@ -56,14 +66,10 @@ GROUPS = _tor
USERS= _tor
CONFLICTS= tor-[0-9]*
-CONFLICTS_BUILD= libevent-[01]*
MANCOMPRESSED= no
MAN1= tor.1 tor-resolve.1 torify.1 tor-gencert.1
-LICENSE= BSD
-LICENSE_FILE= ${WRKSRC}/LICENSE
-
.include <bsd.port.pre.mk>
.if ( ${OSVERSION} < 704000 || \
@@ -74,6 +80,7 @@ WITH_OPENSSL_PORT= yes
.include "${PORTSDIR}/Mk/bsd.openssl.mk"
.if defined(WITH_BUFFEREVENTS)
+BROKEN = there are unresolved problems with BUFFEREVENTS; please disable this option
CONFIGURE_ARGS+= --enable-bufferevents
.else
CONFIGURE_ARGS+= --disable-bufferevents
@@ -95,9 +102,17 @@ CONFIGURE_ARGS+= --disable-instrument-downloads
BUILD_DEPENDS += ${LOCALBASE}/lib/event2/libevent.a:${PORTSDIR}/devel/libevent2
CONFIGURE_ARGS+= --enable-static-tor --with-libevent-dir=${LOCALBASE}/lib/event2 \
--with-zlib-dir=/usr/lib
+TOR_LIBEVENT_LIBS= ${LOCALBASE}/lib/event2/libevent.a
+.if defined(WITH_BUFFEREVENTS)
+TOR_LIBEVENT_LIBS:= ${LOCALBASE}/lib/event2/libevent_openssl.a ${TOR_LIBEVENT_LIBS}
+.endif
.else
CONFIGURE_ARGS+= --enable-linker-hardening
LIB_DEPENDS+= event-2.0:${PORTSDIR}/devel/libevent2
+TOR_LIBEVENT_LIBS= -levent-2.0
+.if defined(WITH_BUFFEREVENTS)
+TOR_LIBEVENT_LIBS:= -levent_openssl-2.0 ${TOR_LIBEVENT_LIBS}
+.endif
.endif
.if defined(WITH_TCMALLOC)
diff --git a/security/tor-devel/distinfo b/security/tor-devel/distinfo
index 22d2231555d7..c2cf78371474 100644
--- a/security/tor-devel/distinfo
+++ b/security/tor-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (tor-0.2.3.1-alpha.tar.gz) = 8906e80068952a4d3d9f65dfea2f4b0fd76b6b301fd1e62adac6c1b3bebe360e
-SIZE (tor-0.2.3.1-alpha.tar.gz) = 2686119
+SHA256 (tor-0.2.3.2-alpha.tar.gz) = 8f423af73c8d8477752858cfcc0c15860f487a0f9a390e791eaea22f4b467edd
+SIZE (tor-0.2.3.2-alpha.tar.gz) = 2755750
diff --git a/security/tor-devel/files/patch-configure b/security/tor-devel/files/patch-configure
new file mode 100644
index 000000000000..0c1bdb4972c9
--- /dev/null
+++ b/security/tor-devel/files/patch-configure
@@ -0,0 +1,67 @@
+--- configure.orig 2011-07-18 13:22:21.000000000 -0400
++++ configure 2011-07-23 16:09:51.000000000 -0400
+@@ -2579,7 +2579,7 @@
+ # Check whether --enable-linker-hardening was given.
+ if test "${enable_linker_hardening+set}" = set; then
+ enableval=$enable_linker_hardening; if test x$enableval = xyes; then
+- LDFLAGS="$LDFLAGS -z relro -z now"
++ LDFLAGS="$LDFLAGS -Wl,-z,relro -Wl,-z,now"
+ fi
+ fi
+
+@@ -6816,7 +6816,7 @@
+ ac_res=$ac_cv_search_clock_gettime
+ if test "$ac_res" != no; then
+ test "$ac_res" = "none required" || LIBS="$ac_res $LIBS"
+- have_rt=yes
++# have_rt=yes
+ fi
+
+ if test "$have_rt" = yes; then
+@@ -6825,6 +6825,7 @@
+ fi
+
+
++if false ; then
+ trylibeventdir=""
+
+ # Check whether --with-libevent-dir was given.
+@@ -7235,6 +7236,7 @@
+ LIBS="$tor_saved_LIBS"
+ LDFLAGS="$tor_saved_LDFLAGS"
+ CPPFLAGS="$tor_saved_CPPFLAGS"
++fi
+
+
+
+@@ -7607,6 +7609,7 @@
+ fi
+
+
++if false ; then
+ if test "$enable_static_libevent" = "yes"; then
+ if test "$tor_cv_library_libevent_dir" = "(system)"; then
+ { { echo "$as_me:$LINENO: error: \"You must specify an explicit --with-libevent-dir=x option when using --enable-static-libevent\"" >&5
+@@ -7618,6 +7621,7 @@
+ else
+ TOR_LIBEVENT_LIBS="-levent"
+ fi
++fi
+
+ if test "$enable_bufferevents" = "yes" ; then
+ if test "$ac_cv_header_event2_bufferevent_ssl_h" != "yes" ; then
+@@ -7750,12 +7754,14 @@
+ #define USE_BUFFEREVENTS 1
+ _ACEOF
+
++if false ; then
+ if test "$enable_static_libevent" = "yes"; then
+ TOR_LIBEVENT_LIBS="$TOR_LIBDIR_libevent/libevent_openssl.a $TOR_LIBEVENT_LIBS"
+ else
+ TOR_LIBEVENT_LIBS="-levent_openssl $TOR_LIBEVENT_LIBS"
+ fi
+ fi
++fi
+
+
+