aboutsummaryrefslogtreecommitdiff
path: root/security/tor-devel
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-07-24 13:32:58 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-07-24 13:32:58 +0000
commitb5646534525f3eb9cce485f6580fe9a473ce2ba7 (patch)
treeffddb673c48038e781d69f6c3d08ec8855ad33a5 /security/tor-devel
parentafee9d5cd365a4ef10c99ef86e5358e76a5d37f2 (diff)
downloadports-b5646534525f3eb9cce485f6580fe9a473ce2ba7.tar.gz
ports-b5646534525f3eb9cce485f6580fe9a473ce2ba7.zip
Notes
Diffstat (limited to 'security/tor-devel')
-rw-r--r--security/tor-devel/Makefile19
1 files changed, 10 insertions, 9 deletions
diff --git a/security/tor-devel/Makefile b/security/tor-devel/Makefile
index f070fe4e96e3..293e70b32e83 100644
--- a/security/tor-devel/Makefile
+++ b/security/tor-devel/Makefile
@@ -3,6 +3,7 @@
PORTNAME= tor
DISTVERSION= 0.2.5.5-alpha
+PORTREVISION= 1
CATEGORIES= security net ipv6
MASTER_SITES= TOR
PKGNAMESUFFIX= -devel
@@ -16,8 +17,8 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
USES= gmake
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-openssl-dir="${OPENSSLBASE}" --disable-asciidoc
-CONFIGURE_ENV= TOR_CPPFLAGS_libevent="-I${LOCALBASE}/include/event2 -I${LOCALBASE}/include" \
- TOR_LDFLAGS_libevent="-L${LOCALBASE}/lib/event2" \
+CONFIGURE_ENV= TOR_CPPFLAGS_libevent="-I${LOCALBASE}/include" \
+ TOR_LDFLAGS_libevent="-L${LOCALBASE}/lib/" \
TOR_LIBEVENT_LIBS="${TOR_LIBEVENT_LIBS}"
OPTIONS_DEFINE= BUFFEREVENTS BUFFREELISTS INSTR_DOWNLOADS MEMPOOLS \
@@ -80,19 +81,19 @@ CONFIGURE_ARGS+= --disable-mempools
.endif
.if ${PORT_OPTIONS:MSTATIC_TOR}
-BUILD_DEPENDS += ${LOCALBASE}/lib/event2/libevent.a:${PORTSDIR}/devel/libevent2
-CONFIGURE_ARGS+= --enable-static-tor --with-libevent-dir=${LOCALBASE}/lib/event2 \
+BUILD_DEPENDS += ${LOCALBASE}/lib/libevent.a:${PORTSDIR}/devel/libevent2
+CONFIGURE_ARGS+= --enable-static-tor \
--with-zlib-dir=/usr/lib --disable-linker-hardening
-TOR_LIBEVENT_LIBS= ${LOCALBASE}/lib/event2/libevent.a
+TOR_LIBEVENT_LIBS= ${LOCALBASE}/lib/libevent.a
.if ${PORT_OPTIONS:MBUFFEREVENTS}
-TOR_LIBEVENT_LIBS:= ${LOCALBASE}/lib/event2/libevent_openssl.a ${TOR_LIBEVENT_LIBS}
+TOR_LIBEVENT_LIBS:= ${LOCALBASE}/lib/libevent_openssl.a ${TOR_LIBEVENT_LIBS}
.endif
.else
CONFIGURE_ARGS+= --enable-linker-hardening
-LIB_DEPENDS+= libevent-2.0.so:${PORTSDIR}/devel/libevent2
-TOR_LIBEVENT_LIBS= -levent-2.0
+LIB_DEPENDS+= libevent.so:${PORTSDIR}/devel/libevent2
+TOR_LIBEVENT_LIBS= -levent
.if ${PORT_OPTIONS:MBUFFEREVENTS}
-TOR_LIBEVENT_LIBS:= -levent_openssl-2.0 ${TOR_LIBEVENT_LIBS}
+TOR_LIBEVENT_LIBS:= -levent_openssl ${TOR_LIBEVENT_LIBS}
.endif
.endif