aboutsummaryrefslogtreecommitdiff
path: root/security/tor/Makefile
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2017-10-01 20:19:49 +0000
committerKurt Jaeger <pi@FreeBSD.org>2017-10-01 20:19:49 +0000
commitd077c67d1b5bf225ec2061be935a4be4179f111e (patch)
tree2b0c91ff4e4d0cbb504c686bd09a8cc22663b8b6 /security/tor/Makefile
parent1040ffd7b44e7fbc89d033787dc5284b989c0ce2 (diff)
security/tor: update 0.3.0.10 -> 0.3.1.7
- Adds Lzma and Zstd compression - Rework some options to options_ng PR: 222431 Submitted by: brnrd, Yuri Victorovich <yuri@rawbw.com> (maintainer)
Notes
Notes: svn path=/head/; revision=451058
Diffstat (limited to 'security/tor/Makefile')
-rw-r--r--security/tor/Makefile28
1 files changed, 19 insertions, 9 deletions
diff --git a/security/tor/Makefile b/security/tor/Makefile
index 46e93620d67d..1f93050436b2 100644
--- a/security/tor/Makefile
+++ b/security/tor/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= tor
-PORTVERSION= 0.3.0.10
-PORTREVISION= 1
+PORTVERSION= 0.3.1.7
CATEGORIES= security net ipv6
MASTER_SITES= TOR
@@ -26,12 +25,14 @@ CONFIGURE_ENV= TOR_CPPFLAGS_libevent="-I${LOCALBASE}/include" \
TOR_LIBEVENT_LIBS="${TOR_LIBEVENT_LIBS}"
OPTIONS_DEFINE= MANPAGES DOCS STATIC_TOR TCMALLOC TOR2WEB
-OPTIONS_DEFAULT=MANPAGES
+OPTIONS_GROUP= COMPRESSION
+OPTIONS_GROUP_COMPRESSION=ZSTD LZMA
+OPTIONS_DEFAULT=MANPAGES ZSTD LZMA
OPTIONS_SUB= yes
-
STATIC_TOR_DESC= Build a static tor
TCMALLOC_DESC= Use the tcmalloc memory allocation library
TOR2WEB_DESC= (EXPERT OPTION) Faster but non-anonymous hidden services
+COMPRESSION_DESC= Supported compression libraries
USE_RC_SUBR= tor
SUB_FILES= pkg-message
@@ -41,11 +42,16 @@ PLIST_SUB= USER="${USERS}" GROUP="${GROUPS}"
GROUPS= _tor
USERS= _tor
-CONFLICTS= tor-devel-[0-9]*
+CONFLICTS_INSTALL= tor-devel-[0-9]*
STATIC_TOR_USES= ssl:build
STATIC_TOR_USES_OFF= ssl
+TOR2WEB_CONFIGURE_ENABLE= tor2web-mode
+ZSTD_CONFIGURE_ENABLE= zstd
+ZSTD_CONFIGURE_ENV=TOR_ZSTD_LIBS="${TOR_ZSTD_LIBS}"
+LZMA_CONFIGURE_ENABLE= lzma
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDOCS} || ${PORT_OPTIONS:MMANPAGES}
@@ -66,10 +72,18 @@ BUILD_DEPENDS += ${LOCALBASE}/lib/libevent.a:devel/libevent
CONFIGURE_ARGS+= --enable-static-tor \
--with-zlib-dir=/usr/lib --disable-linker-hardening
TOR_LIBEVENT_LIBS= ${LOCALBASE}/lib/libevent.a
+. if ${PORT_OPTIONS:MZSTD}
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libzstd.a:archivers/zstd
+TOR_ZSTD_LIBS= ${LOCALBASE}/lib/libzstd.a
+. endif
.else
CONFIGURE_ARGS+= --enable-linker-hardening
LIB_DEPENDS+= libevent.so:devel/libevent
TOR_LIBEVENT_LIBS= -levent
+. if ${PORT_OPTIONS:MZSTD}
+LIB_DEPENDS+= libzstd.so:archivers/zstd
+TOR_ZSTD_LIBS= -lzstd
+. endif
.endif
.if ${PORT_OPTIONS:MTCMALLOC}
@@ -81,10 +95,6 @@ LIB_DEPENDS+= libtcmalloc.so:devel/google-perftools
.endif
.endif
-.if ${PORT_OPTIONS:MTOR2WEB}
-CONFIGURE_ARGS+= --enable-tor2web-mode
-.endif
-
pre-everything::
.if ${PORT_OPTIONS:MTOR2WEB}
@${ECHO_MSG}