aboutsummaryrefslogtreecommitdiff
path: root/security/tor
diff options
context:
space:
mode:
authorBrendan Fabeny <bf@FreeBSD.org>2013-08-07 12:54:37 +0000
committerBrendan Fabeny <bf@FreeBSD.org>2013-08-07 12:54:37 +0000
commitbd0fca35b5f21e0a664069b2d0448565e1830160 (patch)
treec7f54e3795e577781342a9a1ff71852e91fe9d3a /security/tor
parent6943595e6d6f62a247170ea669e6054fa0826cc8 (diff)
downloadports-bd0fca35b5f21e0a664069b2d0448565e1830160.tar.gz
ports-bd0fca35b5f21e0a664069b2d0448565e1830160.zip
Notes
Diffstat (limited to 'security/tor')
-rw-r--r--security/tor/Makefile13
-rw-r--r--security/tor/files/tor.in15
-rw-r--r--security/tor/pkg-plist6
3 files changed, 20 insertions, 14 deletions
diff --git a/security/tor/Makefile b/security/tor/Makefile
index cf4453bafabc..c3750864c9f6 100644
--- a/security/tor/Makefile
+++ b/security/tor/Makefile
@@ -3,6 +3,7 @@
PORTNAME= tor
DISTVERSION= 0.2.3.25
+PORTREVISION= 1
CATEGORIES= security net ipv6
MASTER_SITES= https://www.torproject.org/dist/ \
ftp://ftp.bit.nl/mirror/tor/ \
@@ -31,7 +32,6 @@ MASTER_SITES= https://www.torproject.org/dist/ \
http://tor.spline.de/dist/ \
http://tor.taiga-san.net/dist/ \
http://tor.vesta.nu/dist/ \
- http://tordistua.reactor-xg.kiev.ua/ \
http://torproj.xpdm.us/dist/ \
https://torproject.antagonism.org/dist/ \
https://torproject.crypto.is/dist/ \
@@ -39,7 +39,6 @@ MASTER_SITES= https://www.torproject.org/dist/ \
http://torproject.jcsh.it/dist/ \
http://torproject.nwlinux.us/dist/ \
http://torproject.ph3x.at/dist/ \
- http://torua.reactor-xg.kiev.ua/dist/ \
https://www.coevoet.nl/tor/dist/ \
http://www.oignon.net/dist/ \
http://www.torproject.nl/dist/ \
@@ -89,7 +88,7 @@ MAN1= tor.1 tor-resolve.1 torify.1 tor-gencert.1
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MGMAKE}
-USE_GMAKE= yes
+USES+= gmake
.else
MAKE_JOBS_UNSAFE= yes
.endif
@@ -137,7 +136,7 @@ TOR_LIBEVENT_LIBS:= ${LOCALBASE}/lib/event2/libevent_openssl.a ${TOR_LIBEVENT_LI
.endif
.else
CONFIGURE_ARGS+= --enable-linker-hardening
-LIB_DEPENDS+= event-2.0:${PORTSDIR}/devel/libevent2
+LIB_DEPENDS+= libevent-2.0.so:${PORTSDIR}/devel/libevent2
TOR_LIBEVENT_LIBS= -levent-2.0
.if ${PORT_OPTIONS:MBUFFEREVENTS}
TOR_LIBEVENT_LIBS:= -levent_openssl-2.0 ${TOR_LIBEVENT_LIBS}
@@ -149,7 +148,7 @@ CONFIGURE_ARGS+= --with-tcmalloc
.if ${PORT_OPTIONS:MSTATIC_TOR}
BUILD_DEPENDS += ${LOCALBASE}/lib/libtcmalloc.so:${PORTSDIR}/devel/google-perftools
.else
-LIB_DEPENDS+= tcmalloc:${PORTSDIR}/devel/google-perftools
+LIB_DEPENDS+= libtcmalloc.so:${PORTSDIR}/devel/google-perftools
.endif
.endif
@@ -199,8 +198,8 @@ post-install:
.if empty(PORT_OPTIONS:MTOR2WEB)
check regression-test test: build
- @( cd ${BUILD_WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} \
- ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} check )
+ @cd ${BUILD_WRKSRC} ; ${SETENV} ${MAKE_ENV} ${MAKE_CMD} \
+ ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} check
.endif
.include <bsd.port.mk>
diff --git a/security/tor/files/tor.in b/security/tor/files/tor.in
index bf5b9098772a..a3f60ce24fbd 100644
--- a/security/tor/files/tor.in
+++ b/security/tor/files/tor.in
@@ -10,13 +10,13 @@
# All these options will overide any settings in your local torrc as
# they are command line options.
#
-# tor_enable (bool): Set to "NO" by default
-# Set it to "YES" to enable tor
-# tor_conf (str): Points to your tor conf file
+# tor_enable (bool): Set it to "YES" to enable tor. Default: NO
+# tor_conf (str): Points to your torrc file.
# Default: %%PREFIX%%/etc/tor/torrc
-# tor_user (str): Tor Daemon user. Default _tor
-# tor_datadir (str): Tor DataDir. Defaults /var/db/tor
-# tor_logfile (str): Tor Log File. Defaults /var/log/tor
+# tor_user (str): Tor daemon user. Default: _tor
+# tor_datadir (str): Tor datadir. Default: /var/db/tor
+# tor_logfile (str): Tor log file. Default: /var/log/tor
+# tor_loglevel (str): Tor log severity level. Default: notice
#
. /etc/rc.subr
@@ -31,13 +31,14 @@ load_rc_config ${name}
: ${tor_user="_tor"}
: ${tor_pidfile="/var/run/tor/tor.pid"}
: ${tor_logfile="/var/log/tor"}
+: ${tor_loglevel="notice"}
: ${tor_datadir="/var/db/tor"}
required_files=${tor_conf}
required_dirs=${tor_datadir}
pidfile=${tor_pidfile}
command="%%PREFIX%%/bin/${name}"
-command_args="-f ${tor_conf} --PidFile ${tor_pidfile} --RunAsDaemon 1 --DataDirectory ${tor_datadir} --+Log notice\ file\ ${tor_logfile}"
+command_args="-f ${tor_conf} --PidFile ${tor_pidfile} --RunAsDaemon 1 --DataDirectory ${tor_datadir} --+Log ${tor_loglevel}\ file\ ${tor_logfile}"
extra_commands="log"
log_cmd="${name}_log"
diff --git a/security/tor/pkg-plist b/security/tor/pkg-plist
index 3b2349b5ce49..136c54c17f36 100644
--- a/security/tor/pkg-plist
+++ b/security/tor/pkg-plist
@@ -1,3 +1,4 @@
+@stopdaemon tor
bin/tor
bin/tor-gencert
bin/tor-resolve
@@ -7,3 +8,8 @@ etc/tor/torrc.sample
%%DATADIR%%/geoip
@dirrm %%DATADIR%%
@dirrmtry etc/tor
+@cwd /
+@dirrmtry var/run/tor
+@dirrmtry var/db/tor/data
+@dirrmtry var/db/tor
+@cwd