aboutsummaryrefslogtreecommitdiff
path: root/security/tor
diff options
context:
space:
mode:
authorBrendan Fabeny <bf@FreeBSD.org>2011-08-30 16:57:43 +0000
committerBrendan Fabeny <bf@FreeBSD.org>2011-08-30 16:57:43 +0000
commit3ed506443b4bd0d994ea068f51239271ca7c4dda (patch)
treed95e09f2382eb6e2770f8aa865644bceeecfecc6 /security/tor
parent7475f0f821d293f692846af99aefe2f29cf8c83f (diff)
downloadports-3ed506443b4bd0d994ea068f51239271ca7c4dda.tar.gz
ports-3ed506443b4bd0d994ea068f51239271ca7c4dda.zip
Notes
Diffstat (limited to 'security/tor')
-rw-r--r--security/tor/Makefile30
-rw-r--r--security/tor/distinfo4
-rw-r--r--security/tor/files/patch-configure52
-rw-r--r--security/tor/files/pkg-message.in2
-rw-r--r--security/tor/pkg-plist4
5 files changed, 75 insertions, 17 deletions
diff --git a/security/tor/Makefile b/security/tor/Makefile
index 436726145ace..4b9d8e6fb6c7 100644
--- a/security/tor/Makefile
+++ b/security/tor/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= tor
-DISTVERSION= 0.2.1.30
+DISTVERSION= 0.2.2.32
CATEGORIES= security net ipv6
MASTER_SITES= https://www.torproject.org/dist/ \
ftp://ftp.bit.nl/mirror/tor/ \
@@ -40,13 +40,17 @@ COMMENT= An anonymizing overlay network for TCP
LICENSE= BSD
LICENSE_FILE= ${WRKSRC}/LICENSE
-LIB_DEPENDS= event-1.4:${PORTSDIR}/devel/libevent
+LIB_DEPENDS= event-2.0:${PORTSDIR}/devel/libevent2
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+= --with-openssl-dir="${OPENSSLBASE}"
+CONFIGURE_ARGS= --with-openssl-dir="${OPENSSLBASE}" --disable-asciidoc \
+ --enable-linker-hardening
+CONFIGURE_ENV= LDFLAGS="${LDFLAGS}" \
+ TOR_CPPFLAGS_libevent="-I${LOCALBASE}/include/event2 -I${LOCALBASE}/include" \
+ TOR_LDFLAGS_libevent="-L${LOCALBASE}/lib/event2" \
+ TOR_LIBEVENT_LIBS="-levent-2.0"
OPTIONS= BUFFREELISTS "freelists for buffer RAM" on \
- GEOIP "track country data" off \
INSTR_DOWNLOADS "instrument downloads for analysis" off \
TCMALLOC "use the tcmalloc memory allocation library" off \
THREADS "multi-threading support" on \
@@ -65,6 +69,12 @@ MAN1= tor.1 tor-resolve.1 torify.1 tor-gencert.1
.include <bsd.port.pre.mk>
+.if ( (${OSVERSION} >= 703100 && ${OSVERSION} < 800000) || \
+(${OSVERSION} >= 800500 && ${OSVERSION} < 900000) || \
+(${OSVERSION} >= 900003) ) && !defined(USE_GCC)
+CONFIGURE_ARGS+= --enable-gcc-hardening
+.endif
+
.if ( ${OSVERSION} < 704000 || \
(${OSVERSION} >= 800000 && ${OSVERSION} < 801500) || \
(${OSVERSION} >= 900000 && ${OSVERSION} < 900011) )
@@ -78,12 +88,6 @@ CONFIGURE_ARGS+= --enable-buf-freelists
CONFIGURE_ARGS+= --disable-buf-freelists
.endif
-.if defined(WITH_GEOIP)
-CONFIGURE_ARGS+= --enable-geoip-stats
-.else
-CONFIGURE_ARGS+= --disable-geoip-stats
-.endif
-
.if defined(WITH_INSTR_DOWNLOADS)
CONFIGURE_ARGS+= --enable-instrument-downloads
.else
@@ -113,12 +117,14 @@ post-patch:
${WRKSRC}/contrib/tor-tsocks.conf.sample
@${REINPLACE_CMD} -e "s|tor-tsocks.conf|tor-tsocks.conf.sample|g" \
${WRKSRC}/contrib/Makefile.in
- @${REINPLACE_CMD} -e '\|CFLAGS=|{s|-g||;s|-O[0-9]\{0,1\}||;}' \
- -e 's|netinet/in6||g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e '\|^install-data-am:|s|install-docDATA||' \
+ ${WRKSRC}/doc/Makefile.in
post-configure:
@${FIND} -X ${WRKSRC} -type f -name Makefile | ${XARGS} ${REINPLACE_CMD} -e \
"s|-lpthread|${PTHREAD_LIBS}|g"
+ @${REINPLACE_CMD} -e '\|^nodist_man_MANS =|s|$$|${MAN1}|' \
+ ${WRKSRC}/doc/Makefile
post-install:
${MKDIR} /var/run/tor
diff --git a/security/tor/distinfo b/security/tor/distinfo
index 58de8842503b..542120b07952 100644
--- a/security/tor/distinfo
+++ b/security/tor/distinfo
@@ -1,2 +1,2 @@
-SHA256 (tor-0.2.1.30.tar.gz) = f352a1a8ffa469ae251324f89386074074bcffef1a7c6a72caa7e4c2d12ce109
-SIZE (tor-0.2.1.30.tar.gz) = 2447447
+SHA256 (tor-0.2.2.32.tar.gz) = 8744328c10b54950e08ee404a75a0e76865be0615cad6f7ffc8c75af7151ef4d
+SIZE (tor-0.2.2.32.tar.gz) = 2701371
diff --git a/security/tor/files/patch-configure b/security/tor/files/patch-configure
new file mode 100644
index 000000000000..fec931ffb57a
--- /dev/null
+++ b/security/tor/files/patch-configure
@@ -0,0 +1,52 @@
+--- configure.orig 2011-08-27 00:17:47.000000000 -0400
++++ configure 2011-08-30 05:20:28.000000000 -0400
+@@ -2516,7 +2516,7 @@
+ # Check whether --enable-linker-hardening was given.
+ if test "${enable_linker_hardening+set}" = set; then
+ enableval=$enable_linker_hardening; if test x$enableval = xyes; then
+- LDFLAGS="$LDFLAGS -z relro -z now"
++ LDFLAGS="$LDFLAGS -Wl,-z,relro -Wl,-z,now"
+ fi
+ fi
+
+@@ -6503,7 +6503,7 @@
+ ac_res=$ac_cv_search_clock_gettime
+ if test "$ac_res" != no; then
+ test "$ac_res" = "none required" || LIBS="$ac_res $LIBS"
+- have_rt=yes
++# have_rt=yes
+ fi
+
+ if test "$have_rt" = yes; then
+@@ -6512,6 +6512,7 @@
+ fi
+
+
++if false ; then
+ trylibeventdir=""
+
+ # Check whether --with-libevent-dir was given.
+@@ -6922,6 +6923,7 @@
+ LIBS="$tor_saved_LIBS"
+ LDFLAGS="$tor_saved_LDFLAGS"
+ CPPFLAGS="$tor_saved_CPPFLAGS"
++fi
+
+
+
+@@ -7293,6 +7295,7 @@
+ fi
+
+
++if false ; then
+ if test "$enable_static_libevent" = "yes"; then
+ if test "$tor_cv_library_libevent_dir" = "(system)"; then
+ { { echo "$as_me:$LINENO: error: \"You must specify an explicit --with-libevent-dir=x option when using --enable-static-libevent\"" >&5
+@@ -7304,6 +7307,7 @@
+ else
+ TOR_LIBEVENT_LIBS="-levent"
+ fi
++fi
+
+
+
diff --git a/security/tor/files/pkg-message.in b/security/tor/files/pkg-message.in
index e23f4f4c223b..2ab52d393df9 100644
--- a/security/tor/files/pkg-message.in
+++ b/security/tor/files/pkg-message.in
@@ -2,7 +2,7 @@
To enable the tor server, set tor_enable="YES" in your /etc/rc.conf
and edit %%PREFIX%%/etc/tor/torrc. Note that the rc.subr script overrides
many torrc options and is tunable: see %%PREFIX%%/etc/rc.d/tor for details.
-To use the torify script, install the net/tsocks port. After removing the
+To use the torify script, install the net/torsocks port. After removing the
package, or updating to a new version, users may need to delete all files
in /var/db/tor.
================================================================================
diff --git a/security/tor/pkg-plist b/security/tor/pkg-plist
index 9459fabaccee..d1b8fba5195d 100644
--- a/security/tor/pkg-plist
+++ b/security/tor/pkg-plist
@@ -4,6 +4,6 @@ bin/tor-resolve
bin/torify
etc/tor/tor-tsocks.conf.sample
etc/tor/torrc.sample
-share/tor/geoip
-@dirrm share/tor
+%%DATADIR%%/geoip
+@dirrm %%DATADIR%%
@dirrm etc/tor