aboutsummaryrefslogtreecommitdiff
path: root/security/tor
diff options
context:
space:
mode:
authorBrendan Fabeny <bf@FreeBSD.org>2014-02-10 01:35:05 +0000
committerBrendan Fabeny <bf@FreeBSD.org>2014-02-10 01:35:05 +0000
commit6c3c53afb812f6d2d1f68614f02814a4e5f97774 (patch)
tree3b1dc3b0f7585b90c95f64328217d849d699308e /security/tor
parent9ce799d7ee14911da414cf015947c42ee99916fd (diff)
Notes
Diffstat (limited to 'security/tor')
-rw-r--r--security/tor/Makefile84
-rw-r--r--security/tor/files/pkg-message.in18
-rw-r--r--security/tor/pkg-plist9
3 files changed, 24 insertions, 87 deletions
diff --git a/security/tor/Makefile b/security/tor/Makefile
index 8c8b2b8f2681..d19b216f9391 100644
--- a/security/tor/Makefile
+++ b/security/tor/Makefile
@@ -4,46 +4,7 @@
PORTNAME= tor
DISTVERSION= 0.2.4.20
CATEGORIES= security net ipv6
-MASTER_SITES= https://www.torproject.org/dist/ \
- ftp://ftp.bit.nl/mirror/tor/ \
- http://cyberside.net.ee/tor/ \
- http://ftp.bit.nl/mirror/tor/ \
- http://mirror.hessmo.com/tor/dist/ \
- http://mirror.host4site.co.il/torproject.org/dist/ \
- http://mirror.open-networx.org/torproject.org/dist/ \
- http://mirror.tor.hu/dist/ \
- https://mirror.torland.me/torproject.org/dist/ \
- http://mirrors.chaos-darmstadt.de/tor-mirror/dist/ \
- http://theonionrouter.com/dist/ \
- http://tor.amorphis.eu/dist/ \
- http://tor.askapache.com/dist/ \
- http://tor.beme-it.de/dist/ \
- http://tor.blingblingsquad.net/dist/ \
- http://tor.borgmann.tv/dist/ \
- http://tor.ccc.de/dist/ \
- http://tor.cyberarmy.at/dist/ \
- http://tor.dont-know-me.at/dist/ \
- http://tor.factor.cc/dist/ \
- http://tor.homosu.net/dist/ \
- http://tor.idnr.ws/dist/ \
- http://tor.myrl.net/dist/ \
- http://tor.kamagurka.org/dist/ \
- http://tor.spline.de/dist/ \
- http://tor.taiga-san.net/dist/ \
- http://tor.vesta.nu/dist/ \
- http://torproj.xpdm.us/dist/ \
- https://torproject.antagonism.org/dist/ \
- https://torproject.crypto.is/dist/ \
- http://torproject.is/dist/ \
- http://torproject.jcsh.it/dist/ \
- http://torproject.nwlinux.us/dist/ \
- http://torproject.ph3x.at/dist/ \
- https://www.coevoet.nl/tor/dist/ \
- http://www.oignon.net/dist/ \
- http://www.torproject.nl/dist/ \
- http://www.torproject.org.nyud.net/dist/ \
- http://www.torproject.us/dist/ \
- http://www.torservers.net/mirrors/torproject.org/dist/
+MASTER_SITES= TOR
MAINTAINER= bf@FreeBSD.org
COMMENT= An anonymizing overlay network for TCP
@@ -51,18 +12,18 @@ COMMENT= An anonymizing overlay network for TCP
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
+USES= gmake
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-openssl-dir="${OPENSSLBASE}" --disable-asciidoc
CONFIGURE_ENV= TOR_CPPFLAGS_libevent="-I${LOCALBASE}/include/event2 -I${LOCALBASE}/include" \
TOR_LDFLAGS_libevent="-L${LOCALBASE}/lib/event2" \
TOR_LIBEVENT_LIBS="${TOR_LIBEVENT_LIBS}"
-OPTIONS_DEFINE= BUFFEREVENTS BUFFREELISTS GMAKE INSTR_DOWNLOADS \
+OPTIONS_DEFINE= BUFFEREVENTS BUFFREELISTS INSTR_DOWNLOADS \
STATIC_TOR TCMALLOC THREADS TOR2WEB TRANSPARENT
BUFFEREVENTS_DESC= Use libevent's buffered IO
BUFFREELISTS_DESC= Freelists for buffer RAM
-GMAKE_DESC= Parallel build safety via GNU make
INSTR_DOWNLOADS_DESC= Instrument downloads for analysis
STATIC_TOR_DESC= Build a static tor
TCMALLOC_DESC= Use the tcmalloc memory allocation library
@@ -81,20 +42,9 @@ USERS= _tor
CONFLICTS= tor-devel-[0-9]*
-MANCOMPRESSED= no
-MAN1= tor.1 tor-resolve.1 torify.1 tor-gencert.1
-
-NO_STAGE= yes
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MGMAKE}
-USES+= gmake
-.else
-MAKE_JOBS_UNSAFE= yes
-.endif
-
-.if ( (${OSVERSION} >= 703100 && ${OSVERSION} < 800000) || \
-(${OSVERSION} >= 800500 && ${OSVERSION} < 900000) || \
+.if ( (${OSVERSION} < 900000) || \
(${OSVERSION} >= 900003) ) && !defined(USE_GCC) && empty(CC:T:M*gcc4*) && \
empty(PORT_OPTIONS:MSTATIC_TOR) && empty(ARCH:Mia64)
CONFIGURE_ARGS+= --enable-gcc-hardening
@@ -102,16 +52,6 @@ CONFIGURE_ARGS+= --enable-gcc-hardening
CONFIGURE_ARGS+= --disable-gcc-hardening
.endif
-.if ( ${OSVERSION} < 704000 || \
-(${OSVERSION} >= 800000 && ${OSVERSION} < 802000) || \
-(${OSVERSION} >= 900000 && ${OSVERSION} < 900027) )
-WITH_OPENSSL_PORT= yes
-.endif
-
-.if ( ${OSVERSION} < 800038 )
-CPPFLAGS+= -DSTAILQ_ENTRY=SIMPLEQ_ENTRY
-.endif
-
.if ${PORT_OPTIONS:MBUFFEREVENTS}
CONFIGURE_ARGS+= --enable-bufferevents
.else
@@ -181,23 +121,13 @@ post-patch:
post-configure:
@${FIND} -X ${WRKSRC} -type f -name Makefile | ${XARGS} ${REINPLACE_CMD} -e \
"s|-lpthread|${PTHREAD_LIBS}|g"
- @${REINPLACE_CMD} -e '\|^nodist_man1_MANS =|s|$$|${MAN1:S@^@doc/@}|' \
+ @${REINPLACE_CMD} -e '\|^nodist_man1_MANS =|s|$$|$$(regular_mans:=.1)|' \
${WRKSRC}/Makefile
-post-install:
- ${MKDIR} /var/run/tor
- ${CHOWN} -R _tor:_tor /var/run/tor
- ${TOUCH} /var/log/tor
- ${CHOWN} _tor:_tor /var/log/tor
- ${MKDIR} /var/db/tor/data
- ${CHOWN} -R _tor:_tor /var/db/tor
- ${CHMOD} -R 700 /var/db/tor
- ${CAT} ${PKGMESSAGE}
-
-.if empty(PORT_OPTIONS:MTOR2WEB)
+.if ! ${PORT_OPTIONS:MTOR2WEB}
check regression-test test: build
@cd ${BUILD_WRKSRC} ; ${SETENV} ${MAKE_ENV} ${MAKE_CMD} \
- ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} check
+ ${MAKE_ARGS} check
.endif
.include <bsd.port.mk>
diff --git a/security/tor/files/pkg-message.in b/security/tor/files/pkg-message.in
index 2ab52d393df9..b2bf82fa9739 100644
--- a/security/tor/files/pkg-message.in
+++ b/security/tor/files/pkg-message.in
@@ -1,8 +1,16 @@
================================================================================
To enable the tor server, set tor_enable="YES" in your /etc/rc.conf
-and edit %%PREFIX%%/etc/tor/torrc. Note that the rc.subr script overrides
-many torrc options and is tunable: see %%PREFIX%%/etc/rc.d/tor for details.
-To use the torify script, install the net/torsocks port. After removing the
-package, or updating to a new version, users may need to delete all files
-in /var/db/tor.
+and edit %%PREFIX%%/etc/tor/torrc as desired. (However, note that the
+%%PREFIX%%/etc/rc.d/tor rc.subr script can override some torrc
+options: see that script for details.) To use the torify script, install
+the net/torsocks port. After installing tor for the first time, or after
+a major update of tor, you should:
+
+rm -r /var/db/tor /var/run/tor
+mkdir -p /var/db/tor/data /var/run/tor
+touch /var/log/tor
+chown -R _tor:_tor /var/db/tor /var/log/tor /var/run/tor
+chmod -R 700 /var/db/tor
+
+before starting the tor server.
================================================================================
diff --git a/security/tor/pkg-plist b/security/tor/pkg-plist
index cbd123779d29..16c00ba2c634 100644
--- a/security/tor/pkg-plist
+++ b/security/tor/pkg-plist
@@ -4,12 +4,11 @@ bin/tor-gencert
bin/tor-resolve
bin/torify
etc/tor/torrc.sample
+man/man1/tor-gencert.1.gz
+man/man1/tor-resolve.1.gz
+man/man1/tor.1.gz
+man/man1/torify.1.gz
%%DATADIR%%/geoip
%%DATADIR%%/geoip6
@dirrm %%DATADIR%%
@dirrmtry etc/tor
-@cwd /
-@dirrmtry var/run/tor
-@dirrmtry var/db/tor/data
-@dirrmtry var/db/tor
-@cwd