aboutsummaryrefslogtreecommitdiff
path: root/security/tripwire/Makefile
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2009-02-21 00:16:16 +0000
committerCy Schubert <cy@FreeBSD.org>2009-02-21 00:16:16 +0000
commit42de3a6f7c62e0a20f129dfe9d5687946e6c6d58 (patch)
treed56ce5d71df7c58123f55c045e42396fc6b6a015 /security/tripwire/Makefile
parent219952004fb0eb89935f95f5961eea3328275630 (diff)
Notes
Diffstat (limited to 'security/tripwire/Makefile')
-rw-r--r--security/tripwire/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/security/tripwire/Makefile b/security/tripwire/Makefile
index 0f4c89e39fc0..6b56a661cc66 100644
--- a/security/tripwire/Makefile
+++ b/security/tripwire/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= tripwire
-PORTVERSION= 2.4.0.1
+PORTVERSION= 2.4.1.2
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -19,8 +19,7 @@ LATEST_LINK= ${PORTNAME}
MAN5= twfiles.5 twconfig.5 twpolicy.5
MAN8= siggen.8 tripwire.8 twadmin.8 twintro.8 twprint.8
NO_PACKAGE= "requires local database to be built"
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-BUILD_WRKSRC= ${WRKSRC}/src
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-src
USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
@@ -70,9 +69,9 @@ install-config-files:
@ cd ${WRKSRC} && ${LN} -sf install/install.cfg install/install.sh .
.if ( defined(TRIPWIRE_CLOBBER) && ${TRIPWIRE_CLOBBER} == "YES" ) || \
( defined(TRIPWIRE_CLOBBER) && ${TRIPWIRE_CLOBBER} == "yes" )
- @ cd ${WRKSRC} && PREFIX=${PREFIX} ./install.sh -f
+ @ cd ${WRKSRC} && PREFIX=${PREFIX} CLOBBER=true ${GMAKE} install-data-hook
.else
- @ cd ${WRKSRC} && PREFIX=${PREFIX} ./install.sh
+ @ cd ${WRKSRC} && PREFIX=${PREFIX} ${GMAKE} install-data-hook
.endif
create-database: