aboutsummaryrefslogtreecommitdiff
path: root/security/tripwire/Makefile
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>2000-05-29 02:27:45 +0000
committerSteve Price <steve@FreeBSD.org>2000-05-29 02:27:45 +0000
commit0a9a4b5bd26129e33add24cc6b0326df8e0beac2 (patch)
treef44827ca975d1492492f439445fc36bdf97369af /security/tripwire/Makefile
parentfd7636eb2a2c9ca84b31336fba50929e7ad58cc3 (diff)
- Fix some of the compiler warnings (see patches/patch-warnings)
- Fix the Makefiles to obey the CC and CFLAGS settings - Fix patches/patch-ab to be PREFIX/LOCALBASE safe - Fix the post-install to not compress the gunzip and tripwire executables that go onto a floppy -- there is no support for the gzip-ed ELF binaries at all, and even for the older AOUT ones such support was optional - Replaces the /kernel with `sysctl -n kern.bootfile` in the tw.conf as the tw.conf.freebsd2 is copied into the right place. - Replace the use of mktemp(3) with tmpfile(3) (see patches/patch-mktemp). This also caused a removal of a few buffers (of size MAXPATHLEN+256) and quite a few strcpy and sprintf invocations. PR: 18634 Submitted by: Mikhail Teterin <mi@aldan.algebra.com>
Notes
Notes: svn path=/head/; revision=28852
Diffstat (limited to 'security/tripwire/Makefile')
-rw-r--r--security/tripwire/Makefile24
1 files changed, 16 insertions, 8 deletions
diff --git a/security/tripwire/Makefile b/security/tripwire/Makefile
index 070bc8b1ceb8..7c2c4ed201c3 100644
--- a/security/tripwire/Makefile
+++ b/security/tripwire/Makefile
@@ -20,30 +20,38 @@ NO_PACKAGE= "requires local database to be built"
RESTRICTED= "contains crypto class algorithms"
post-extract:
- @ (cd ${WRKDIR}; tar xf T1.2.tar)
+ @ (cd ${WRKDIR}; tar xpf T1.2.tar)
+
+post-patch:
+ @${PERL} -pi -e 's|/secureplace/bin|${PREFIX}/bin|g;' \
+ -e 's|/usr/man|${PREFIX}/man|g;' ${WRKSRC}/Makefile
pre-configure:
@ ${CP} ${FILESDIR}/conf-freebsd2.h ${WRKSRC}/configs
- @ ${CP} ${FILESDIR}/tw.conf.freebsd2 ${WRKSRC}/configs/tw.conf.freebsd2
+ @ ${SED} s%/kernel%`sysctl -bn kern.bootfile`% \
+ < ${FILESDIR}/tw.conf.freebsd2 \
+ > ${WRKSRC}/configs/tw.conf.freebsd2
post-install:
@ ${MKDIR} /var/adm/tcheck
@ ${CP} ${FILESDIR}/tw.conf.freebsd2 /var/adm/tcheck/tw.config
- @ ${ECHO} Creating tripwire database
+ # Creating tripwire database
@ (cd /var/adm/tcheck; tripwire -initialize)
.if defined(TRIPWIRE_FLOPPY) && ${TRIPWIRE_FLOPPY} == YES
+ # preparing the floppy
@ disklabel -w -B /dev/rfd0c fd1440
@ newfs -u 0 -t 0 -i 196608 -m 0 -T minimum -o space /dev/rfd0c
- @ mount /dev/fd0c /mnt
- @ ${GZIP_CMD} < ${PREFIX}/bin/tripwire > /mnt/tripwire
+ mount /dev/fd0c /mnt
+ # transferring things to the floppy
@ ${CP} -p /var/adm/tcheck/tw.config /mnt/tw.config
@ ${GZIP_CMD} < /var/adm/tcheck/databases/tw.db_`hostname` \
> /mnt/tw.db_`hostname`.gz
- @ ${CP} -p ${FILESDIR}/twcheck /mnt/twcheck
- @ ${GZIP_CMD} < /usr/bin/gunzip > /mnt/gunzip
+ @ ${CP} -p ${FILESDIR}/twcheck /usr/bin/gunzip \
+ ${PREFIX}/bin/tripwire \
+ /mnt/
@ ${CHMOD} 555 /mnt/tripwire /mnt/gunzip /mnt/twcheck
@ umount /mnt
- @ ${ECHO} Do not forget to remove and write-protect the floppy.
+ # Do not forget to remove and write-protect the floppy.
.endif
.include <bsd.port.mk>