aboutsummaryrefslogtreecommitdiff
path: root/security/tthsum/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2011-10-15 08:33:06 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2011-10-15 08:33:06 +0000
commitcc952036a6682787cdba9508df73af4c9a0519db (patch)
tree359e4b13d7d8305f4866132d35e872ee4c99d5f6 /security/tthsum/Makefile
parentfcdb59b306cd3d1292a158ca8ce3aecbbe2f9709 (diff)
downloadports-cc952036a6682787cdba9508df73af4c9a0519db.tar.gz
ports-cc952036a6682787cdba9508df73af4c9a0519db.zip
Notes
Diffstat (limited to 'security/tthsum/Makefile')
-rw-r--r--security/tthsum/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/security/tthsum/Makefile b/security/tthsum/Makefile
index 8be11991f8db..21ea2b73dde7 100644
--- a/security/tthsum/Makefile
+++ b/security/tthsum/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= tthsum
-PORTVERSION= 1.2.1
+PORTVERSION= 1.3.0
CATEGORIES= security
MASTER_SITES= http://tthsum.devs.nu/pkg/ \
CRITICAL
@@ -14,6 +14,8 @@ MASTER_SITES= http://tthsum.devs.nu/pkg/ \
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= A command-line utility for generating and checking TTH message digests
+LICENSE= GPLv3
+
USE_GMAKE= yes
MANCOMPRESSED= yes
@@ -22,4 +24,7 @@ MAKE_JOBS_SAFE= yes
MAN1= tthsum.1
PLIST_FILES= bin/tthsum
+regression-test: build
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} test runtest
+
.include <bsd.port.mk>