aboutsummaryrefslogtreecommitdiff
path: root/security/tthsum
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2013-08-14 12:44:56 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2013-08-14 12:44:56 +0000
commit192975256bbc28cebe950c7ccdeb5dc29e0915ce (patch)
treeab5c652533105202e03abb913f5b85d9e3111fa2 /security/tthsum
parent2101a40e90f940dff1c302e94fc52644c5f42c4d (diff)
Notes
Diffstat (limited to 'security/tthsum')
-rw-r--r--security/tthsum/Makefile5
-rw-r--r--security/tthsum/distinfo4
-rw-r--r--security/tthsum/files/patch-Makefile18
3 files changed, 17 insertions, 10 deletions
diff --git a/security/tthsum/Makefile b/security/tthsum/Makefile
index 72a638f7db68..cf6b69f921a4 100644
--- a/security/tthsum/Makefile
+++ b/security/tthsum/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= tthsum
-PORTVERSION= 1.3.1
-PORTREVISION= 1
+PORTVERSION= 1.3.2
CATEGORIES= security
MASTER_SITES= http://tthsum.devs.nu/pkg/ \
CRITICAL
@@ -21,6 +20,8 @@ MANCOMPRESSED= yes
MAN1= tthsum.1
PLIST_FILES= bin/tthsum
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
regression-test: build
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} test runtest
diff --git a/security/tthsum/distinfo b/security/tthsum/distinfo
index 6f15020542fa..a8323cce9404 100644
--- a/security/tthsum/distinfo
+++ b/security/tthsum/distinfo
@@ -1,2 +1,2 @@
-SHA256 (tthsum-1.3.1.tar.gz) = b141e585884144e90c4cc63872b0bfddc32db3d842a406d8b8a744db82736da5
-SIZE (tthsum-1.3.1.tar.gz) = 78989
+SHA256 (tthsum-1.3.2.tar.gz) = 49d9e2b37ff69a831f271584fc35c358c28523c8595c95f3a1fa18b2951b00f2
+SIZE (tthsum-1.3.2.tar.gz) = 88434
diff --git a/security/tthsum/files/patch-Makefile b/security/tthsum/files/patch-Makefile
index 74615254de2c..5ec8ace69e3b 100644
--- a/security/tthsum/files/patch-Makefile
+++ b/security/tthsum/files/patch-Makefile
@@ -1,5 +1,5 @@
---- ./Makefile.orig 2011-10-10 08:34:43.000000000 +0200
-+++ ./Makefile 2011-10-15 10:22:58.000000000 +0200
+--- ./Makefile.orig 2013-08-13 20:58:36.000000000 +0200
++++ ./Makefile 2013-08-14 14:40:58.335943659 +0200
@@ -11,16 +11,6 @@
MAN = $(DESTDIR)/usr/local/man
endif
@@ -17,7 +17,7 @@
CC ?= gcc
GZIP = gzip -9 -c
RM = rm -rf
-@@ -45,9 +35,9 @@
+@@ -47,12 +37,12 @@
override CPPFLAGS += $(shell cat $(BINS)/autoconf.cppflags)
@@ -25,7 +25,13 @@
+all: tthsum manual
-install: tthsum manual test runtest
+- install -d $(BIN) $(MAN)/man1
+- install $(BINS)/tthsum $(BIN)
+- install -m644 $(SHARES)/tthsum.1.gz $(MAN)/man1
+install: tthsum manual
- install -d $(BIN) $(MAN)/man1
- install $(BINS)/tthsum $(BIN)
- install -m644 $(SHARES)/tthsum.1.gz $(MAN)/man1
++ install -d $(BIN) $(MANPREFIX)/man/man1
++ install $(BINS)/tthsum $(PREFIX)/bin
++ install -m644 $(SHARES)/tthsum.1.gz $(MANPREFIX)/man/man1
+
+ uninstall:
+ $(RM) $(BIN)/tthsum