aboutsummaryrefslogtreecommitdiff
path: root/security/tuntun
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-10-16 21:43:35 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-10-16 21:43:35 +0000
commit7b79f0ccb4ead5654bab3d5efefd0680e43e147d (patch)
tree49e43826637b44c66d1ca7fa3e47e6d90c870536 /security/tuntun
parent52ca764a5d8eaf37b31334423b0f2955975a8492 (diff)
downloadports-7b79f0ccb4ead5654bab3d5efefd0680e43e147d.tar.gz
ports-7b79f0ccb4ead5654bab3d5efefd0680e43e147d.zip
Notes
Diffstat (limited to 'security/tuntun')
-rw-r--r--security/tuntun/Makefile22
-rw-r--r--security/tuntun/distinfo3
-rw-r--r--security/tuntun/files/patch-gnio46
-rw-r--r--security/tuntun/files/patch-po11
-rw-r--r--security/tuntun/files/patch-tuntun.server10
-rw-r--r--security/tuntun/pkg-descr12
-rw-r--r--security/tuntun/pkg-plist25
7 files changed, 129 insertions, 0 deletions
diff --git a/security/tuntun/Makefile b/security/tuntun/Makefile
new file mode 100644
index 000000000000..450737825e0c
--- /dev/null
+++ b/security/tuntun/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: tuntun
+# Date created: 2008-09-16
+# Whom: Anderson S. Ferreira <anderson@cnpm.embrapa.br>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tuntun
+PORTVERSION= 0.3.1
+CATEGORIES= security gnome
+MASTER_SITES= http://tuntun.googlecode.com/files/
+
+MAINTAINER= anderson@cnpm.embrapa.br
+COMMENT= A Gnome applet gui for OpenVPN
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --libdir=${PREFIX}/libdata/servers
+USE_GMAKE= yes
+
+USE_GNOME= gnomehier intlhack gnomeprefix gnomehack gnomepanel glib20
+
+.include <bsd.port.mk>
diff --git a/security/tuntun/distinfo b/security/tuntun/distinfo
new file mode 100644
index 000000000000..4bc5cfab2e4b
--- /dev/null
+++ b/security/tuntun/distinfo
@@ -0,0 +1,3 @@
+MD5 (tuntun-0.3.1.tar.gz) = 0bd7807e466cb2ea133a9478d4d15e61
+SHA256 (tuntun-0.3.1.tar.gz) = 4d4abca12fbf430402ef0189cfaf1a2d6551cf3faa570b81d18500503c004819
+SIZE (tuntun-0.3.1.tar.gz) = 558837
diff --git a/security/tuntun/files/patch-gnio b/security/tuntun/files/patch-gnio
new file mode 100644
index 000000000000..e8ca5df1d078
--- /dev/null
+++ b/security/tuntun/files/patch-gnio
@@ -0,0 +1,46 @@
+--- gnio.build.patch.orig 2008-09-16 08:20:43.000000000 -0300
++++ gnio.build.patch 2008-09-16 11:08:44.000000000 -0300
+@@ -31,3 +31,43 @@
+ bld.install_files('PREFIX', 'include/gnio', 'gnio/gi*.h')
+ bld.install_files('PREFIX', 'include/gnio', 'gnio/gn*.h')
+ bld.install_files('PREFIX', 'include/gnio', 'gnio/gr*.h')
++--- gnio/gnio/ginet4address.c.orig 2008-06-16 09:00:35.000000000 -0300
+++++ gnio/gnio/ginet4address.c 2008-09-16 09:39:55.000000000 -0300
++@@ -23,6 +23,7 @@
++
++ #include <config.h>
++ #include <glib.h>
+++#include <sys/types.h>
++
++ #ifndef G_OS_WIN32
++ # include <netinet/in.h>
++--- gnio/gnio/ginet6address.c.orig 2008-06-16 09:00:35.000000000 -0300
+++++ gnio/gnio/ginet6address.c 2008-09-16 09:39:55.000000000 -0300
++@@ -27,6 +27,7 @@
++
++ #include <netinet/in.h>
++ #include <arpa/inet.h>
+++#include <sys/socket.h>
++
++ #include "ginet6address.h"
++
++--- gnio/gnio/gresolver.c.orig 2008-07-09 18:15:16.000000000 -0300
+++++ gnio/gnio/gresolver.c 2008-09-16 09:39:55.000000000 -0300
++@@ -24,6 +24,7 @@
++ #include <config.h>
++ #include <glib.h>
++ #include <gio/gio.h>
+++#include <sys/socket.h>
++
++ #include <string.h>
++ #ifndef G_OS_WIN32
++--- gnio/gnio/gsocket.c.orig 2008-07-09 18:15:16.000000000 -0300
+++++ gnio/gnio/gsocket.c 2008-09-16 09:39:55.000000000 -0300
++@@ -27,6 +27,7 @@
++ #include <gnio/gnio.h>
++ #include "gasynchelper.h"
++ #include "gnioenums.h"
+++#include <sys/socket.h>
++
++ #include <string.h>
++ #ifndef G_OS_WIN32
diff --git a/security/tuntun/files/patch-po b/security/tuntun/files/patch-po
new file mode 100644
index 000000000000..c1116dd9863c
--- /dev/null
+++ b/security/tuntun/files/patch-po
@@ -0,0 +1,11 @@
+--- po/Makefile.in.in.orig 2008-09-16 11:15:56.000000000 -0300
++++ po/Makefile.in.in 2008-09-16 11:16:40.000000000 -0300
+@@ -44,7 +44,7 @@
+ INSTALL = @INSTALL@
+ INSTALL_DATA = @INSTALL_DATA@
+
+-GMSGFMT = @GMSGFMT@
++GMSGFMT = @MSGFMT@
+ MSGFMT = @MSGFMT@
+ XGETTEXT = @XGETTEXT@
+ INTLTOOL_UPDATE = @INTLTOOL_UPDATE@
diff --git a/security/tuntun/files/patch-tuntun.server b/security/tuntun/files/patch-tuntun.server
new file mode 100644
index 000000000000..b8f75c0122a7
--- /dev/null
+++ b/security/tuntun/files/patch-tuntun.server
@@ -0,0 +1,10 @@
+--- src/tuntun.server.in 2008-09-16 11:10:52.000000000 -0300
++++ src/tuntun.server.in 2008-09-16 11:11:36.000000000 -0300
+@@ -1,6 +1,6 @@
+ <oaf_info>
+ <oaf_server iid="OAFIID:GNOME_Tuntun_Factory" type="exe"
+- location="/usr/lib/gnome-applets/tuntun">
++ location="/usr/local/libexec/tuntun">
+
+ <oaf_attribute name="repo_ids" type="stringv">
+ <item value="IDL:Bonobo/GenericFactory:1.0"/>
diff --git a/security/tuntun/pkg-descr b/security/tuntun/pkg-descr
new file mode 100644
index 000000000000..c529ce002913
--- /dev/null
+++ b/security/tuntun/pkg-descr
@@ -0,0 +1,12 @@
+Tuntun is an applet for Gnome panel that manage a list of vpn connections
+through the OpenVPN Management Interface.
+
+Main features
+
+ * Simple & lightweight just a client GUI to start/stop your OpenVPN tunnels
+ and nothing more
+ * Integrated with the Gnome Desktop (support for the Keyring and notification
+ daemon)
+ * Support for Auth and Private-Key OpenVPN authentication methods
+
+ WWW: http://code.google.com/p/tuntun/
diff --git a/security/tuntun/pkg-plist b/security/tuntun/pkg-plist
new file mode 100644
index 000000000000..48b0bb647f91
--- /dev/null
+++ b/security/tuntun/pkg-plist
@@ -0,0 +1,25 @@
+libdata/bonobo/servers/tuntun.server
+libexec/tuntun
+share/locale/it/LC_MESSAGES/tuntun.mo
+share/locale/lv/LC_MESSAGES/tuntun.mo
+share/pixmaps/tuntun-icon.png
+share/tuntun/ui/tuntun.ui
+share/tuntun/ui/tuntun-auth-dialog.ui
+share/tuntun/pixmaps/tuntun.png
+share/tuntun/pixmaps/tuntun_act_1.png
+share/tuntun/pixmaps/tuntun_act_2.png
+share/tuntun/pixmaps/connect.png
+share/tuntun/pixmaps/connected.png
+share/tuntun/pixmaps/disconnect.png
+share/tuntun/pixmaps/not_connected.png
+share/tuntun/pixmaps/unknown.png
+share/doc/tuntun/AUTHORS
+share/doc/tuntun/COPYING
+share/doc/tuntun/ChangeLog
+share/doc/tuntun/INSTALL
+share/doc/tuntun/NEWS
+share/doc/tuntun/README
+@dirrm share/doc/tuntun
+@dirrm share/tuntun/pixmaps
+@dirrm share/tuntun/ui
+@dirrm share/tuntun