aboutsummaryrefslogtreecommitdiff
path: root/security/umit/Makefile
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2007-04-20 18:05:55 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2007-04-20 18:05:55 +0000
commit966eac9a6b4546ab46975e821656cf7d3fa9b360 (patch)
tree019d2e340123a8f489d48cfba356ce688c6ede1b /security/umit/Makefile
parentb39aab511cae0fae2f11eec4bcb3873e074df60e (diff)
downloadports-966eac9a6b4546ab46975e821656cf7d3fa9b360.tar.gz
ports-966eac9a6b4546ab46975e821656cf7d3fa9b360.zip
Notes
Diffstat (limited to 'security/umit/Makefile')
-rw-r--r--security/umit/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/security/umit/Makefile b/security/umit/Makefile
new file mode 100644
index 000000000000..201738a5ba7f
--- /dev/null
+++ b/security/umit/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: umit
+# Date created: 20 April 2007
+# Whom: Elisey Savateev <b3k@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= umit
+PORTVERSION= 0.9.3
+CATEGORIES= security
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ http://bio3k.softboard.ru/uploads/arch/
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= b3k@mail.ru
+COMMENT= UMIT is the nmap frontend developed with Python and PyGTK
+
+RUN_DEPENDS= ${LOCALBASE}/bin/nmap:${PORTSDIR}/security/nmap \
+ ${PYTHON_SITELIBDIR}/pysqlite2/__init__.py:${PORTSDIR}/databases/py-pysqlite23
+
+USE_BZIP2= yes
+USE_PYTHON= yes
+USE_GNOME= pygtk2
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386"
+WITHOUT_PSYCO= yes
+.endif
+
+.ifndef(WITHOUT_PSYCO)
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/psyco/_psyco.so:${PORTSDIR}/devel/py-psyco
+.endif
+
+pre-everything::
+.ifndef(WITHOUT_PSYCO)
+ @${ECHO_MSG} '===> Define WITHOUT_PSYCO to disable devel/py-psyco optimization'
+.endif
+
+do-build:
+ cd ${WRKSRC} && ${PYTHON_CMD} setup.py build
+
+do-install:
+ cd ${WRKSRC} && ${PYTHON_CMD} setup.py install --prefix ${PREFIX}
+
+.include <bsd.port.post.mk>