aboutsummaryrefslogtreecommitdiff
path: root/security/unicornscan
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2016-03-20 10:53:08 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2016-03-20 10:53:08 +0000
commit654ccc6aac9c7681ed39c2cd2d10d8360ec7a9bc (patch)
treec30aa05ffe4be67ca3bb38317073b7e6603daa7c /security/unicornscan
parent3dc362ac88ab73d6f0b3635628a59d9597e6da4e (diff)
downloadports-654ccc6aac9c7681ed39c2cd2d10d8360ec7a9bc.tar.gz
ports-654ccc6aac9c7681ed39c2cd2d10d8360ec7a9bc.zip
Notes
Diffstat (limited to 'security/unicornscan')
-rw-r--r--security/unicornscan/Makefile4
-rw-r--r--security/unicornscan/files/patch-libs__Makefile8
-rw-r--r--security/unicornscan/files/patch-src-scan_progs-Makefile2
-rw-r--r--security/unicornscan/files/patch-src__Makefile17
-rw-r--r--security/unicornscan/files/patch-src__Makefile.inc14
5 files changed, 13 insertions, 32 deletions
diff --git a/security/unicornscan/Makefile b/security/unicornscan/Makefile
index d9b6f76f448a..aafdf96ece3f 100644
--- a/security/unicornscan/Makefile
+++ b/security/unicornscan/Makefile
@@ -15,15 +15,11 @@ LICENSE= GPLv2
LIB_DEPENDS= libnet.so:${PORTSDIR}/net/libnet
USES= gmake
-MAKE_ENV= LIBNET_CONFIG="${LIBNET_CONFIG}"
CFLAGS+= -DWITH_LONGOPTS
-LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
SUB_FILES= pkg-message
post-patch:
- @${REINPLACE_CMD} -e 's|-lnet|`${LIBNET_CONFIG} --libs`|' \
- ${WRKSRC}/src/scan_progs/Makefile ${WRKSRC}/src/tools/Makefile
@${REINPLACE_CMD} -e 's|/usr/local/share|${PREFIX}/etc|' \
${WRKSRC}/fconf/unicorn.conf
# Unbreak the build against Clang (it does not like one function being inline)
diff --git a/security/unicornscan/files/patch-libs__Makefile b/security/unicornscan/files/patch-libs__Makefile
index ee72e98bea78..e3df8c0a7b3c 100644
--- a/security/unicornscan/files/patch-libs__Makefile
+++ b/security/unicornscan/files/patch-libs__Makefile
@@ -1,6 +1,6 @@
---- libs/Makefile.orig Thu Sep 30 07:29:05 2004
-+++ libs/Makefile Fri Sep 29 14:32:37 2006
-@@ -6,30 +6,10 @@
+--- libs/Makefile.orig 2004-09-30 10:29:05 UTC
++++ libs/Makefile
+@@ -6,30 +6,10 @@ CFLAGS=$(MYCFLAGS)
default: pcap_test libnet_test
pcap_test: pcap_test.c
@@ -29,7 +29,7 @@
-
-libpcap-$(PCAPVER).tar.gz:
- wget http://tcpdump.org/release/libpcap-$(PCAPVER).tar.gz
-+ $(CC) $(CFLAGS) -o libnet_test libnet_test.c -lpcap `$(LIBNET_CONFIG) --libs` $(LDADD)
++ $(CC) $(CFLAGS) -o libnet_test libnet_test.c -lpcap -lnet $(LDADD)
clean:
- rm -rf fake libnet libpcap-$(PCAPVER) pcap_test libnet_test
diff --git a/security/unicornscan/files/patch-src-scan_progs-Makefile b/security/unicornscan/files/patch-src-scan_progs-Makefile
index 1142697748e3..b82ebdb45ece 100644
--- a/security/unicornscan/files/patch-src-scan_progs-Makefile
+++ b/security/unicornscan/files/patch-src-scan_progs-Makefile
@@ -18,7 +18,7 @@
+ $(CC) -c $(ENTRY) $(CFLAGS) -DBUILD_IDENT_RECV=1 -o $@
+
+$(SENDERNAME): $(S_OBJS) $(G_HDRS) $(S_HDRS) $(C_OBJS) entry_send.o
-+ $(CC) $(CFLAGS) -o $(SENDERNAME) $(S_OBJS) $(C_OBJS) entry_send.o $(G_LDADD) -lpcap `/usr/local/bin/libnet11-config --libs` $(LDADD)
++ $(CC) $(CFLAGS) -o $(SENDERNAME) $(S_OBJS) $(C_OBJS) entry_send.o $(G_LDADD) -lpcap -lnet $(LDADD)
+
+$(LISTENERNAME): $(L_OBJS) $(G_HDRS) $(L_HDRS) $(C_OBJS) entry_recv.o
+ $(CC) $(CFLAGS) -o $(LISTENERNAME) $(L_OBJS) $(C_OBJS) entry_recv.o $(G_LDADD) -lpcap $(LDADD)
diff --git a/security/unicornscan/files/patch-src__Makefile b/security/unicornscan/files/patch-src__Makefile
index 4657bc84d3dc..21eb9916cb34 100644
--- a/security/unicornscan/files/patch-src__Makefile
+++ b/security/unicornscan/files/patch-src__Makefile
@@ -1,17 +1,6 @@
---- src/Makefile.orig Thu Sep 30 07:29:05 2004
-+++ src/Makefile Fri Sep 29 14:32:21 2006
-@@ -4,8 +4,8 @@
- HDRS=$(SRCS:.c=.h) config.h settings.h
- OBJS=$(SRCS:.c=.o)
-
--CFLAGS=$(MYCFLAGS)
--LIBS=-lscan -luni -lparse -lpcap -lnet $(LDADD)
-+CFLAGS+=$(MYCFLAGS)
-+LIBS=-lscan -luni -lparse -lpcap `$(LIBNET_CONFIG) --libs` $(LDADD)
- LIBDIRS=-L./unilib -L./scan_progs -L./parse -L../libs/fake/lib
- TARGETNAME=unicornscan
-
-@@ -19,42 +19,42 @@
+--- src/Makefile.orig 2004-09-30 10:29:05 UTC
++++ src/Makefile
+@@ -19,42 +19,42 @@ compile.h:
./compiledby.sh > compile.h
unilib_d:
diff --git a/security/unicornscan/files/patch-src__Makefile.inc b/security/unicornscan/files/patch-src__Makefile.inc
index f075f850d900..bbd19260fef1 100644
--- a/security/unicornscan/files/patch-src__Makefile.inc
+++ b/security/unicornscan/files/patch-src__Makefile.inc
@@ -1,5 +1,5 @@
---- src/Makefile.inc.orig Thu Sep 30 07:29:05 2004
-+++ src/Makefile.inc Thu Sep 28 14:08:32 2006
+--- src/Makefile.inc.orig 2004-09-30 10:29:05 UTC
++++ src/Makefile.inc
@@ -1,14 +1,13 @@
# gcc only
-CC=gcc
@@ -14,16 +14,12 @@
# its fine to do almost anything here, just dont remove the includes
-MYCFLAGS=-O1 -ggdb -Wall -Wshadow -Wcast-align -Wcast-qual -Wchar-subscripts -Wno-deprecated-declarations -Wformat-security -Wimplicit -Wsign-compare -Wuninitialized -Wunused -Wwrite-strings -I. -rdynamic -I../libs/fake/include -I/usr/local/include -L/usr/local/lib -DPREFIX=\"$(PREFIX)\" -DLOCALSTATEDIR=\"$(LOCALSTATEDIR)\" -DTARGETNAME=\"$(TARGETNAME)\" -DSENDERNAME=\"$(SENDERNAME)\" -DLISTENERNAME=\"$(LISTENERNAME)\"
-+MYCFLAGS:=$(CFLAGS) -Wall -Wshadow -Wcast-align -Wcast-qual -Wchar-subscripts -Wno-deprecated-declarations -Wformat-security -Wimplicit -Wsign-compare -Wuninitialized -Wunused -Wwrite-strings -I. -rdynamic -I../libs/fake/include `$(LIBNET_CONFIG) --defines` `$(LIBNET_CONFIG) --cflags` -DPREFIX=\"$(PREFIX)\" -DLOCALSTATEDIR=\"$(LOCALSTATEDIR)\" -DTARGETNAME=\"$(TARGETNAME)\" -DSENDERNAME=\"$(SENDERNAME)\" -DLISTENERNAME=\"$(LISTENERNAME)\"
++MYCFLAGS:=$(CFLAGS) -Wall -Wshadow -Wcast-align -Wcast-qual -Wchar-subscripts -Wno-deprecated-declarations -Wformat-security -Wimplicit -Wsign-compare -Wuninitialized -Wunused -Wwrite-strings -I. -rdynamic -I../libs/fake/include -I/usr/local/include -L/usr/local/lib -DPREFIX=\"$(PREFIX)\" -DLOCALSTATEDIR=\"$(LOCALSTATEDIR)\" -DTARGETNAME=\"$(TARGETNAME)\" -DSENDERNAME=\"$(SENDERNAME)\" -DLISTENERNAME=\"$(LISTENERNAME)\"
# sometimes you dont have a link to gmake, if your make _is_ gmake, you can use make then, but we need GNU make (for now)
MAKE=gmake
-@@ -23,10 +22,10 @@
- #LDADD=-lsocket -lnsl -ldl -lposix4 -lresolv
-
- # freebsd, netbsd example
--#LDADD=
-+LDADD=
+@@ -26,7 +25,7 @@ MAKE=gmake
+ #LDADD=
# linux example
-LDADD=-ldl