aboutsummaryrefslogtreecommitdiff
path: root/security/vida
diff options
context:
space:
mode:
authorMichael Landin <mich@FreeBSD.org>2003-05-15 13:59:37 +0000
committerMichael Landin <mich@FreeBSD.org>2003-05-15 13:59:37 +0000
commite75cf91623f672999820ed5a0c19f478461a4b3a (patch)
tree7df7469f3129442dfe3b757c7a0c56eb3f355a5c /security/vida
parent52c517532fd0d92edbfdf352845eddbe3c42c09a (diff)
downloadports-e75cf91623f672999820ed5a0c19f478461a4b3a.tar.gz
ports-e75cf91623f672999820ed5a0c19f478461a4b3a.zip
Notes
Diffstat (limited to 'security/vida')
-rw-r--r--security/vida/Makefile33
-rw-r--r--security/vida/distinfo1
-rw-r--r--security/vida/files/patch-aa18
-rw-r--r--security/vida/pkg-descr20
-rw-r--r--security/vida/pkg-plist1
5 files changed, 73 insertions, 0 deletions
diff --git a/security/vida/Makefile b/security/vida/Makefile
new file mode 100644
index 000000000000..0572aca11da7
--- /dev/null
+++ b/security/vida/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: vida
+# Date created: Thu Apr 17 11:22:35 GMT 2003
+# Whom: mich@freebsdcluster.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= vida
+PORTVERSION= 0.7.1
+CATEGORIES= security
+MASTER_SITES= http://vidatapipe.sourceforge.net/
+
+MAINTAINER= mich@FreeBSD.org
+COMMENT= Vida is a multi-datapipe handler
+
+BUILD_DEPENDS= ${LOCALBASE}/include/libnet.h:${PORTSDIR}/net/libnet
+
+LDFLAGS+= -pthread -lncurses -lpcap -lnet
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+do-build:
+ cd ${WRKSRC} && \
+ ${CC} -I${LOCALBASE}/include -L${LOCALBASE}/lib ${CFLAGS} vida.c funz.c dnshijacking.c \
+ ${LDFLAGS} `libnet-config --defines` -o ${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/vida.1.gz ${PREFIX}/man/man1/
+
+MAN1= vida.1
+MANCOMPRESSED= yes
+.include <bsd.port.mk>
diff --git a/security/vida/distinfo b/security/vida/distinfo
new file mode 100644
index 000000000000..4c9fef3d4c2b
--- /dev/null
+++ b/security/vida/distinfo
@@ -0,0 +1 @@
+MD5 (vida-0.7.1.tar.gz) = 032049c11eb018c27047b7be98b2919f
diff --git a/security/vida/files/patch-aa b/security/vida/files/patch-aa
new file mode 100644
index 000000000000..45e2373ad4a4
--- /dev/null
+++ b/security/vida/files/patch-aa
@@ -0,0 +1,18 @@
+--- include.h.orig Thu Apr 17 11:36:06 2003
++++ include.h Thu Apr 17 11:36:19 2003
+@@ -24,13 +24,13 @@
+ * *
+ \*____________________________________________*/
+
+-#include <sys/socket.h>
+ #include <sys/types.h>
++#include <sys/socket.h>
+ #include <sys/wait.h>
+ #include <netinet/in.h>
+ #include <netdb.h>
+ #include <string.h>
+-#include <malloc.h>
++#include <stdlib.h>
+ #include <errno.h>
+ #include <unistd.h>
+ #include <sys/types.h>
diff --git a/security/vida/pkg-descr b/security/vida/pkg-descr
new file mode 100644
index 000000000000..8d2a86e8fbcf
--- /dev/null
+++ b/security/vida/pkg-descr
@@ -0,0 +1,20 @@
+Vida is a multi-datapipe handler, written in C with ncurses library,
+for unix and unix-like OS.
+
+Features:
+- visual interface built with ncurses library
+- multiple datapipes
+- multiple connections for each datapipe
+- password authentication over datapipes
+- computes the total of sent and received bytes
+- sniffing a routed connection (monodirectional, bidirectional and to
+ colors, packages matching a string)
+- simple hijacking of a routed connection (in both directions)
+- dns-hijacking of a dns-spoofed connection over switched LAN (todo)
+- logging to text fil
+
+WWW: http://vidatapipe.sourceforge.net/
+AUTHOR: <embyte@madlab.it>
+
+ - Michael L. Hostbaek
+ <mich@FreeBSD.org>
diff --git a/security/vida/pkg-plist b/security/vida/pkg-plist
new file mode 100644
index 000000000000..16de60db7935
--- /dev/null
+++ b/security/vida/pkg-plist
@@ -0,0 +1 @@
+bin/vida