aboutsummaryrefslogtreecommitdiff
path: root/security/vpnc
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2011-11-10 21:52:29 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2011-11-10 21:52:29 +0000
commite1ef09c0965f694288fb29f9fb14247a6f578bd8 (patch)
treeaa79cd75d1d0783a431d90f7ab2e6816d30f159c /security/vpnc
parent84509f9c283b28e019e610b0bc81a9c12fac1056 (diff)
Fix handling of /etc/resolv.conf during connect/disconnect. Now that FreeBSD 9.x
has a script called /sbin/resolvconf it tried to use the Debian, Ubuntu, Gentoo syntax which is incompatible with FreeBSD's version of the script and will therefore fail. Feature safe: yes
Notes
Notes: svn path=/head/; revision=285477
Diffstat (limited to 'security/vpnc')
-rw-r--r--security/vpnc/Makefile2
-rw-r--r--security/vpnc/files/patch-vpnc-script.in17
2 files changed, 15 insertions, 4 deletions
diff --git a/security/vpnc/Makefile b/security/vpnc/Makefile
index 34e2f413ee9b..cce212d02e48 100644
--- a/security/vpnc/Makefile
+++ b/security/vpnc/Makefile
@@ -7,7 +7,7 @@
PORTNAME= vpnc
PORTVERSION= 0.5.3
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= security
MASTER_SITES= http://www.unix-ag.uni-kl.de/~massar/vpnc/ \
CRITICAL
diff --git a/security/vpnc/files/patch-vpnc-script.in b/security/vpnc/files/patch-vpnc-script.in
index 591456134b6b..98e0112703b0 100644
--- a/security/vpnc/files/patch-vpnc-script.in
+++ b/security/vpnc/files/patch-vpnc-script.in
@@ -1,5 +1,5 @@
---- vpnc-script.in.orig 2008-11-24 00:18:37.000000000 +0100
-+++ vpnc-script.in 2008-11-24 00:21:54.000000000 +0100
+--- vpnc-script.in.orig 2008-11-19 21:55:51.000000000 +0100
++++ vpnc-script.in 2011-11-10 22:41:12.000000000 +0100
@@ -48,8 +48,8 @@
OS="`uname -s`"
@@ -11,7 +11,18 @@
FULL_SCRIPTNAME=@PREFIX@/sbin/vpnc
SCRIPTNAME=`basename $FULL_SCRIPTNAME`
-@@ -420,11 +420,13 @@
+@@ -73,7 +73,9 @@
+ route_syntax_netmask="-netmask"
+ fi
+
+-if [ -x /sbin/resolvconf ]; then # Optional tool on Debian, Ubuntu, Gentoo
++# Optional tool on Debian, Ubuntu, Gentoo, FreeBSD 9.0-RELEASE has a different,
++# incompatible /sbin/resolvconf implementation
++if [ -x /sbin/resolvconf ] && [ "$OS" = "Linux" ]; then
+ MODIFYRESOLVCONF=modify_resolvconf_manager
+ RESTORERESOLVCONF=restore_resolvconf_manager
+ elif [ -x /sbin/modify_resolvconf ]; then # Mandatory tool on Suse earlier than 11.1
+@@ -420,11 +422,13 @@
fi
fi
elif [ "$OS" = "FreeBSD" ]; then