aboutsummaryrefslogtreecommitdiff
path: root/security/vpnc
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-03-21 09:59:20 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-03-21 09:59:20 +0000
commit3eaaec99dde9e2d8b9d98ec592d998cfff62880a (patch)
treebe52a3ed73513b28017e4f5d1ea07c69d1817a72 /security/vpnc
parent57330813f3b10942268915b6f2c3b6d0d0bab3a8 (diff)
downloadports-3eaaec99dde9e2d8b9d98ec592d998cfff62880a.tar.gz
ports-3eaaec99dde9e2d8b9d98ec592d998cfff62880a.zip
Notes
Diffstat (limited to 'security/vpnc')
-rw-r--r--security/vpnc/Makefile1
-rw-r--r--security/vpnc/files/patch-config.c9
2 files changed, 10 insertions, 0 deletions
diff --git a/security/vpnc/Makefile b/security/vpnc/Makefile
index 9a5d76653d99..95292c3e3850 100644
--- a/security/vpnc/Makefile
+++ b/security/vpnc/Makefile
@@ -7,6 +7,7 @@
PORTNAME= vpnc
PORTVERSION= 0.4.0
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://www.unix-ag.uni-kl.de/~massar/vpnc/
diff --git a/security/vpnc/files/patch-config.c b/security/vpnc/files/patch-config.c
index 1aaf9d85e3f7..4bd18adbc238 100644
--- a/security/vpnc/files/patch-config.c
+++ b/security/vpnc/files/patch-config.c
@@ -15,6 +15,15 @@
}
static const char *config_def_vendor(void)
+@@ -485,7 +485,7 @@
+ {
+ char *realname;
+
+- asprintf(&realname, "%s%s%s", index(name, '/') ? "" : "/etc/vpnc/", name, add_dot_conf ? ".conf" : "");
++ asprintf(&realname, "%s%s%s", index(name, '/') ? "" : "%%PREFIX%%/etc/vpnc/", name, add_dot_conf ? ".conf" : "");
+ return realname;
+ }
+
@@ -701,8 +701,8 @@
}