aboutsummaryrefslogtreecommitdiff
path: root/security/vpnc
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2004-11-23 14:43:51 +0000
committerVolker Stolz <vs@FreeBSD.org>2004-11-23 14:43:51 +0000
commit1b48d93a5bd318d78a3dad79ec5793a588b79bc5 (patch)
tree3adb7e4f236331e4b66799024340b35a62492f9c /security/vpnc
parenta8a50c1f9a2ad8d3b2e02a3d805d9045f8d40faf (diff)
downloadports-1b48d93a5bd318d78a3dad79ec5793a588b79bc5.tar.gz
ports-1b48d93a5bd318d78a3dad79ec5793a588b79bc5.zip
Notes
Diffstat (limited to 'security/vpnc')
-rw-r--r--security/vpnc/Makefile2
-rw-r--r--security/vpnc/distinfo4
-rw-r--r--security/vpnc/files/patch-sysdep.h10
-rw-r--r--security/vpnc/files/patch-tunip.c26
4 files changed, 3 insertions, 39 deletions
diff --git a/security/vpnc/Makefile b/security/vpnc/Makefile
index 15529ab9a5d2..1fece9cdca18 100644
--- a/security/vpnc/Makefile
+++ b/security/vpnc/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= vpnc
-PORTVERSION= 0.3.1
+PORTVERSION= 0.3.2
CATEGORIES= security
MASTER_SITES= http://www.unix-ag.uni-kl.de/~massar/vpnc/:source \
http://dragon.roe.ch/mirrors/distfiles/vpnc/:script
diff --git a/security/vpnc/distinfo b/security/vpnc/distinfo
index d1b420b4becc..68eb738eca4c 100644
--- a/security/vpnc/distinfo
+++ b/security/vpnc/distinfo
@@ -1,4 +1,4 @@
-MD5 (vpnc-0.3.1.tar.gz) = 02b814ee7bd5ff3f5a5535eff4e3387d
-SIZE (vpnc-0.3.1.tar.gz) = 56007
+MD5 (vpnc-0.3.2.tar.gz) = aaccdffc5656095a45dfe87c5bf612cb
+SIZE (vpnc-0.3.2.tar.gz) = 56669
MD5 (vpnc-wrapper-1.10) = 32c11fe4de7f0cda2fdfcc7dd2a40271
SIZE (vpnc-wrapper-1.10) = 6414
diff --git a/security/vpnc/files/patch-sysdep.h b/security/vpnc/files/patch-sysdep.h
deleted file mode 100644
index b5b236b1d777..000000000000
--- a/security/vpnc/files/patch-sysdep.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- sysdep.h.dist Wed Nov 17 16:37:52 2004
-+++ sysdep.h Wed Nov 17 16:37:37 2004
-@@ -1,6 +1,7 @@
- #ifndef __SYSDEP_H__
- #define __SYSDEP_H__
-
-+#include <sys/types.h>
- #include <netinet/in.h>
-
- int tun_open(char *dev);
diff --git a/security/vpnc/files/patch-tunip.c b/security/vpnc/files/patch-tunip.c
deleted file mode 100644
index 20cf33701117..000000000000
--- a/security/vpnc/files/patch-tunip.c
+++ /dev/null
@@ -1,26 +0,0 @@
-Index: tunip.c
-===================================================================
---- tunip.c (revision 35)
-+++ tunip.c (working copy)
-@@ -596,10 +596,6 @@
- /* Fill non-mutable fields */
- ip->ip_v = IPVERSION;
- ip->ip_hl = 5;
-- ip->ip_len = encap->buflen + (peer->remote_sa->md_algo? 12 :0);
--#ifdef NEED_IPLEN_FIX
-- ip->ip_len = htons(ip->ip_len);
--#endif
- /*gcry_md_get_algo_dlen(md_algo); see RFC .. only use 96 bit */
- ip->ip_id = htons(ip_id++);
- ip->ip_p = IPPROTO_ESP;
-@@ -614,6 +610,10 @@
-
- encap_esp_encapsulate(encap, peer);
-
-+ ip->ip_len = encap->buflen;
-+#ifdef NEED_IPLEN_FIX
-+ ip->ip_len = htons(ip->ip_len);
-+#endif
- ip->ip_sum = in_cksum((u_short *) encap->buf, sizeof(struct ip));
-
- sent = sendto(encap->fd, encap->buf, encap->buflen, 0,