aboutsummaryrefslogtreecommitdiff
path: root/security/vpnc
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2015-03-03 20:50:53 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2015-03-03 20:50:53 +0000
commitd979d4588d00391cfa98409212d9edf90d9ef471 (patch)
tree1387cd19e05853743b87332480f080c814c4e4b6 /security/vpnc
parent25c8965284778a93eaac8310be4aea78cc27b278 (diff)
downloadports-d979d4588d00391cfa98409212d9edf90d9ef471.tar.gz
ports-d979d4588d00391cfa98409212d9edf90d9ef471.zip
Notes
Diffstat (limited to 'security/vpnc')
-rw-r--r--security/vpnc/Makefile7
-rw-r--r--security/vpnc/files/patch-sysdep.h21
2 files changed, 23 insertions, 5 deletions
diff --git a/security/vpnc/Makefile b/security/vpnc/Makefile
index 23d233ad85e1..72e26eebfe32 100644
--- a/security/vpnc/Makefile
+++ b/security/vpnc/Makefile
@@ -3,7 +3,7 @@
PORTNAME= vpnc
PORTVERSION= 0.5.3
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= security
MASTER_SITES= http://www.unix-ag.uni-kl.de/~massar/vpnc/ \
LOCAL/ehaupt
@@ -56,6 +56,11 @@ CFLAGS+= -DCISCO_PATCH_VERSION
.endif
post-patch:
+.if ${OSVERSION} >= 1100042
+ @${REINPLACE_CMD} \
+ -e 's|.*%%FREEBSD_IPLEN_FIX%%.*|#define NEED_IPLEN_FIX 1|' \
+ ${WRKSRC}/sysdep.h
+.endif
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|' ${WRKSRC}/config.c
@${REINPLACE_CMD} -e 's|\(/etc/vpnc\)|${PREFIX}\1|' \
${WRKSRC}/${MANPAGE8}.template
diff --git a/security/vpnc/files/patch-sysdep.h b/security/vpnc/files/patch-sysdep.h
index a80eb49420d4..66ef9172bfa3 100644
--- a/security/vpnc/files/patch-sysdep.h
+++ b/security/vpnc/files/patch-sysdep.h
@@ -1,6 +1,19 @@
---- sysdep.h.orig 2008-11-19 20:36:12 UTC
-+++ sysdep.h
-@@ -86,6 +86,7 @@ int tun_get_hwaddr(int fd, char *dev, ui
+--- sysdep.h.orig 2008-11-19 21:36:12.000000000 +0100
++++ sysdep.h 2015-03-03 21:35:27.443313082 +0100
+@@ -75,17 +75,20 @@
+ /***************************************************************************/
+ #if defined(__FreeBSD_kernel__)
+ #define HAVE_SA_LEN 1
++/* %%FREEBSD_IPLEN_FIX%% */
+ #endif
+
+ /***************************************************************************/
+ #if defined(__FreeBSD__)
+ #define HAVE_SA_LEN 1
++/* %%FREEBSD_IPLEN_FIX%% */
+
+ #define HAVE_VASPRINTF 1
+ #define HAVE_ASPRINTF 1
#define HAVE_FGETLN 1
#define HAVE_UNSETENV 1
#define HAVE_SETENV 1
@@ -8,7 +21,7 @@
#endif
/***************************************************************************/
-@@ -97,6 +98,7 @@ int tun_get_hwaddr(int fd, char *dev, ui
+@@ -97,6 +100,7 @@
#define HAVE_FGETLN 1
#define HAVE_UNSETENV 1
#define HAVE_SETENV 1