aboutsummaryrefslogtreecommitdiff
path: root/security/vscan
diff options
context:
space:
mode:
authorJames E. Housley <jeh@FreeBSD.org>2006-07-14 19:39:12 +0000
committerJames E. Housley <jeh@FreeBSD.org>2006-07-14 19:39:12 +0000
commit2081a1ab3f0bd87a76ef38ced970e068cae60cdd (patch)
treeeccc633534fcfeebd2bca26c9ae148f9de0578f0 /security/vscan
parent2ed36baaffa52b996c16a7182f7ae0639c78607c (diff)
downloadports-2081a1ab3f0bd87a76ef38ced970e068cae60cdd.tar.gz
ports-2081a1ab3f0bd87a76ef38ced970e068cae60cdd.zip
Notes
Diffstat (limited to 'security/vscan')
-rw-r--r--security/vscan/Makefile23
-rw-r--r--security/vscan/pkg-plist2
2 files changed, 18 insertions, 7 deletions
diff --git a/security/vscan/Makefile b/security/vscan/Makefile
index 2323d33bfd6f..60a5774a2c5a 100644
--- a/security/vscan/Makefile
+++ b/security/vscan/Makefile
@@ -20,6 +20,16 @@ COMMENT= Evaluation version of a DOS/Windows/Linux file virus scanner
# libmap.conf(5) to map against current libc. This may affect the system
# security. Use at your own risk.
.include <bsd.port.pre.mk>
+.if ${ARCH} == "amd64"
+WITHOUT_COMPAT3=1
+UVSCAN_LIB32= 32
+USE_LDCONFIG32= ${PREFIX}/lib32
+LDCONFIG= /sbin/ldconfig -32
+.else
+UVSCAN_LIB32=
+INSTALLS_SHLIB= YES
+.endif
+
.if defined(WITHOUT_COMPAT3)
.if ${OSVERSION} < 510000
IGNORE= requires FreeBSD 5.1 or later
@@ -29,10 +39,9 @@ LIB_DEPENDS+= c.3:${PORTSDIR}/misc/compat3x
.endif
LIB_DEPENDS+= m.2:${PORTSDIR}/misc/compat4x
-ONLY_FOR_ARCHS= i386
+ONLY_FOR_ARCHS= i386 amd64
NO_BUILD= YES
NO_WRKSUBDIR= YES
-INSTALLS_SHLIB= YES
LICENSE= shareware
RESTRICTED= "restrictive 30 day evaluation license"
@@ -44,6 +53,8 @@ PORTDOCS= e4400upg.pdf readme.txt
PROGFILES= contact.txt license.dat license.txt messages.dat \
signlic.txt
+PLIST_SUB+= UVSCAN_LIB32=${UVSCAN_LIB32}
+
do-configure:
${SED} <${FILESDIR}/uvscan.sh >${WRKSRC}/uvscan.sh \
-e 's:@@PREFIX@@:${PREFIX}:g'
@@ -55,7 +66,7 @@ do-install:
${INSTALL_SCRIPT} ${WRKSRC}/uvscan ${PREFIX}/libexec/uvscan
${INSTALL_SCRIPT} ${WRKSRC}/uvscan.sh ${PREFIX}/bin/uvscan
${INSTALL_SCRIPT} ${WRKSRC}/uvscan_secure ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/libbsdfv.so.4 ${PREFIX}/lib/libbsdfv.so.4
+ ${INSTALL_PROGRAM} ${WRKSRC}/libbsdfv.so.4 ${PREFIX}/lib${UVSCAN_LIB32}/libbsdfv.so.4
.for filename in ${PROGFILES}
${INSTALL_DATA} ${WRKSRC}/${filename} ${PREFIX}/libexec/uvscan
.endfor
@@ -72,14 +83,14 @@ do-install:
@${CAT} ${PKGMESSAGE}
post-install:
- ${LN} -sf ${PREFIX}/lib/libbsdfv.so.4 ${PREFIX}/lib/libbsdfv.so
+ ${LN} -sf ${PREFIX}/lib${UVSCAN_LIB32}/libbsdfv.so.4 ${PREFIX}/lib${UVSCAN_LIB32}/libbsdfv.so
.if defined(WITHOUT_COMPAT3) && ${OSVERSION} >= 510000
@${ECHO_CMD} ""
@${ECHO_CMD} "This may affect the system security. Use at your own risk."
- @${ECHO_CMD} "You need to add the following two lines to your libmap.conf(5):"
+ @${ECHO_CMD} "You need to add the following two lines to your libmap${UVSCAN_LIB32}.conf(5):"
@${ECHO_CMD} ""
@${ECHO_CMD} "[/usr/local/libexec/uvscan/uvscan]"
- @${ECHO_CMD} "libc.so.3 libc.so"
+ @${ECHO_CMD} "libc.so.3 libc.so.4"
@${ECHO_CMD} ""
.endif
@${ECHO_CMD} "Trying to fetch the current DAT file"
diff --git a/security/vscan/pkg-plist b/security/vscan/pkg-plist
index dc4d4db89912..9e5cad977a56 100644
--- a/security/vscan/pkg-plist
+++ b/security/vscan/pkg-plist
@@ -2,7 +2,7 @@
bin/uvscan
bin/uvscan_secure
sbin/update_dat
-lib/libbsdfv.so.4
+lib%%UVSCAN_LIB32%%/libbsdfv.so.4
libexec/uvscan/contact.txt
libexec/uvscan/license.dat
libexec/uvscan/license.txt