aboutsummaryrefslogtreecommitdiff
path: root/security/wapiti
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2013-11-29 09:51:02 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2013-11-29 09:51:02 +0000
commitac8cf90ea398187fc9d39daf0c41d1909c0751e0 (patch)
tree9c1881999e44a834c76293d238384300f11c17f8 /security/wapiti
parent2e3ef3ccd29c0a16bdf82fd40b9120fa8a36582f (diff)
Notes
Diffstat (limited to 'security/wapiti')
-rw-r--r--security/wapiti/Makefile32
-rw-r--r--security/wapiti/distinfo4
-rw-r--r--security/wapiti/files/patch-setup.py11
-rw-r--r--security/wapiti/files/patch-wapitiCore__language__language.py12
4 files changed, 35 insertions, 24 deletions
diff --git a/security/wapiti/Makefile b/security/wapiti/Makefile
index f6316ba190d2..ea9b0c755baa 100644
--- a/security/wapiti/Makefile
+++ b/security/wapiti/Makefile
@@ -2,34 +2,22 @@
# $FreeBSD$
PORTNAME= wapiti
-PORTVERSION= 1.1.6
-PORTREVISION= 1
+PORTVERSION= 2.3.0
CATEGORIES= security
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
-MAINTAINER= jadawin@FreeBSD.org
+MAINTAINER= antoine@FreeBSD.org
COMMENT= Wapiti is a vulnerability scanner for web applications
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/tidy:${PORTSDIR}/www/py-utidy
+LICENSE= GPLv2
-USE_PYTHON= 2.5+
-NO_BUILD= yes
-PORTDOCS= README
+# easy_install puts man page and doc in the egg, so use install with setuptools
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:${PORTSDIR}/devel/py-setuptools
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}beautifulsoup32>=0:${PORTSDIR}/www/py-beautifulsoup32 \
+ ${PYTHON_PKGNAMEPREFIX}requests>=1.2.3:${PORTSDIR}/www/py-requests
-PLIST_FILES= bin/wapiti.py \
- bin/lswww.py \
- bin/getcookie.py \
- bin/cookie.py \
- bin/BeautifulSoup.py
-
-NO_STAGE= yes
-do-install:
-.for i in wapiti.py lswww.py getcookie.py cookie.py BeautifulSoup.py
- ${INSTALL_SCRIPT} ${WRKSRC}/${i} ${PREFIX}/bin/
-.endfor
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
-.endif
+USE_PYTHON= -2.7
+USE_PYDISTUTILS=yes
+PYDISTUTILS_AUTOPLIST=yes
.include <bsd.port.mk>
diff --git a/security/wapiti/distinfo b/security/wapiti/distinfo
index 0ded0cb84293..a21e14d0f37f 100644
--- a/security/wapiti/distinfo
+++ b/security/wapiti/distinfo
@@ -1,2 +1,2 @@
-SHA256 (wapiti-1.1.6.tar.gz) = cb9fb6b969d01e84e953235f7e7554fee62916aaf3215a1abd4455a0efecbaed
-SIZE (wapiti-1.1.6.tar.gz) = 51200
+SHA256 (wapiti-2.3.0.tar.gz) = 6b836a4810f17b7eda4345fb12293112129961ba243140c72a8da0ac2572f4b4
+SIZE (wapiti-2.3.0.tar.gz) = 305739
diff --git a/security/wapiti/files/patch-setup.py b/security/wapiti/files/patch-setup.py
new file mode 100644
index 000000000000..fecc4769d76a
--- /dev/null
+++ b/security/wapiti/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- ./setup.py.orig 2013-10-20 12:04:17.000000000 +0000
++++ ./setup.py 2013-11-28 19:47:25.000000000 +0000
+@@ -14,7 +14,7 @@
+ "README",
+ "TODO",
+ "VERSION"]))
+-doc_and_conf_files.append(("share/man/man1", ["doc/wapiti.1.gz"]))
++doc_and_conf_files.append(("man/man1", ["doc/wapiti.1.gz"]))
+
+ # Main
+ setup(
diff --git a/security/wapiti/files/patch-wapitiCore__language__language.py b/security/wapiti/files/patch-wapitiCore__language__language.py
new file mode 100644
index 000000000000..b44d3c8a8cca
--- /dev/null
+++ b/security/wapiti/files/patch-wapitiCore__language__language.py
@@ -0,0 +1,12 @@
+--- ./wapitiCore/language/language.py.orig 2013-10-02 19:36:32.000000000 +0000
++++ ./wapitiCore/language/language.py 2013-11-28 19:46:44.000000000 +0000
+@@ -55,7 +55,8 @@
+ # if lang is not specified, default language is used
+ defLocale = locale.getdefaultlocale()
+ langCounty = defLocale[0] # en_UK
+- lang = langCounty[:2] # en
++ if langCounty is not None:
++ lang = langCounty[:2] # en
+ if lang not in self.AVAILABLE_LANGS:
+ # if lang is not one of the supported languages, we use english
+ print("Oups! No translations found for your language... Using english.")