aboutsummaryrefslogtreecommitdiff
path: root/security/wpa_supplicant
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-10-13 13:49:55 +0000
committerJohn Marino <marino@FreeBSD.org>2014-10-13 13:49:55 +0000
commit61f267d59a03195d246d1f8e1da88de1b00db966 (patch)
treee6d71105872af1c704db0a1848e7311d4ce8e058 /security/wpa_supplicant
parent7e933d9737298ecf8e4ff8d052b7a2021d3ba0ee (diff)
Notes
Diffstat (limited to 'security/wpa_supplicant')
-rw-r--r--security/wpa_supplicant/Makefile2
-rw-r--r--security/wpa_supplicant/files/patch-src_drivers_driver__bsd.c16
2 files changed, 17 insertions, 1 deletions
diff --git a/security/wpa_supplicant/Makefile b/security/wpa_supplicant/Makefile
index 48624769793d..9c5afefed4e6 100644
--- a/security/wpa_supplicant/Makefile
+++ b/security/wpa_supplicant/Makefile
@@ -2,7 +2,7 @@
PORTNAME= wpa_supplicant
PORTVERSION= 2.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security net
MASTER_SITES= http://w1.fi/releases/
diff --git a/security/wpa_supplicant/files/patch-src_drivers_driver__bsd.c b/security/wpa_supplicant/files/patch-src_drivers_driver__bsd.c
new file mode 100644
index 000000000000..1d4447cc96bf
--- /dev/null
+++ b/security/wpa_supplicant/files/patch-src_drivers_driver__bsd.c
@@ -0,0 +1,16 @@
+--- src/drivers/driver_bsd.c.orig 2014-10-09 14:41:31 UTC
++++ src/drivers/driver_bsd.c
+@@ -1334,7 +1334,13 @@ wpa_driver_bsd_add_scan_entry(struct wpa
+ *pos++ = 1;
+ *pos++ = sr->isr_erp;
+
++#if defined(__FreeBSD__) || defined(__FreeBSD_kernel__) \
++ || defined(__DragonFly__)
++ os_memcpy(pos, (u8 *)(sr + 1) + sr->isr_ssid_len + sr->isr_meshid_len,
++ sr->isr_ie_len);
++#else
+ os_memcpy(pos, (u8 *)(sr + 1) + sr->isr_ssid_len, sr->isr_ie_len);
++#endif
+ pos += sr->isr_ie_len;
+
+ result->ie_len = pos - (u8 *)(result + 1);