aboutsummaryrefslogtreecommitdiff
path: root/security/wpa_supplicant
diff options
context:
space:
mode:
authorJoseph Mingrone <jrm@FreeBSD.org>2016-12-25 03:15:14 +0000
committerJoseph Mingrone <jrm@FreeBSD.org>2016-12-25 03:15:14 +0000
commit06e9773ae037787985162aa347bba4b6724480f0 (patch)
treee2062f3ff49c84d9c5c8b66a13b74135cd81c045 /security/wpa_supplicant
parente4605233e41516864b593d832a89d908e78b3e0b (diff)
Notes
Diffstat (limited to 'security/wpa_supplicant')
-rw-r--r--security/wpa_supplicant/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/security/wpa_supplicant/Makefile b/security/wpa_supplicant/Makefile
index 84c24e898cd8..f2f1c08240ab 100644
--- a/security/wpa_supplicant/Makefile
+++ b/security/wpa_supplicant/Makefile
@@ -11,8 +11,6 @@ COMMENT= Supplicant (client) for WPA/802.1x protocols
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/README
-BROKEN_FreeBSD_9= does not build (error: void value not ignored as it ought to be)
-
USES= cpe gmake readline ssl
BUILD_WRKSRC= ${WRKSRC}/wpa_supplicant
INSTALL_WRKSRC= ${WRKSRC}/src
@@ -95,7 +93,13 @@ TNC_DESC= Trusted Network Connect
PRIVSEP_PLIST_FILES= sbin/wpa_priv
-.include <bsd.port.options.mk>
+.include <bsd.port.pre.mk>
+
+.if ${SSL_DEFAULT} == base
+BROKEN_FreeBSD_9= Does not build on FreeBSD < 10 with base SSL. Add DEFAULT_VERSIONS+=ssl=openssl\
+ or DEFAULT_VERSIONS+=ssl=libressl to /etc/make.conf and rebuild everything that\
+ requires SSL.
+.endif
.if ${PORT_OPTIONS:MNDIS} && ${PORT_OPTIONS:MPRIVSEP}
BROKEN= Fails to compile with both NDIS and PRIVSEP
@@ -173,4 +177,4 @@ do-install-DOCS-on:
do-install-PRIVSEP-on:
${INSTALL_PROGRAM} ${BUILD_WRKSRC}/wpa_priv ${STAGEDIR}${PREFIX}/sbin
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>