aboutsummaryrefslogtreecommitdiff
path: root/security/wpa_supplicant
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2006-09-14 17:37:05 +0000
committerBrooks Davis <brooks@FreeBSD.org>2006-09-14 17:37:05 +0000
commit6c9ac209609366cd471cb2b47db360898192c4ae (patch)
tree18910f4fbc78fd37d6764924b4b6fb843624f7ba /security/wpa_supplicant
parentb17ed41b7762c756c626bfb5148381cc526c488b (diff)
downloadports-6c9ac209609366cd471cb2b47db360898192c4ae.tar.gz
ports-6c9ac209609366cd471cb2b47db360898192c4ae.zip
Notes
Diffstat (limited to 'security/wpa_supplicant')
-rw-r--r--security/wpa_supplicant/Makefile4
-rw-r--r--security/wpa_supplicant/files/patch-crypto.c13
2 files changed, 13 insertions, 4 deletions
diff --git a/security/wpa_supplicant/Makefile b/security/wpa_supplicant/Makefile
index 2bb1217a4032..82f35955cb9a 100644
--- a/security/wpa_supplicant/Makefile
+++ b/security/wpa_supplicant/Makefile
@@ -65,8 +65,4 @@ post-install:
IGNORE=is not supported on FreeBSD < 6.0
.endif
-.if ${OSVERSION} >= 700019
-BROKEN= does not compile on FreeBSD >= 7.0
-.endif
-
.include <bsd.port.post.mk>
diff --git a/security/wpa_supplicant/files/patch-crypto.c b/security/wpa_supplicant/files/patch-crypto.c
new file mode 100644
index 000000000000..c27bc4c09f64
--- /dev/null
+++ b/security/wpa_supplicant/files/patch-crypto.c
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- crypto.c.orig
++++ crypto.c
+@@ -12,6 +12,7 @@
+ * See README and COPYING for more details.
+ */
+
++#include <sys/types.h>
+ #include <openssl/md4.h>
+ #include <openssl/des.h>
+