aboutsummaryrefslogtreecommitdiff
path: root/security/xca
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2015-10-18 13:41:15 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2015-10-18 13:41:15 +0000
commit2f90775268f8bbc763ddaddab7b8dd84be7e8c93 (patch)
treee56933b171ec60bf114bdfd06ccef438b6058ba8 /security/xca
parent962979cb14a33a469063ec90ca68027e5d4dae59 (diff)
downloadports-2f90775268f8bbc763ddaddab7b8dd84be7e8c93.tar.gz
ports-2f90775268f8bbc763ddaddab7b8dd84be7e8c93.zip
Notes
Diffstat (limited to 'security/xca')
-rw-r--r--security/xca/Makefile61
-rw-r--r--security/xca/distinfo4
-rw-r--r--security/xca/files/patch-doc__Makefile32
-rw-r--r--security/xca/files/patch-img__Makefile11
-rw-r--r--security/xca/files/patch-lib__x509v3ext.cpp20
-rw-r--r--security/xca/pkg-descr14
-rw-r--r--security/xca/pkg-plist28
7 files changed, 59 insertions, 111 deletions
diff --git a/security/xca/Makefile b/security/xca/Makefile
index 8dd5e3c546cc..284638f2cad7 100644
--- a/security/xca/Makefile
+++ b/security/xca/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= xca
-PORTVERSION= 0.9.3
-PORTREVISION= 3
+PORTVERSION= 1.3.2
CATEGORIES= security
MASTER_SITES= SF
@@ -15,41 +14,35 @@ LICENSE_FILE= ${WRKSRC}/COPYRIGHT
LIB_DEPENDS= libltdl.so:${PORTSDIR}/devel/libltdl
+USES= desktop-file-utils gmake localbase pkgconfig shared-mime-info
USE_OPENSSL= yes
-USE_QT4= gui moc_build uic_build qmake_build rcc_build linguist_build
-USES= desktop-file-utils gmake shared-mime-info
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-openssl=${OPENSSLDIR} \
+ --with-qt=${QT_PREFIX}
+MAKE_ARGS= DOCTOOL="${TRUE}"
DESTDIRNAME= destdir
-.include <bsd.port.pre.mk>
+OPTIONS_DEFINE= DOCS
+OPTIONS_SINGLE= TOOLKIT
+OPTIONS_SINGLE_TOOLKIT= QT4 QT5
+OPTIONS_DEFAULT= QT4
-BROKEN_sparc64= fails to link
-
-.if ${OSVERSION} >= 1000054
-LD_CXX_LIB= -lc++
-.endif
+QT4_USE= qt4=gui,linguist_build,moc_build,qmake_build \
+ qt4=rcc_build,uic_build
+QT5_USE= qt5=widgets,buildtools_build,linguist_build
+TOOLKIT_DESC= Qt toolkit
post-patch:
- @echo "CPPFLAGS=-I. -I.. -I${WRKSRC}/ui -I${QT_INCDIR} -I${QT_INCDIR}/Qt -I${LOCALBASE}/include" > ${WRKSRC}/Local.mak
- @echo "CFLAGS= ${CFLAGS} -Wall -ggdb" >> ${WRKSRC}/Local.mak
- @echo "LDFLAGS= ${LDFLAGS}" >> ${WRKSRC}/Local.mak
- @echo "LIBS= ${LIBS} -L${QT_LIBDIR} -L${LOCALBASE}/lib -lQtCore -lQtGui -lpthread -lcrypto -lltdl ${LD_CXX_LIB}" >> ${WRKSRC}/Local.mak
- @echo "MOC=${MOC}" >> ${WRKSRC}/Local.mak
- @echo "UIC=${QT_PREFIX}/bin/uic-qt4" >> ${WRKSRC}/Local.mak
- @echo "RCC=${LOCALBASE}/bin/rcc" >> ${WRKSRC}/Local.mak
- @echo "LRELEASE=${LOCALBASE}/bin/lrelease-qt4" >> ${WRKSRC}/Local.mak
- @echo "CC=${CC}" >> ${WRKSRC}/Local.mak
- @echo "LD=${LD}" >> ${WRKSRC}/Local.mak
- @echo "STRIP=${STRIP_CMD}" >> ${WRKSRC}/Local.mak
- @echo "prefix=${PREFIX}" >> ${WRKSRC}/Local.mak
- @echo "etc=${PREFIX}/etc/xca" >> ${WRKSRC}/Local.mak
- @echo "basedir=" >> ${WRKSRC}/Local.mak
- @echo "docdir=${DOCSDIR}" >> ${WRKSRC}/Local.mak
- @echo "#define PREFIX \"${PREFIX}\"" > ${WRKSRC}/local.h
- @echo "#define ETC \"${PREFIX}/etc/xca\"" >> ${WRKSRC}/local.h
- @echo "#define VER \"${PORTVERSION}\"" >> ${WRKSRC}/local.h
- @echo "#define DOCDIR \"${DOCSDIR}\"" >> ${WRKSRC}/local.h
- @${REINPLACE_CMD} -e "/rR/{G;s/$$/TOPDIR_/;}" -e "s:\(TOPDIR\)_:\1=${WRKSRC}:" ${WRKSRC}/Makefile
- @${REINPLACE_CMD} -e "/VPATH/{G;s/$$/TOPDIR_/;}" -e "s:\(TOPDIR\)_:\1=${WRKSRC}:" ${WRKSRC}/misc/Makefile
- @${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' ${WRKSRC}/lib/import.cpp
-
-.include <bsd.port.post.mk>
+ @${REINPLACE_CMD} -e \
+ '/^CFLAGS/s|-O2||' ${WRKSRC}/Local.mak.in
+ @${REINPLACE_CMD} -e \
+ '/install/s|-D|-c|' ${WRKSRC}/img/Makefile
+
+post-patch-QT5-off:
+ @${REINPLACE_CMD} -e \
+ 's|Qt5|Qt0|g' ${WRKSRC}/configure
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/xca*
+
+.include <bsd.port.mk>
diff --git a/security/xca/distinfo b/security/xca/distinfo
index 14e068853f09..df17059bef96 100644
--- a/security/xca/distinfo
+++ b/security/xca/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xca-0.9.3.tar.gz) = 6842b50c8b4478070d8af743cb72aee1f53a2c4ff2b8285fcec5f856119cc6ba
-SIZE (xca-0.9.3.tar.gz) = 755165
+SHA256 (xca-1.3.2.tar.gz) = 04f11f2148c8369c1a1b4e109956ed8cc807ec266d0d936410624ba8ee4b5ce4
+SIZE (xca-1.3.2.tar.gz) = 897947
diff --git a/security/xca/files/patch-doc__Makefile b/security/xca/files/patch-doc__Makefile
deleted file mode 100644
index 2592aea26988..000000000000
--- a/security/xca/files/patch-doc__Makefile
+++ /dev/null
@@ -1,32 +0,0 @@
---- doc/Makefile.orig 2012-05-12 09:37:14 UTC
-+++ doc/Makefile
-@@ -5,7 +5,7 @@ endif
-
- DELFILES=xca*.html xca.1.gz
-
--doc: xca.1.gz xca.html
-+doc: xca.1.gz
- include $(TOPDIR)/Rules.mak
-
- mandir=man
-@@ -15,10 +15,7 @@ xca.1.gz: xca.1
-
- xca.html: xca.sgml
- rm -f xca*.html
-- echo 'The documentation for XCA can be viewed online at: <a href="http://xca.sourceforge.net/">http://xca.sourceforge.net/</a>.' > $@
-- test ! -f xca-doc.tgz || tar zxf xca-doc.tgz
-- @$(PRINT) " DOC [$(BASENAME)] $@"
-- $(LINUXDOC) -B html $< >/dev/null
-+ echo 'The documentation for XCA can be viewed online at: <a href="http://xca.sourceforge.net/">http://xca.sourceforge.net/</a>.' >> $@
-
- install: xca.1.gz xca.html
- install -m 755 -d $(destdir)$(docdir) \
-@@ -26,8 +23,4 @@ install: xca.1.gz xca.html
- install -m 644 xca*.html $(destdir)$(docdir)
- install xca.1.gz $(destdir)$(prefix)/$(mandir)/man1
-
--app: xca.html
-- mkdir -p $(APPDIR)/Resources
-- install -m 644 xca*.html $(APPDIR)/Resources
--
-
diff --git a/security/xca/files/patch-img__Makefile b/security/xca/files/patch-img__Makefile
deleted file mode 100644
index 5497f5b652f0..000000000000
--- a/security/xca/files/patch-img__Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- img/Makefile.orig 2012-05-12 09:37:14 UTC
-+++ img/Makefile
-@@ -13,7 +13,7 @@ include $(TOPDIR)/Rules.mak
- sinclude .depend
-
- install: xca-32x32.xpm
-- install -D -m 644 $^ $(destdir)$(prefix)/share/pixmaps/xca-32x32.xpm
-+ install -d -m 755 $(destdir)$(prefix)/share/pixmaps && install -m 644 $^ $(destdir)$(prefix)/share/pixmaps/xca-32x32.xpm
-
- imgres.cpp: imgres.rcc
- @$(PRINT) " RCC [$(BASENAME)] $@"
diff --git a/security/xca/files/patch-lib__x509v3ext.cpp b/security/xca/files/patch-lib__x509v3ext.cpp
deleted file mode 100644
index b713f083c0d0..000000000000
--- a/security/xca/files/patch-lib__x509v3ext.cpp
+++ /dev/null
@@ -1,20 +0,0 @@
---- lib/x509v3ext.cpp.orig 2012-05-12 09:37:14 UTC
-+++ lib/x509v3ext.cpp
-@@ -27,6 +27,8 @@ x509v3ext::x509v3ext(const X509_EXTENSIO
- x509v3ext::x509v3ext(const x509v3ext &n)
- {
- ext = NULL;
-+ if (!n.isValid())
-+ return;
- set(n.ext);
- }
-
-@@ -743,7 +745,7 @@ X509_EXTENSION *x509v3ext::get() const
-
- bool x509v3ext::isValid() const
- {
-- return ext->value->length > 0 &&
-+ return ext && ext->value && ext->value->length > 0 &&
- OBJ_obj2nid(ext->object) != NID_undef;
- }
-
diff --git a/security/xca/pkg-descr b/security/xca/pkg-descr
index bfce09749603..55d94af96643 100644
--- a/security/xca/pkg-descr
+++ b/security/xca/pkg-descr
@@ -1,8 +1,8 @@
-Graphical certification authority is an interface for managing
-RSA keys and certificates, and the creation and signing of PKCS#10 requests.
-It uses the OpenSSL library and a Berkeley DB for key and certificate storage.
-It supports importing and exporting keys and PEM DER PKCS8 certificates,
-signing and revoking of PEM DER PKCS12, and selection of x509v3 extensions.
-A tree view of certificates is presented.
+Graphical certification authority is an interface for managing RSA keys
+and certificates, and the creation and signing of PKCS#10 requests. It
+uses the OpenSSL library and a Berkeley DB for key and certificate
+storage. It supports importing and exporting keys and PEM DER PKCS8
+certificates, signing and revoking of PEM DER PKCS12, and selection of
+x509v3 extensions. A tree view of certificates is presented.
-WWW: http://www.hohnstaedt.de/xca.html
+WWW: http://xca.hohnstaedt.de/
diff --git a/security/xca/pkg-plist b/security/xca/pkg-plist
index cdc1669ae461..7a63072b2324 100644
--- a/security/xca/pkg-plist
+++ b/security/xca/pkg-plist
@@ -1,4 +1,26 @@
bin/xca
+bin/xca_db_stat
+man/man1/xca.1.gz
+man/man1/xca_db_stat.1.gz
+share/applications/xca.desktop
+%%PORTDOCS%%%%DOCSDIR%%/xca-1.html
+%%PORTDOCS%%%%DOCSDIR%%/xca-10.html
+%%PORTDOCS%%%%DOCSDIR%%/xca-11.html
+%%PORTDOCS%%%%DOCSDIR%%/xca-12.html
+%%PORTDOCS%%%%DOCSDIR%%/xca-13.html
+%%PORTDOCS%%%%DOCSDIR%%/xca-14.html
+%%PORTDOCS%%%%DOCSDIR%%/xca-15.html
+%%PORTDOCS%%%%DOCSDIR%%/xca-2.html
+%%PORTDOCS%%%%DOCSDIR%%/xca-3.html
+%%PORTDOCS%%%%DOCSDIR%%/xca-4.html
+%%PORTDOCS%%%%DOCSDIR%%/xca-5.html
+%%PORTDOCS%%%%DOCSDIR%%/xca-6.html
+%%PORTDOCS%%%%DOCSDIR%%/xca-7.html
+%%PORTDOCS%%%%DOCSDIR%%/xca-8.html
+%%PORTDOCS%%%%DOCSDIR%%/xca-9.html
+%%PORTDOCS%%%%DOCSDIR%%/xca.html
+share/mime/packages/xca.xml
+share/pixmaps/xca-32x32.xpm
%%DATADIR%%/CA.xca
%%DATADIR%%/HTTPS_client.xca
%%DATADIR%%/HTTPS_server.xca
@@ -10,10 +32,6 @@ bin/xca
%%DATADIR%%/xca_de.qm
%%DATADIR%%/xca_es.qm
%%DATADIR%%/xca_fr.qm
+%%DATADIR%%/xca_hr.qm
%%DATADIR%%/xca_ru.qm
%%DATADIR%%/xca_tr.qm
-%%DOCSDIR%%/xca.html
-man/man1/xca.1.gz
-share/applications/xca.desktop
-share/mime/packages/xca.xml
-share/pixmaps/xca-32x32.xpm