aboutsummaryrefslogtreecommitdiff
path: root/security/xca
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2008-06-08 17:42:27 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2008-06-08 17:42:27 +0000
commit2f430bb6d4ed113cd4a294d45e6c053645ce1f31 (patch)
tree9cef8f187380e6208b8e1891f34241a5a6584491 /security/xca
parentdaf487572ddeeed7fcc94e2168451c576af1df3e (diff)
downloadports-2f430bb6d4ed113cd4a294d45e6c053645ce1f31.tar.gz
ports-2f430bb6d4ed113cd4a294d45e6c053645ce1f31.zip
Notes
Diffstat (limited to 'security/xca')
-rw-r--r--security/xca/Makefile8
-rw-r--r--security/xca/distinfo6
-rw-r--r--security/xca/files/patch-lib__x509rev.cpp13
3 files changed, 19 insertions, 8 deletions
diff --git a/security/xca/Makefile b/security/xca/Makefile
index e45d9b7a5399..eb710256826d 100644
--- a/security/xca/Makefile
+++ b/security/xca/Makefile
@@ -6,11 +6,9 @@
#
PORTNAME= xca
-PORTVERSION= 0.6.3
-PORTREVISION= 1
+PORTVERSION= 0.6.4
CATEGORIES= security
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= SF
MAINTAINER= mark@foster.cc
COMMENT= Graphical certification authority
@@ -28,7 +26,7 @@ MANCOMPRESSED= yes
.include <bsd.port.pre.mk>
post-patch:
- @echo "CPPFLAGS=-I. -I.. -I${WRKSRC}/ui -I${LOCALBASE}/include -I${QT_PREFIX}/include/Qt" > ${WRKSRC}/Local.mak
+ @echo "CPPFLAGS=-I. -I.. -I${WRKSRC}/ui -I${QT_PREFIX}/include/Qt -I${LOCALBASE}/include" > ${WRKSRC}/Local.mak
@echo "CFLAGS= ${CFLAGS} -Wall -ggdb" >> ${WRKSRC}/Local.mak
@echo "LDFLAGS= ${LDFLAGS} -L${LOCALBASE}/lib" >> ${WRKSRC}/Local.mak
@echo "LIBS= -lQtGui ${PTHREAD_LIBS} -lcrypto" >> ${WRKSRC}/Local.mak
diff --git a/security/xca/distinfo b/security/xca/distinfo
index cd3a39570971..90f465baf52d 100644
--- a/security/xca/distinfo
+++ b/security/xca/distinfo
@@ -1,3 +1,3 @@
-MD5 (xca-0.6.3.tar.gz) = 8e0c2f8fbd01451acb841a3fb99ca399
-SHA256 (xca-0.6.3.tar.gz) = 032e64ac3bbef15c3ddf58278593ef02d52680b183c0a2a0bceb8f887a90fc7b
-SIZE (xca-0.6.3.tar.gz) = 260070
+MD5 (xca-0.6.4.tar.gz) = f805a2e094436f976c7a4cda5980027e
+SHA256 (xca-0.6.4.tar.gz) = 63e5992d461cbea38fb5433c989ee1cc73d7dac5162e57d6e70a7735d9f80ed4
+SIZE (xca-0.6.4.tar.gz) = 266574
diff --git a/security/xca/files/patch-lib__x509rev.cpp b/security/xca/files/patch-lib__x509rev.cpp
new file mode 100644
index 000000000000..1c7a909d4092
--- /dev/null
+++ b/security/xca/files/patch-lib__x509rev.cpp
@@ -0,0 +1,13 @@
+--- ./lib/x509rev.cpp.orig 2007-08-13 21:55:50.000000000 +0300
++++ ./lib/x509rev.cpp 2008-06-08 18:23:04.749150142 +0300
+@@ -13,8 +13,8 @@
+
+ #else
+ #define X509_REVOKED_dup(x5r) (X509_REVOKED *)ASN1_dup( \
+- (int (*)(...))i2d_X509_REVOKED, \
+- (char *(*)(...))d2i_X509_REVOKED, \
++ (int (*)())i2d_X509_REVOKED, \
++ (char *(*)())d2i_X509_REVOKED, \
+ (char *)x5r)
+ #endif
+