aboutsummaryrefslogtreecommitdiff
path: root/security/xyssl
diff options
context:
space:
mode:
authorOKAZAKI Tetsurou <okazaki@FreeBSD.org>2009-01-04 11:29:30 +0000
committerOKAZAKI Tetsurou <okazaki@FreeBSD.org>2009-01-04 11:29:30 +0000
commit07546fc1a4fcf983f7f830b33841911247fd7042 (patch)
tree1aae52b76a1cdcf1d5c17abb3e7c41c8454dab82 /security/xyssl
parent2c57d34998389ff9f1c19b17ccdb294b5f39ca96 (diff)
downloadports-07546fc1a4fcf983f7f830b33841911247fd7042.tar.gz
ports-07546fc1a4fcf983f7f830b33841911247fd7042.zip
Notes
Diffstat (limited to 'security/xyssl')
-rw-r--r--security/xyssl/Makefile19
-rw-r--r--security/xyssl/distinfo6
-rw-r--r--security/xyssl/files/patch-Makefile72
-rw-r--r--security/xyssl/pkg-plist23
4 files changed, 69 insertions, 51 deletions
diff --git a/security/xyssl/Makefile b/security/xyssl/Makefile
index 3c2f95f38982..efda6c500a5e 100644
--- a/security/xyssl/Makefile
+++ b/security/xyssl/Makefile
@@ -6,20 +6,25 @@
#
PORTNAME= xyssl
-PORTVERSION= 0.6
+PORTVERSION= 0.9
CATEGORIES= security devel
-MASTER_SITES= http://xyssl.org/code/download/ \
+MASTER_SITES= http://polarssl.org/code/download/ \
ftp://ftp.solitox.net/pub/XySSL/
-DISTNAME= xyssl-${PORTVERSION}
-EXTRACT_SUFX= .tgz
+DISTFILES= xyssl-${PORTVERSION}-bsd.tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= A liteweight SSL and TLS toolkit for C developers
-DEPRECATED= Download sites are down, cannot update due to software website being down.
-EXPIRATION_DATE=2008-12-01
-
# HAS_CONFIGURE= no
# GNU_CONFIGURE= no
+PORTDOCS= BSD.txt ChangeLog
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/BSD.txt ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/ChangeLog ${DOCSDIR}
+.endif
+
.include <bsd.port.mk>
diff --git a/security/xyssl/distinfo b/security/xyssl/distinfo
index 32db02de9b2f..13f8344c9c9e 100644
--- a/security/xyssl/distinfo
+++ b/security/xyssl/distinfo
@@ -1,3 +1,3 @@
-MD5 (xyssl-0.6.tgz) = 4528b29a7de7d850bd1cb95af2c6d3ab
-SHA256 (xyssl-0.6.tgz) = a4729988a7014cf5c20e6a2ffb4f2a57d48360c6ec584c7c11c7879073e1f3e0
-SIZE (xyssl-0.6.tgz) = 161714
+MD5 (xyssl-0.9-bsd.tgz) = 47699a8e5be1be4cab5be92e3f214aaf
+SHA256 (xyssl-0.9-bsd.tgz) = cffb78aff512bba7fc1f574b1e9c5cd6759e446719e09c68ce70ccd0fbcef943
+SIZE (xyssl-0.9-bsd.tgz) = 200296
diff --git a/security/xyssl/files/patch-Makefile b/security/xyssl/files/patch-Makefile
index e9eca1fe0841..1845d1217ebf 100644
--- a/security/xyssl/files/patch-Makefile
+++ b/security/xyssl/files/patch-Makefile
@@ -1,37 +1,35 @@
-*** Makefile.orig Sat Mar 31 18:00:00 2007
---- Makefile Thu Apr 5 14:17:48 2007
-***************
-*** 13,26 ****
- mv html docs
-
- install:
-! mkdir -p $(DESTDIR)/{include/xyssl,lib}
-! cp -v -r include $(DESTDIR)/include
-! cp -v library/libxyssl.a $(DESTDIR)/lib
-!
-! mkdir -p $(DESTDIR)/bin
-! for i in programs/*; do test -x $i && \
-! cp -v $i $(DESTDIR)/xyssl_$i; \
-! done
-
- clean:
- cd library && make clean && cd ..
---- 13,30 ----
- mv html docs
-
- install:
-! /usr/bin/install -d -v -m 0755 $(DESTDIR)/include/xyssl
-! /usr/bin/install -v -m 0644 include/xyssl/* $(DESTDIR)/include/xyssl/
-! /usr/bin/install -v -m 0644 library/libxyssl.a $(DESTDIR)/lib
-!
-! /usr/bin/install -v -m 0755 programs/benchmark $(DESTDIR)/bin/xyssl_benchmark
-! /usr/bin/install -v -m 0755 programs/filecrypt $(DESTDIR)/bin/xyssl_filecrypt
-! /usr/bin/install -v -m 0755 programs/hello $(DESTDIR)/bin/xyssl_hello
-! /usr/bin/install -v -m 0755 programs/mpi_demo $(DESTDIR)/bin/xyssl_mpi_demo
-! /usr/bin/install -v -m 0755 programs/selftest $(DESTDIR)/bin/xyssl_selftest
-! /usr/bin/install -v -m 0755 programs/ssl_client1 $(DESTDIR)/bin/xyssl_ssl_client1
-! /usr/bin/install -v -m 0755 programs/ssl_client2 $(DESTDIR)/bin/xyssl_ssl_client2
-! /usr/bin/install -v -m 0755 programs/ssl_server $(DESTDIR)/bin/xyssl_ssl_server
-
- clean:
- cd library && make clean && cd ..
+--- Makefile.orig 2008-03-16 14:23:22.000000000 +0000
++++ Makefile 2009-01-02 23:45:48.380520000 +0000
+@@ -1,6 +1,6 @@
+
+-DESTDIR=/usr/local
+-PREFIX=xyssl_
++PREFIX?=/usr/local
++DESTDIR=${PREFIX}
+
+ .SILENT:
+
+@@ -10,17 +10,17 @@
+
+ install:
+ mkdir -p $(DESTDIR)/include/xyssl
+- cp -r include/xyssl $(DESTDIR)/include
+-
++ ${BSD_INSTALL_DATA} include/xyssl/*.h $(DESTDIR)/include/xyssl
++
+ mkdir -p $(DESTDIR)/lib
+- cp library/libxyssl.* $(DESTDIR)/lib
+-
++ ${BSD_INSTALL_DATA} library/libxyssl.* $(DESTDIR)/lib
++
+ mkdir -p $(DESTDIR)/bin
+ for p in programs/*/* ; do \
+ if [ -x $$p ] && [ ! -d $$p ] ; \
+ then \
+- f=$(PREFIX)`basename $$p` ; \
+- cp $$p $(DESTDIR)/bin/$$f ; \
++ f=xyssl_`basename $$p` ; \
++ ${BSD_INSTALL_PROGRAM} $$p $(DESTDIR)/bin/$$f ; \
+ fi \
+ done
+
diff --git a/security/xyssl/pkg-plist b/security/xyssl/pkg-plist
index 27f89396f8dd..33ea21ed1f89 100644
--- a/security/xyssl/pkg-plist
+++ b/security/xyssl/pkg-plist
@@ -1,17 +1,30 @@
lib/libxyssl.a
-bin/xyssl_benchmark
-bin/xyssl_filecrypt
+bin/xyssl_aescrypt2
bin/xyssl_hello
+bin/xyssl_md5sum
+bin/xyssl_sha1sum
+bin/xyssl_sha2sum
+bin/xyssl_dh_client
+bin/xyssl_dh_genprime
+bin/xyssl_dh_server
bin/xyssl_mpi_demo
-bin/xyssl_selftest
+bin/xyssl_rsa_genkey
+bin/xyssl_rsa_sign
+bin/xyssl_rsa_verify
bin/xyssl_ssl_client1
bin/xyssl_ssl_client2
bin/xyssl_ssl_server
+bin/xyssl_benchmark
+bin/xyssl_selftest
+bin/xyssl_ssl_test
include/xyssl/aes.h
include/xyssl/arc4.h
include/xyssl/base64.h
include/xyssl/bignum.h
+include/xyssl/bn_mul.h
include/xyssl/certs.h
+include/xyssl/config.h
+include/xyssl/debug.h
include/xyssl/des.h
include/xyssl/dhm.h
include/xyssl/havege.h
@@ -19,11 +32,13 @@ include/xyssl/md2.h
include/xyssl/md4.h
include/xyssl/md5.h
include/xyssl/net.h
+include/xyssl/openssl.h
+include/xyssl/padlock.h
include/xyssl/rsa.h
include/xyssl/sha1.h
include/xyssl/sha2.h
+include/xyssl/sha4.h
include/xyssl/ssl.h
-include/xyssl/ssl_conf.h
include/xyssl/timing.h
include/xyssl/x509.h
@dirrm include/xyssl