aboutsummaryrefslogtreecommitdiff
path: root/security/yassl
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2013-04-29 22:30:01 +0000
committerJohan van Selst <johans@FreeBSD.org>2013-04-29 22:30:01 +0000
commit341aabf49fccb8893b7c28e903b69fd73093d650 (patch)
treed0ed592c9b368a0d58c7407ac38acf50fe7465d6 /security/yassl
parent9ff06b3cbf038359059e40e0db31ba0cbe996d0f (diff)
downloadports-341aabf49fccb8893b7c28e903b69fd73093d650.tar.gz
ports-341aabf49fccb8893b7c28e903b69fd73093d650.zip
Notes
Diffstat (limited to 'security/yassl')
-rw-r--r--security/yassl/Makefile12
-rw-r--r--security/yassl/distinfo4
-rw-r--r--security/yassl/pkg-plist33
3 files changed, 29 insertions, 20 deletions
diff --git a/security/yassl/Makefile b/security/yassl/Makefile
index 86052b75d967..05bc7600f92e 100644
--- a/security/yassl/Makefile
+++ b/security/yassl/Makefile
@@ -1,12 +1,12 @@
# $FreeBSD$
PORTNAME= cyassl
-PORTVERSION= 2.5.0
+PORTVERSION= 2.6.0
CATEGORIES= security devel
MASTER_SITES= http://www.yassl.com/
MAINTAINER= johans@FreeBSD.org
-COMMENT= A embedded SSL C-Library
+COMMENT= Embedded SSL C-Library
LICENSE= GPLv2
@@ -15,14 +15,18 @@ USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-dependency-tracking \
--enable-shared --enable-static \
- --enable-dtls --enable-opensslExtra --enable-ipv6
+ --enable-dtls --enable-opensslextra --enable-ipv6 \
+ --enable-dsa --enable-ecc
USE_LDCONFIG= yes
PORTDOCS= *
post-configure:
- ${REINPLACE_CMD} \
+ @${REINPLACE_CMD} \
-e 's|$${prefix}/cyassl/include|$${prefix}/include/cyassl|' \
-e 's|$${prefix}/cyassl/lib|$${prefix}/lib/cyassl|' \
${WRKSRC}/Makefile
+ # i386 assembly is broken: do not use
+ @${REINPLACE_CMD} -e 's/(TFM_X86)/(TFM_X86_BROKEN)/' \
+ ${WRKSRC}/ctaocrypt/src/asm.c
.include <bsd.port.mk>
diff --git a/security/yassl/distinfo b/security/yassl/distinfo
index 4eac311ca4ba..e851d80de27a 100644
--- a/security/yassl/distinfo
+++ b/security/yassl/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cyassl-2.5.0.zip) = 3b4ecc75cdb001d5171b127c03fd3f458bc585bfa1c19505dcf36bc239c04c2e
-SIZE (cyassl-2.5.0.zip) = 1203748
+SHA256 (cyassl-2.6.0.zip) = 87647ec18d1cea430b678272528494bd929b5b3b29ae7549af8065644103d602
+SIZE (cyassl-2.6.0.zip) = 1277590
diff --git a/security/yassl/pkg-plist b/security/yassl/pkg-plist
index 30f6c17405d5..f76540fdf215 100644
--- a/security/yassl/pkg-plist
+++ b/security/yassl/pkg-plist
@@ -2,7 +2,7 @@ bin/cyassl-config
lib/libcyassl.a
lib/libcyassl.la
lib/libcyassl.so
-lib/libcyassl.so.4
+lib/libcyassl.so.5
include/cyassl/openssl/asn1.h
include/cyassl/openssl/bio.h
include/cyassl/openssl/bn.h
@@ -11,8 +11,8 @@ include/cyassl/openssl/crypto.h
include/cyassl/openssl/des.h
include/cyassl/openssl/dh.h
include/cyassl/openssl/dsa.h
-include/cyassl/openssl/ecdsa.h
include/cyassl/openssl/ec.h
+include/cyassl/openssl/ecdsa.h
include/cyassl/openssl/engine.h
include/cyassl/openssl/err.h
include/cyassl/openssl/evp.h
@@ -20,7 +20,6 @@ include/cyassl/openssl/hmac.h
include/cyassl/openssl/lhash.h
include/cyassl/openssl/md4.h
include/cyassl/openssl/md5.h
-include/cyassl/openssl/ripemd.h
include/cyassl/openssl/ocsp.h
include/cyassl/openssl/opensslconf.h
include/cyassl/openssl/opensslv.h
@@ -28,6 +27,7 @@ include/cyassl/openssl/ossl_typ.h
include/cyassl/openssl/pem.h
include/cyassl/openssl/pkcs12.h
include/cyassl/openssl/rand.h
+include/cyassl/openssl/ripemd.h
include/cyassl/openssl/rsa.h
include/cyassl/openssl/sha.h
include/cyassl/openssl/ssl.h
@@ -39,8 +39,12 @@ include/cyassl/ctaocrypt/aes.h
include/cyassl/ctaocrypt/arc4.h
include/cyassl/ctaocrypt/asn.h
include/cyassl/ctaocrypt/asn_public.h
+include/cyassl/ctaocrypt/blake2-impl.h
+include/cyassl/ctaocrypt/blake2-int.h
+include/cyassl/ctaocrypt/blake2.h
include/cyassl/ctaocrypt/camellia.h
include/cyassl/ctaocrypt/coding.h
+include/cyassl/ctaocrypt/compress.h
include/cyassl/ctaocrypt/des3.h
include/cyassl/ctaocrypt/dh.h
include/cyassl/ctaocrypt/dsa.h
@@ -49,37 +53,38 @@ include/cyassl/ctaocrypt/error.h
include/cyassl/ctaocrypt/hc128.h
include/cyassl/ctaocrypt/hmac.h
include/cyassl/ctaocrypt/integer.h
+include/cyassl/ctaocrypt/logging.h
include/cyassl/ctaocrypt/md2.h
include/cyassl/ctaocrypt/md4.h
include/cyassl/ctaocrypt/md5.h
+include/cyassl/ctaocrypt/memory.h
include/cyassl/ctaocrypt/misc.h
+include/cyassl/ctaocrypt/mpi_class.h
+include/cyassl/ctaocrypt/mpi_superclass.h
include/cyassl/ctaocrypt/pwdbased.h
include/cyassl/ctaocrypt/rabbit.h
include/cyassl/ctaocrypt/random.h
include/cyassl/ctaocrypt/ripemd.h
include/cyassl/ctaocrypt/rsa.h
include/cyassl/ctaocrypt/settings.h
+include/cyassl/ctaocrypt/sha.h
include/cyassl/ctaocrypt/sha256.h
include/cyassl/ctaocrypt/sha512.h
-include/cyassl/ctaocrypt/sha.h
include/cyassl/ctaocrypt/tfm.h
include/cyassl/ctaocrypt/types.h
include/cyassl/ctaocrypt/visibility.h
-include/cyassl/ctaocrypt/logging.h
-include/cyassl/ctaocrypt/memory.h
-include/cyassl/ctaocrypt/mpi_class.h
-include/cyassl/ctaocrypt/mpi_superclass.h
+include/cyassl/callbacks.h
+include/cyassl/certs_test.h
+include/cyassl/crl.h
include/cyassl/error.h
include/cyassl/internal.h
-include/cyassl/ssl.h
-include/cyassl/sniffer_error.h
+include/cyassl/ocsp.h
+include/cyassl/options.h
include/cyassl/sniffer.h
-include/cyassl/callbacks.h
-include/cyassl/certs_test.h
+include/cyassl/sniffer_error.h
+include/cyassl/ssl.h
include/cyassl/test.h
include/cyassl/version.h
-include/cyassl/ocsp.h
-include/cyassl/crl.h
@dirrm include/cyassl/openssl
@dirrm include/cyassl/ctaocrypt
@dirrm include/cyassl