aboutsummaryrefslogtreecommitdiff
path: root/security/yersinia/Makefile
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2006-07-10 16:10:59 +0000
committerStefan Eßer <se@FreeBSD.org>2006-07-10 16:10:59 +0000
commitdd6c29952121ac09c6123be273f341308ed943eb (patch)
tree327a6312de9fecbcd422ee014863f3d66a89c7e5 /security/yersinia/Makefile
parent567137897b6453e1c6289b1402df21d9504a204b (diff)
downloadports-dd6c29952121ac09c6123be273f341308ed943eb.tar.gz
ports-dd6c29952121ac09c6123be273f341308ed943eb.zip
Notes
Diffstat (limited to 'security/yersinia/Makefile')
-rw-r--r--security/yersinia/Makefile25
1 files changed, 18 insertions, 7 deletions
diff --git a/security/yersinia/Makefile b/security/yersinia/Makefile
index 40fcb65817be..df5a5e2c5d8b 100644
--- a/security/yersinia/Makefile
+++ b/security/yersinia/Makefile
@@ -13,19 +13,30 @@ MASTER_SITES= http://www.yersinia.net/download/
MAINTAINER= se@FreeBSD.org
COMMENT= Layer 2 vulnerability scanner (switches, spanning tree, 802.1q ...)
-.include <bsd.port.pre.mk>
-
BUILD_DEPENDS= libnet*>=1.1.2,1:${PORTSDIR}/net/libnet
+.if !defined(WITHOUT_GTK)
+.if exists(${X11BASE}/include/gtk-2.0/gtk/gtk.h)
+WITH_GTK= true
+.endif
+.endif
+.if defined(WITH_GTK)
+USE_GNOME+= pkgconfig gtk20
+PKGNAMESUFFIX= -gtk
+CONFLICTS= yersinia-[0-9]*
+.else
+CONFIGURE_ARGS+= --disable-gtk
+CONFLICTS= yersinia-gtk-[0-9]*
+.endif
+GNU_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
.if ${OSVERSION} < 500000
BUILD_DEPENDS+= ${LOCALBASE}/lib/libpcap.a:${PORTSDIR}/net/libpcap
.endif
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
-
-NOT_FOR_ARCHS= ia64 sparc64
+#NOT_FOR_ARCHS= ia64 sparc64
MAN8= yersinia.8
PLIST_FILES= sbin/yersinia