aboutsummaryrefslogtreecommitdiff
path: root/security/yersinia
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2006-07-10 16:10:59 +0000
committerStefan Eßer <se@FreeBSD.org>2006-07-10 16:10:59 +0000
commitdd6c29952121ac09c6123be273f341308ed943eb (patch)
tree327a6312de9fecbcd422ee014863f3d66a89c7e5 /security/yersinia
parent567137897b6453e1c6289b1402df21d9504a204b (diff)
downloadports-dd6c29952121ac09c6123be273f341308ed943eb.tar.gz
ports-dd6c29952121ac09c6123be273f341308ed943eb.zip
Notes
Diffstat (limited to 'security/yersinia')
-rw-r--r--security/yersinia/Makefile25
-rw-r--r--security/yersinia/files/patch-configure5
-rw-r--r--security/yersinia/files/patch-protocols.h10
-rw-r--r--security/yersinia/files/patch-src-ncurses-gui.c15
4 files changed, 21 insertions, 34 deletions
diff --git a/security/yersinia/Makefile b/security/yersinia/Makefile
index 40fcb65817be..df5a5e2c5d8b 100644
--- a/security/yersinia/Makefile
+++ b/security/yersinia/Makefile
@@ -13,19 +13,30 @@ MASTER_SITES= http://www.yersinia.net/download/
MAINTAINER= se@FreeBSD.org
COMMENT= Layer 2 vulnerability scanner (switches, spanning tree, 802.1q ...)
-.include <bsd.port.pre.mk>
-
BUILD_DEPENDS= libnet*>=1.1.2,1:${PORTSDIR}/net/libnet
+.if !defined(WITHOUT_GTK)
+.if exists(${X11BASE}/include/gtk-2.0/gtk/gtk.h)
+WITH_GTK= true
+.endif
+.endif
+.if defined(WITH_GTK)
+USE_GNOME+= pkgconfig gtk20
+PKGNAMESUFFIX= -gtk
+CONFLICTS= yersinia-[0-9]*
+.else
+CONFIGURE_ARGS+= --disable-gtk
+CONFLICTS= yersinia-gtk-[0-9]*
+.endif
+GNU_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
.if ${OSVERSION} < 500000
BUILD_DEPENDS+= ${LOCALBASE}/lib/libpcap.a:${PORTSDIR}/net/libpcap
.endif
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
-
-NOT_FOR_ARCHS= ia64 sparc64
+#NOT_FOR_ARCHS= ia64 sparc64
MAN8= yersinia.8
PLIST_FILES= sbin/yersinia
diff --git a/security/yersinia/files/patch-configure b/security/yersinia/files/patch-configure
index 438d4c828d20..586bfb60d54c 100644
--- a/security/yersinia/files/patch-configure
+++ b/security/yersinia/files/patch-configure
@@ -1,11 +1,12 @@
--- configure~ Sun Jun 18 17:24:36 2006
-+++ configure Sun Jun 25 11:52:30 2006
-@@ -2971,7 +2971,7 @@
++++ configure Mon Jul 10 17:43:09 2006
+@@ -2971,7 +2971,8 @@
if test -n "$GCC"; then
- CFLAGS="-O3 -Wall -g"
+# CFLAGS="-O3 -Wall -g"
++:
else
{ echo "$as_me:$LINENO: WARNING: Ouch!! Only gcc is supported..." >&5
echo "$as_me: WARNING: Ouch!! Only gcc is supported..." >&2;}
diff --git a/security/yersinia/files/patch-protocols.h b/security/yersinia/files/patch-protocols.h
deleted file mode 100644
index 302161a74ad6..000000000000
--- a/security/yersinia/files/patch-protocols.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/protocols.h~ Sun Jun 18 17:23:33 2006
-+++ src/protocols.h Sun Jun 25 11:46:35 2006
-@@ -26,6 +26,7 @@
- #define __PROTOCOLS_H__
-
- #include <pcap.h>
-+#include <sys/socket.h>
- #include <net/if.h>
-
- #ifdef SOLARIS
diff --git a/security/yersinia/files/patch-src-ncurses-gui.c b/security/yersinia/files/patch-src-ncurses-gui.c
deleted file mode 100644
index 0fc407a9964d..000000000000
--- a/security/yersinia/files/patch-src-ncurses-gui.c
+++ /dev/null
@@ -1,15 +0,0 @@
---- src/ncurses-gui.c.orig Mon Nov 14 17:49:42 2005
-+++ src/ncurses-gui.c Mon Nov 14 18:01:48 2005
-@@ -87,6 +87,12 @@
- #include "ncurses-gui.h"
-
-
-+#ifdef __FreeBSD__
-+#include <sys/param.h>
-+#if __FreeBSD_version < 500037
-+#define resize_term resizeterm
-+#endif
-+#endif
-
- /*
- * Initialization routines for the GUI