aboutsummaryrefslogtreecommitdiff
path: root/security/ykpers
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2013-01-28 07:30:11 +0000
committerJason Helfman <jgh@FreeBSD.org>2013-01-28 07:30:11 +0000
commit97fdbf5826fdebb2917a5a22eb55ad63c2c803a7 (patch)
tree23feb68b7021441befba1164268bd062997d9321 /security/ykpers
parent557f6a1d6d3bbd9a1b9c846e604a7be503c2d5c2 (diff)
downloadports-97fdbf5826fdebb2917a5a22eb55ad63c2c803a7.tar.gz
ports-97fdbf5826fdebb2917a5a22eb55ad63c2c803a7.zip
Notes
Diffstat (limited to 'security/ykpers')
-rw-r--r--security/ykpers/Makefile57
-rw-r--r--security/ykpers/distinfo2
-rw-r--r--security/ykpers/files/patch-tests-test__args__to__config.c32
-rw-r--r--security/ykpers/pkg-descr4
4 files changed, 95 insertions, 0 deletions
diff --git a/security/ykpers/Makefile b/security/ykpers/Makefile
new file mode 100644
index 000000000000..02d28736b0fc
--- /dev/null
+++ b/security/ykpers/Makefile
@@ -0,0 +1,57 @@
+# $FreeBSD$
+
+PORTNAME= ykpers
+PORTVERSION= 1.11.3
+CATEGORIES= security
+MASTER_SITES= GOOGLE_CODE
+
+MAINTAINER= matt@mjslabs.com
+COMMENT= Library and tool for personalization of Yubico's YubiKey
+
+LICENSE= BSD
+
+LIB_DEPENDS= yubikey:${PORTSDIR}/security/libyubikey
+
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+USE_PKGCONFIG= build
+
+MAN1= ykchalresp.1 \
+ ykinfo.1 \
+ ykpersonalize.1
+PLIST_FILES= bin/ykchalresp \
+ bin/ykinfo \
+ bin/ykpersonalize \
+ include/ykpers-1/ykcore.h \
+ include/ykpers-1/ykdef.h \
+ include/ykpers-1/ykpbkdf2.h \
+ include/ykpers-1/ykpers.h \
+ include/ykpers-1/ykpers-version.h \
+ include/ykpers-1/ykstatus.h \
+ lib/libykpers-1.a \
+ lib/libykpers-1.la \
+ lib/libykpers-1.so \
+ lib/libykpers-1.so.12 \
+ libdata/pkgconfig/ykpers-1.pc
+PLIST_DIRS= include/ykpers-1
+
+PROJECTHOST= yubikey-personalization
+
+MAKE_JOBS_UNSAFE=yes
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 800069
+LDFLAGS+= -L/usr/lib
+.else
+LIB_DEPENDS+= usb:${PORTSDIR}/devel/libusb
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|^pkgconfigdir = .*|pkgconfigdir = /usr/local/libdata/pkgconfig|g' \
+ ${WRKSRC}/Makefile.in
+
+regression-test: build
+ @(cd ${WRKSRC}; ${MAKE} check)
+
+.include <bsd.port.post.mk>
diff --git a/security/ykpers/distinfo b/security/ykpers/distinfo
new file mode 100644
index 000000000000..44b4c00769db
--- /dev/null
+++ b/security/ykpers/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ykpers-1.11.3.tar.gz) = 9c89fa2ffe68612d10e7d4b733372706360abddbc3e7442958023f4f6110dac6
+SIZE (ykpers-1.11.3.tar.gz) = 463589
diff --git a/security/ykpers/files/patch-tests-test__args__to__config.c b/security/ykpers/files/patch-tests-test__args__to__config.c
new file mode 100644
index 000000000000..38eae8724ec9
--- /dev/null
+++ b/security/ykpers/files/patch-tests-test__args__to__config.c
@@ -0,0 +1,32 @@
+--- tests/test_args_to_config.c.orig 2013-01-26 18:31:02.000000000 -0800
++++ tests/test_args_to_config.c 2013-01-26 18:40:07.000000000 -0800
+@@ -123,7 +123,13 @@
+ int rc;
+
+ ykp_errno = 0;
+- optind = 0; /* getopt reinit */
++
++/* Handle both GNU and BSD getopt reinit */
++#ifdef __GLIBC__
++ optind = 0;
++#else
++ optind = optreset = 1;
++#endif
+
+ /* copy version number from st into cfg */
+ assert(ykp_configure_for(cfg, 1, st) == 1);
+@@ -308,7 +314,13 @@
+ int argc = 7;
+
+ ykp_errno = 0;
+- optind = 0; /* getopt reinit */
++
++/* Handle both GNU and BSD getopt reinit */
++#ifdef __GLIBC__
++ optind = 0;
++#else
++ optind = optreset = 1;
++#endif
+
+ /* copy version number from st into cfg */
+ ykp_configure_version(cfg, st);
diff --git a/security/ykpers/pkg-descr b/security/ykpers/pkg-descr
new file mode 100644
index 000000000000..59b256883064
--- /dev/null
+++ b/security/ykpers/pkg-descr
@@ -0,0 +1,4 @@
+The YubiKey Personalization package contains a library and command line tool
+used to personalize (i.e., set a AES key) YubiKeys.
+
+WWW: https://code.google.com/p/yubikey-personalization/