aboutsummaryrefslogtreecommitdiff
path: root/security/yubikey-personalization-gui
diff options
context:
space:
mode:
authorRomain Tartière <romain@FreeBSD.org>2015-10-17 12:59:34 +0000
committerRomain Tartière <romain@FreeBSD.org>2015-10-17 12:59:34 +0000
commitf35d4877c1aa9663986d0428a99d6a6498a8e3d9 (patch)
treef889577ca5f15775261b23434b760f3346bf2051 /security/yubikey-personalization-gui
parent4e001bf38449d9d3c53669ef6af9792fbb6f1b2a (diff)
downloadports-f35d4877c1aa9663986d0428a99d6a6498a8e3d9.tar.gz
ports-f35d4877c1aa9663986d0428a99d6a6498a8e3d9.zip
Notes
Diffstat (limited to 'security/yubikey-personalization-gui')
-rw-r--r--security/yubikey-personalization-gui/Makefile28
-rw-r--r--security/yubikey-personalization-gui/distinfo2
-rw-r--r--security/yubikey-personalization-gui/pkg-descr20
3 files changed, 50 insertions, 0 deletions
diff --git a/security/yubikey-personalization-gui/Makefile b/security/yubikey-personalization-gui/Makefile
new file mode 100644
index 000000000000..7b0ed4f307b1
--- /dev/null
+++ b/security/yubikey-personalization-gui/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= yubikey-personalization-gui
+PORTVERSION= 3.1.23
+CATEGORIES= security
+
+MAINTAINER= romain@FreeBSD.org
+COMMENT= Graphical YubiKey personalization tool
+
+LICENSE= BSD2CLAUSE
+
+LIB_DEPENDS= libykpers-1.so:${PORTSDIR}/security/yubikey-personalization
+
+USE_GITHUB= yes
+GH_ACCOUNT= Yubico
+GH_TAGNAME= ${PORTNAME}-${PORTVERSION}
+
+USES= pkgconfig qmake
+USE_QT4= corelib gui moc_build rcc_build testlib_build uic_build
+
+PLIST_FILES= bin/yubikey-personalization-gui
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/build/release/yubikey-personalization-gui ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.post.mk>
diff --git a/security/yubikey-personalization-gui/distinfo b/security/yubikey-personalization-gui/distinfo
new file mode 100644
index 000000000000..89b294ada7f9
--- /dev/null
+++ b/security/yubikey-personalization-gui/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Yubico-yubikey-personalization-gui-3.1.23-yubikey-personalization-gui-3.1.23_GH0.tar.gz) = 16bdc594435a569b06a13d2e4247ac9b7ebf7405ffc41c292880022be47420c0
+SIZE (Yubico-yubikey-personalization-gui-3.1.23-yubikey-personalization-gui-3.1.23_GH0.tar.gz) = 1449889
diff --git a/security/yubikey-personalization-gui/pkg-descr b/security/yubikey-personalization-gui/pkg-descr
new file mode 100644
index 000000000000..2e8dfe4e3502
--- /dev/null
+++ b/security/yubikey-personalization-gui/pkg-descr
@@ -0,0 +1,20 @@
+The YubiKey Personalization Tool is a Qt based Cross-Platform utility designed
+to facilitate re-configuration of YubiKeys on Windows, Linux and Mac platforms.
+The tool provides a same simple step-by-step approach to make configuration of
+YubiKeys easy to follow and understand, while still being powerful enough to
+exploit all functionality both of the YubiKey 1 and YubiKey 2 generation of
+keys. The tool provides the same functionality and user interface on Windows,
+Linux and Mac platforms.
+
+The Cross-Platform YubiKey Personalization Tool provides the following main
+functions:
+ - Programming the YubiKey in "Yubico OTP" mode;
+ - Programming the YubiKey in "OATH-HOTP" mode;
+ - Programming the YubiKey in "Static Password" mode;
+ - Programming the YubiKey in "Challenge-Response" mode;
+ - Programming the NDEF feature of the YubiKey NEO;
+ - Testing the challenge-response functionality of a YubiKey;
+ - Deleting the configuration of a YubiKey;
+ - Checking type and firmware version of the YubiKey.
+
+WWW: https://github.com/Yubico/yubikey-personalization-gui