aboutsummaryrefslogtreecommitdiff
path: root/security/zebedee
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2000-02-06 21:53:04 +0000
committerKris Kennaway <kris@FreeBSD.org>2000-02-06 21:53:04 +0000
commit0732e1763ffd775163fbf1128e5c56607f27d98a (patch)
tree4232f7a211129131f36f8692432432aa6bf6ac03 /security/zebedee
parent5da30313e5e0daddb96c75d4d1c16a5d706f715f (diff)
downloadports-0732e1763ffd775163fbf1128e5c56607f27d98a.tar.gz
ports-0732e1763ffd775163fbf1128e5c56607f27d98a.zip
Notes
Diffstat (limited to 'security/zebedee')
-rw-r--r--security/zebedee/Makefile5
-rw-r--r--security/zebedee/files/patch-aa32
2 files changed, 25 insertions, 12 deletions
diff --git a/security/zebedee/Makefile b/security/zebedee/Makefile
index 8364b7873bda..65664d1dff9c 100644
--- a/security/zebedee/Makefile
+++ b/security/zebedee/Makefile
@@ -13,10 +13,9 @@ MASTER_SITES= http://www.winton.org.uk/zebedee/ \
MAINTAINER= greg@hewgill.com
-BUILD_DEPENDS= ${LOCALBASE}/include/openssl/blowfish.h:${PORTSDIR}/security/openssl \
- ${LOCALBASE}/lib/libcrypto.a:${PORTSDIR}/security/openssl \
- ${LOCALBASE}/lib/libbz2.a:${PORTSDIR}/archivers/bzip2
+BUILD_DEPENDS= ${LOCALBASE}/lib/libbz2.a:${PORTSDIR}/archivers/bzip2
+USE_OPENSSL= NORSA
USE_PERL5= yes
MAN1= zebedee.1 ftpgw.tcl.1
diff --git a/security/zebedee/files/patch-aa b/security/zebedee/files/patch-aa
index 0d7e189d9688..b1ecc24ca32f 100644
--- a/security/zebedee/files/patch-aa
+++ b/security/zebedee/files/patch-aa
@@ -1,5 +1,5 @@
---- ../zebedee-1.3.0.orig/Makefile Fri Jan 21 13:47:17 2000
-+++ Makefile Sat Jan 22 19:15:21 2000
+--- Makefile.orig Fri Jan 21 13:47:17 2000
++++ Makefile Sat Feb 5 23:59:19 2000
@@ -3,7 +3,7 @@
#
# $Id: Makefile,v 1.10 2000/01/21 21:46:41 nwinton Exp nwinton $
@@ -9,15 +9,19 @@
###
### Locations of tools, libraries and installation directories.
-@@ -17,6 +17,7 @@
+@@ -17,33 +17,34 @@
CC_win32 = /gcc-2.95/bin/gcc
CC_linux = gcc
CC_solaris = gcc
+-CC = $(CC_$(OS))
+CC_freebsd = cc
- CC = $(CC_$(OS))
++CC ?= $(CC_$(OS))
# Optimise/debug compilation
-@@ -26,24 +27,24 @@
+
+ #OPTIM = -Wall -g
+-OPTIM = -Wall -O
++OPTIM = -Wall
# Location of gmp include and library
@@ -30,8 +34,8 @@
-BFINC = -I../blowfish
-BFLIB = ../blowfish/libblowfish.a
-+BFINC = -I${PREFIX}/include/openssl
-+BFLIB = ${PREFIX}/lib/libcrypto.a
++BFINC = -I${OPENSSLINC} -I${OPENSSLINC}/openssl
++BFLIB = ${OPENSSLLIB}/libcrypto.a
# Location of zlib include and library
@@ -45,8 +49,8 @@
-BZINC = -I../bzip2-0.9.5d
-BZLIB = ../bzip2-0.9.5d/libbz2.a
-+BZINC = -I${PREFIX}/include
-+BZLIB = ${PREFIX}/lib/libbz2.a
++BZINC = -I${LOCALBASE}/include
++BZLIB = ${LOCALBASE}/lib/libbz2.a
#
# Tools needed for Perl "POD"-format documentation conversion.
#
@@ -66,3 +70,13 @@
OSLIBS_solaris = -lsocket -lnsl -lthread # Solaris
OSLIBS = $(OSLIBS_$(OS))
+@@ -116,7 +119,8 @@
+ #### You REALLY shouldn't have to modify anything beyond here ...
+ ####
+
+-CFLAGS = $(OPTIM) $(DEFINES) -I. $(GMPINC) $(BFINC) $(ZINC) $(BZINC)
++CFLAGS ?= -O
++CFLAGS += $(OPTIM) $(DEFINES) -I. $(GMPINC) $(BFINC) $(ZINC) $(BZINC)
+
+ LIBS = $(GMPLIB) $(BFLIB) $(ZLIB) $(BZLIB) $(OSLIBS)
+