aboutsummaryrefslogtreecommitdiff
path: root/security/zenmap
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>1998-08-04 17:59:51 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>1998-08-04 17:59:51 +0000
commitf896e54ddc30650268d4ca96719170d777b10bb0 (patch)
tree1f29c94ca073b927403ac070feacf996ccc2f78d /security/zenmap
parent45881298b1cfafdfd000f56944735b44d7295d82 (diff)
downloadports-f896e54ddc30650268d4ca96719170d777b10bb0.tar.gz
ports-f896e54ddc30650268d4ca96719170d777b10bb0.zip
Notes
Diffstat (limited to 'security/zenmap')
-rw-r--r--security/zenmap/Makefile23
-rw-r--r--security/zenmap/distinfo1
-rw-r--r--security/zenmap/files/nmap.187
-rw-r--r--security/zenmap/pkg-comment1
-rw-r--r--security/zenmap/pkg-descr12
-rw-r--r--security/zenmap/pkg-plist2
6 files changed, 126 insertions, 0 deletions
diff --git a/security/zenmap/Makefile b/security/zenmap/Makefile
new file mode 100644
index 000000000000..0247f07d251f
--- /dev/null
+++ b/security/zenmap/Makefile
@@ -0,0 +1,23 @@
+# ex:ts=8
+# Ports collection makefile for: nmap
+# Version required: 1.51
+# Date created: Tue Aug 04, 1998
+# Whom: David O'Brien (obrien@NUXI.com)
+#
+# $Id: Makefile,v 1.2 1997/01/25 18:08:40 obrien Exp $
+#
+
+DISTNAME= nmap-1.51
+CATEGORIES= security
+MASTER_SITES= http://www.insecure.org/nmap/
+
+MAINTAINER= obrien@FreeBSD.org
+
+GNU_CONFIGURE= yes
+MAN1= nmap.1
+
+post-install:
+ @strip ${PREFIX}/bin/nmap
+ @${INSTALL_MAN} ${FILESDIR}/nmap.1 ${PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/security/zenmap/distinfo b/security/zenmap/distinfo
new file mode 100644
index 000000000000..ed2e8d80b962
--- /dev/null
+++ b/security/zenmap/distinfo
@@ -0,0 +1 @@
+MD5 (nmap-1.51.tar.gz) = 1a5e2d4fbc455120a581c1bd68dbd9d7
diff --git a/security/zenmap/files/nmap.1 b/security/zenmap/files/nmap.1
new file mode 100644
index 000000000000..091ef06c37dc
--- /dev/null
+++ b/security/zenmap/files/nmap.1
@@ -0,0 +1,87 @@
+.\"
+.\" Copyright (c) 1998 David E. O'Brien
+.\"
+.\" All rights reserved.
+.\"
+.\" Redistribution and use in source and binary forms, with or without
+.\" modification, are permitted provided that the following conditions
+.\" are met:
+.\" 1. Redistributions of source code must retain the above copyright
+.\" notice, this list of conditions and the following disclaimer.
+.\" 2. Redistributions in binary form must reproduce the above copyright
+.\" notice, this list of conditions and the following disclaimer in the
+.\" documentation and/or other materials provided with the distribution.
+.\"
+.\" THIS SOFTWARE IS PROVIDED BY THE DEVELOPERS ``AS IS'' AND ANY EXPRESS OR
+.\" IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
+.\" OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.
+.\" IN NO EVENT SHALL THE DEVELOPERS BE LIABLE FOR ANY DIRECT, INDIRECT,
+.\" INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT
+.\" NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+.\" DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+.\" THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+.\" (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF
+.\" THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+.\"
+.\" $Id$
+.\"
+.\" .TH NMAP 1L local
+.Dd August 4, 1998
+.Dt NMAP 1
+.Os BSD
+.Sh NAME
+.Nm nmap
+.Nd network port scanner
+.Sh SYNOPSIS
+.Nm nmap
+.Op Ar options
+.Ar hostname
+.Op Ar /mask
+.Sh DESCRIPTION
+.Nm
+is a utility for port scanning large networks, although it works fine for
+single hosts. The guiding philosophy for the creation of
+.Nm
+was TMTOWTDI (There's More Than One Way To Do It). This is the Perl slogan, but
+it is equally applicable to scanners. Sometimes you need speed, other times you
+may need stealth. In some cases, bypassing firewalls may be required. Not to
+mention the fact that you may want to scan different protocols (UDP, TCP, ICMP,
+etc.). You just can't do all this with one scanning mode. And you don't want to
+have 10 different scanners around, all with different interfaces and
+capabilities. Thus
+.Nm
+incorporats virtually every scanning technique known.
+Specifically,
+.Nm
+supports:
+
+ Vanilla TCP connect() scanning,
+ TCP SYN (half open) scanning,
+ TCP FIN (stealth) scanning,
+ TCP ftp proxy (bounce attack) scanning
+ SYN/FIN scanning using IP fragments (bypasses packet filters),
+ UDP recvfrom() scanning,
+ UDP raw ICMP port unreachable scanning,
+ ICMP scanning (ping-sweep), and
+ Reverse-ident scanning.
+
+.Nm
+also supports a number of performance and reliability features such as dynamic
+delay time calculations, packet timeout and retransmission, parallel port
+scanning, detection of down hosts via parallel pings, and flexible target and
+port specification.
+.Sh FILES
+none.
+.Sh SEE ALSO
+.Xr mscan 1L ,
+.Xr nc 1L ,
+.Xr scrobe 1L
+.Sh DIAGNOSTICS
+none.
+.Sh BUGS
+none known.
+.Sh AUTHORS
+This man page has been written by David O'Brien (obrien@cs.ucdavis.edu)
+.\" .Sh HISTORY
+.\" .Nm
+.\" appeared in FreeBSD 3.0.
diff --git a/security/zenmap/pkg-comment b/security/zenmap/pkg-comment
new file mode 100644
index 000000000000..3ef3521f9352
--- /dev/null
+++ b/security/zenmap/pkg-comment
@@ -0,0 +1 @@
+port scanning utility for large networks
diff --git a/security/zenmap/pkg-descr b/security/zenmap/pkg-descr
new file mode 100644
index 000000000000..c77e677a1b2e
--- /dev/null
+++ b/security/zenmap/pkg-descr
@@ -0,0 +1,12 @@
+nmap is a utility for port scanning large networks, although it works fine
+for single hosts. The guiding philosophy for the creation of nmap was TMTOWTDI
+(There's More Than One Way To Do It). Sometimes you need speed, other times
+you may need stealth. In some cases, bypassing firewalls may be required. Not
+to mention the fact that you may want to scan different protocols (UDP, TCP,
+ICMP, etc.). You just can't do all this with one scanning mode. Thus nmap
+incorporats virtually every scanning technique known of.
+
+See the nmap homepage at http://www.insecure.org/nmap/index.html
+
+-- David
+ obrien@cs.ucdavis.edu
diff --git a/security/zenmap/pkg-plist b/security/zenmap/pkg-plist
new file mode 100644
index 000000000000..8f498c525c38
--- /dev/null
+++ b/security/zenmap/pkg-plist
@@ -0,0 +1,2 @@
+bin/nmap
+man/man1/nmap.1.gz